Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problema automount usb da utente normale
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ChobinYY
Apprentice
Apprentice


Joined: 23 Mar 2006
Posts: 156

PostPosted: Wed Jan 05, 2011 11:00 pm    Post subject: problema automount usb da utente normale Reply with quote

Ciao a tutti.

Ho un problemino. La penna usb viene montata senza problemi dall'utente root, ma con un normale utente mi dice che non è possibile montarla perché non sono autorizzato.
Penso sia un problema di permessi, ma purtroppo non so come risolvere. Ho fatto un pò di ricerche ma non sono riuscito a risolvere il problemino.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Thu Jan 06, 2011 9:44 am    Post subject: Reply with quote

hai controllato di essere nei gruppi necessari?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Thu Jan 06, 2011 11:14 am    Post subject: Reply with quote

Quote:

hai controllato di essere nei gruppi necessari?


si, tipo wheel e udev e hal ( se lo usi ).

Posta anche l'output di mtab in modo da poter vedere con quali use flag è montata!
_________________
Pygoscelis papua, chiamato Gentoo dagli abitanti delle isole Falkland/Malvinas, noto per essere il pinguino più veloce!!! XD
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Jan 06, 2011 1:56 pm    Post subject: Re: problema automount usb da utente normale Reply with quote

ChobinYY wrote:
penna usb
La sfera di cristallo mi suggerisce le seguenti opzioni: mancata aggiunta al gruppo disk, mancata impostazione della use suid (mai globale!) per ntfs3g o mancato uso di sudo (come da vecchio wiki).

Tra l'altro usi hal, udev o fstab/mount? Non lo ho capito.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
dursino
Tux's lil' helper
Tux's lil' helper


Joined: 26 Feb 2010
Posts: 83

PostPosted: Thu Jan 06, 2011 2:15 pm    Post subject: Reply with quote

Vorrei una precisazione, se io in /etc/fstab metto l'opzione no-auto di regola non dovrebbe esserci l'automount.
Invece appena inserisco la periferica usb viene montata ma nella directory specificata in fstab.
E' hal che comanda o chi?comunque viene letto fstab sennò non poteva 'indovinare' la directory.
Per usare dispositivi usb quale gruppo è fondamentale? Ho visto in /etc/groups che c'è usb ma non credo sia quello.
grazie
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Thu Jan 06, 2011 4:02 pm    Post subject: Reply with quote

Quote:

Vorrei una precisazione, se io in /etc/fstab metto l'opzione no-auto di regola non dovrebbe esserci l'automount.
Invece appena inserisco la periferica usb viene montata ma nella directory specificata in fstab


L'opzione è noauto senza trattino, guarda nel manuale c'è scritto quello che dici tu :
Quote:

noauto Can only be mounted explicitly (i.e., the -a option will not
cause the filesystem to be mounted).


Credo, che dipenda tutto da hal se c'è l'hai attivo, perchè lui va a vedere nelle sue regole come montarlo no.

Leggendo l'ebuild di hal si trova questo a riguardo dei gruppi di hal :
Code:


## HAL Daemon drops privledges so we need group access to read disks
HALDAEMON_GROUPS_LINUX="haldaemon,plugdev,disk,cdrom,cdrw,floppy,usb"

    # Create groups for hotplugging and HAL
    enewgroup haldaemon
    enewgroup plugdev

    # HAL drops priviledges by default now ...
    # ... so we must make sure it can read disk/cdrom info (ie. be in ${HALDAEMON_GROUPS} groups)
    if use kernel_linux; then
        enewuser haldaemon -1 "-1" /dev/null ${HALDAEMON_GROUPS_LINUX}
    elif use kernel_FreeBSD; then
        enewuser haldaemon -1 "-1" /dev/null ${HALDAEMON_GROUPS_FREEBSD}
    fi

    # Make sure that the haldaemon user is in the ${HALDAEMON_GROUPS}
    # If users have a problem with this, let them file a bug
    if [[ ${ROOT} == / ]] ; then
        if use kernel_linux; then
            usermod -G ${HALDAEMON_GROUPS_LINUX} haldaemon
        elif use kernel_FreeBSD; then
            pw usermod haldaemon -G ${HALDAEMON_GROUPS_FREEBSD}
        fi
    fi


Senza hal, quello che monta le penne è udev e in quel caso la regole per il montaggio sono nei rules di udev....
_________________
Pygoscelis papua, chiamato Gentoo dagli abitanti delle isole Falkland/Malvinas, noto per essere il pinguino più veloce!!! XD
Back to top
View user's profile Send private message
ChobinYY
Apprentice
Apprentice


Joined: 23 Mar 2006
Posts: 156

PostPosted: Thu Jan 06, 2011 7:35 pm    Post subject: Reply with quote

Allora uso hal

i gruppi dell'utente normale sono:
Code:
wheel usb users plugdev peppe


non è presente nessun gruppo disk
Back to top
View user's profile Send private message
ChobinYY
Apprentice
Apprentice


Joined: 23 Mar 2006
Posts: 156

PostPosted: Thu Jan 06, 2011 7:40 pm    Post subject: Reply with quote

Dimenticavo di dire una cosa importante, a me interessa che si monti da sola in gnome.
No via shell. questo avviene quando entro in gnome come root, ma con utente normale mi spunta la finestra dove mi dice che non è impossibile montare perché non sono autorizzato
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Thu Jan 06, 2011 7:49 pm    Post subject: Reply with quote

Prova ad iscriverti al gruppo haldaemon.....
_________________
Pygoscelis papua, chiamato Gentoo dagli abitanti delle isole Falkland/Malvinas, noto per essere il pinguino più veloce!!! XD
Back to top
View user's profile Send private message
ChobinYY
Apprentice
Apprentice


Joined: 23 Mar 2006
Posts: 156

PostPosted: Thu Jan 06, 2011 8:02 pm    Post subject: Reply with quote

ho inserito l'utente nel gruppo haldaemon ma purtroppo gnome mi da lo stesso messaggio
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Thu Jan 06, 2011 10:03 pm    Post subject: Reply with quote

Dai uno sguardo qui e vedi se ti può essere d'aiuto:
https://wiki.archlinux.org/index.php/HAL#Install_and_configure_HAL

Non so, ma eliminare hal è usare solo udev con xorg > 1.8 ???? :P :P :P :P
_________________
Pygoscelis papua, chiamato Gentoo dagli abitanti delle isole Falkland/Malvinas, noto per essere il pinguino più veloce!!! XD
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Jan 07, 2011 10:46 am    Post subject: Reply with quote

voi scimmiacce dovreste potere (da prender sempre con beneficio d'inventario detesto gnome e non lo conosco a fondo), basta impostare globalmente -hal e mettere la regola di udev per l'automount e farlo fare al sistema o cercare la guida per l'automount su gnome ma credo che in questo caso, se vuoi mantenere hal, l'utente debbba essere aggiunto ai gruppi haldaemon,plugdev,disk,cdrom,cdrw,floppy,usb e non devi avere nulla in fstab in relazione ai device usb (o viceversa se ti interessa montare automaticamente una determinata unità in un determinato punto).

Ripeto però che quanto detto vale per il filesystem supportati dal kernel, se si parla di ntfs3g o di altri supportati da fuse si aggiunge il problema dei permessi.

Quindi caro il mio ometto verde e peloso spiega bene qual è l'obiettivo, la sfera di cristallo il nipotino me la ha scassata da diverso tempo e tirare ad indovinare porta solo ulteriori perdite di tempo a tutti noi.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Fri Jan 07, 2011 2:30 pm    Post subject: Reply with quote

ChobinYY wrote:
ho inserito l'utente nel gruppo haldaemon ma purtroppo gnome mi da lo stesso messaggio


Ma hald è avviato?

Il fatto che Xorg 1.9 non usi hal non vuol dire che deve essere eliminato; almeno in kde-4.4.5 ce n'è ancora bisogno..non so su gnome quale sia la situazione.
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Pes88
Apprentice
Apprentice


Joined: 06 May 2009
Posts: 243

PostPosted: Fri Jan 07, 2011 4:55 pm    Post subject: Reply with quote

Quote:

Il fatto che Xorg 1.9 non usi hal non vuol dire che deve essere eliminato; almeno in kde-4.4.5 ce n'è ancora bisogno..non so su gnome quale sia la situazione.


Su kde-4.4.5 necessità ancora di hal, già con il 4.5 , ci sono meno dipendenze, ma dovrebbe essere eliminato completamente dalla 4.6 ( speriamo ) :D :D :D :D

Gnome funziona già senza hal, io non sono un esperto di gnome ma sul mio sistema funziona è non ho hal [/quote]....
_________________
Pygoscelis papua, chiamato Gentoo dagli abitanti delle isole Falkland/Malvinas, noto per essere il pinguino più veloce!!! XD
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Jan 07, 2011 10:51 pm    Post subject: Reply with quote

io con gnome (2.32) non ho problemi senza hal.
Ho risolto aggiungendo il mio utente al gruppo messagebus, controlla il file ~/.xsession-errors se hai errori relativi a d-bus e nel caso aggiungiti.

Per completezza questi sono i miei gruppi
Code:
$ groups
disk wheel audio cdrom video games postgres cdrw usb users tomcat messagebus plugdev samba wireshark

_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum