Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo su MacBook Pro 5,3 e problemi irrisolti
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
oxonian
n00b
n00b


Joined: 05 Jan 2011
Posts: 3

PostPosted: Wed Jan 05, 2011 8:46 pm    Post subject: Gentoo su MacBook Pro 5,3 e problemi irrisolti Reply with quote

Ciao a tutti,

sono nuovo nel forum ma è da tempo che lo seguo. Utilizzo Gentoo da poco anche se in passato ho usato molto Ubuntu.
Ho deciso di passare a Gentoo perchè voglio una distribuzione che mi forzi a capire come funziona Linux e mi piace molto il suo approccio source-based.
Ho un MacBook Pro 5,3 e dopo alcuni giorni sono riuscito a compilare il sitema base e anche Gnome.
Tuttavia ho molti problimi irrisolti. Premetto che ho usato google e i wiki di gentoo e il forum in maniera estensiva ed alcune cose le ho risolte da me ma su altre non ho idea di come fare.

I problemi principali sono questi:

1. non funziona il backlight della tastiera
2. non riesco neppure a regolare la luminosità dello schermo
2. non funziona il sensore della luminosità
4. non ho ben capito come funziona il server Hal (non dovrebbe lui regolare tutte queste funzioni??)
3. quando uso un user non root, non riesco ad avviare Gnome con il comando startx e ottengo il seguente errore:

Quote:
xauth: file /home/ale/.serverauth.6296 does not exist
xauth: timeout in locking authority file /root/.Xauthority
xauth: timeout in locking authority file /root/.Xauthority
xauth: timeout in locking authority file /root/.Xauthority
xauth: timeout in locking authority file /root/.Xauthority



Premetto che ho seguito la guida relativa ai macbook e ho configurato il kernel in maniera conforme (almeno cosi mi sembra..)
Ho letto che molte di queste funzioni sono regolate dal componente Apple SMC che risulta caricato dal kernel.

Per Hal invece non saprei.... non so come funziona.. Ad esempio ho tentato di far funzionare il comando Ctrl-Alt-Bkspc per fare il crash di X e, seguendo sempre la guida gentoo, ho inserito nel file 10-x11-input.fdi la seguente stringa poi ho riavviato[/quote] hald ma nulla, se premo i tre tasti non succede nulla:

Quote:
<merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>


Scusate i tanti problemi sollevati in un unico thread. Non sono espertissimo e quindi mi rivolgo a voi!

Grazie
Back to top
View user's profile Send private message
oxonian
n00b
n00b


Joined: 05 Jan 2011
Posts: 3

PostPosted: Wed Jan 05, 2011 9:07 pm    Post subject: Reply with quote

piccolo update:

X e GNome vanno ache con un altro user avevo dimenticato di configurare startx in modo che avvii direttamente gnome.
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sun Jan 09, 2011 2:21 am    Post subject: Re: Gentoo su MacBook Pro 5,3 e problemi irrisolti Reply with quote

oxonian wrote:
Ciao a tutti,
1. non funziona il backlight della tastiera
2. non riesco neppure a regolare la luminosità dello schermo

Beh, o non è supportato, oppure potrebbe aver bisogno di qualche modulo specifico. Per sapere se hai sbagliato nel kernel, basta che guardi se su Ubuntu funziona. Poi fai lsmod e vai a vedere cosa non hai messo.

Quote:

2. non funziona il sensore della luminosità

Vedi sopra

Quote:

4. non ho ben capito come funziona il server Hal (non dovrebbe lui regolare tutte queste funzioni??)

In realtà è deprecato, e presto verrà rimosso. Il suo lavoro passa a udev. In ogni caso, senza la use hal i programmi non gli chiederanno nulla.

Quote:

Premetto che ho seguito la guida relativa ai macbook e ho configurato il kernel in maniera conforme (almeno cosi mi sembra..)
Ho letto che molte di queste funzioni sono regolate dal componente Apple SMC che risulta caricato dal kernel.
Magari si appoggia anche su qualche tool in userland... E magari c'è qualche use da abilitare pure per lui.

Quote:

Per Hal invece non saprei.... non so come funziona.. Ad esempio ho tentato di far funzionare il comando Ctrl-Alt-Bkspc per fare il crash di X e, seguendo sempre la guida gentoo, ho inserito nel file 10-x11-input.fdi la seguente stringa poi ho riavviato
hald ma nulla, se premo i tre tasti non succede nulla:
[/quote]
Beh, se X non lo compili con la use hal è probabile che lo ignori... Ma dato che hal se ne sta andando è consigliabile togliere la use hal e farlo fare a xorg.conf.
Ti dò una dritta: alt+sysrq+k non farà esattamente quello, ma il risultato è simile.
http://en.wikipedia.org/wiki/Magic_SysRq_key
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Sun Jan 09, 2011 9:44 am    Post subject: Re: Gentoo su MacBook Pro 5,3 e problemi irrisolti Reply with quote

oxonian wrote:

1. non funziona il backlight della tastiera
2. non riesco neppure a regolare la luminosità dello schermo

In portage è presente macbook-backlight hai provato ad installarlo?
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
oxonian
n00b
n00b


Joined: 05 Jan 2011
Posts: 3

PostPosted: Sun Jan 09, 2011 8:57 pm    Post subject: Reply with quote

in questi giorni mi sono dato un occhiata a varie documentazione e ho scoperto che Hal è sconsigliato dalla versione 1.8 di Xorg.

Per il resto il backlight funziona scaricando Pommed ma ancora non riesco a regolare la luminosità dello schermo, cosa che mi preme di più visto che di solito la metto al minimo.

Apple SMC ho testato che funziona, infatti andando nella cartella Devices e modificando i parametri di SMC manualmente (es il fan control) ho notato che vi è risposta dal pc.


Per la luminosità dello schermo sono arrivato alla conclusione che si tratti della scheda video... In molti post ho visto che viene regolata direttamente dalla scheda nvidia, con i quale sto avendo molti problemi di configurazione. Ora vedo di concentrarmi su questo..
il pc ha due schede una Geforce 9600M GT e una 9400M. Ho tentato di usare i driver nouveau (visto che il mio obiettivo era di usare tutti software open-source) ma appena avvio il pc dopo grub2 lo schermo diventa nero e non vedo nemmeno il loading del kernel. So che i nouveau sono incompatibile con il framebuffer video che ho disattivato ricompilando il kernel, ma nulla...
Back to top
View user's profile Send private message
luca120
n00b
n00b


Joined: 10 Jun 2009
Posts: 54

PostPosted: Mon Jan 10, 2011 9:06 pm    Post subject: Reply with quote

oxonian wrote:
in questi giorni mi sono dato un occhiata a varie documentazione e ho scoperto che Hal è sconsigliato dalla versione 1.8 di Xorg.

Per il resto il backlight funziona scaricando Pommed ma ancora non riesco a regolare la luminosità dello schermo, cosa che mi preme di più visto che di solito la metto al minimo.

Apple SMC ho testato che funziona, infatti andando nella cartella Devices e modificando i parametri di SMC manualmente (es il fan control) ho notato che vi è risposta dal pc.


Per la luminosità dello schermo sono arrivato alla conclusione che si tratti della scheda video... In molti post ho visto che viene regolata direttamente dalla scheda nvidia, con i quale sto avendo molti problemi di configurazione. Ora vedo di concentrarmi su questo..
il pc ha due schede una Geforce 9600M GT e una 9400M. Ho tentato di usare i driver nouveau (visto che il mio obiettivo era di usare tutti software open-source) ma appena avvio il pc dopo grub2 lo schermo diventa nero e non vedo nemmeno il loading del kernel. So che i nouveau sono incompatibile con il framebuffer video che ho disattivato ricompilando il kernel, ma nulla...


guarda io ho installato 2 volte gentoo su i due miei pc e tutte due volte quando davo il comando startx non partiva una bega, allora per sfizio ho provato a dare il comando gdm e stranamente funziona TUTTO :):):) non ho mai capito il xke :) prova anche te
Back to top
View user's profile Send private message
0pipe0
n00b
n00b


Joined: 09 Oct 2009
Posts: 43

PostPosted: Fri Jan 14, 2011 3:46 pm    Post subject: Reply with quote

allora:

installa gdm, poi configura /etc/conf.d/xdm e aggiungi xdm nel runlevel default.. così all'avvio il server X magicamente partirà :) ...

per lo scermo io ho usato i driver nvidia proprietari che non supportano l'illuminazione; però esite un pacchetto che si chiama nvidia-bl, compila ed aggiungi il modulo con modprobe. (dovrai aggiungerlo in /etc/conf.d/modules se vuoi farlo caricare all'avvio) .
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum