Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge --sync downloading entire portage tree
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
xiber
Apprentice
Apprentice


Joined: 28 Oct 2003
Posts: 245
Location: Fremont, CA

PostPosted: Tue Feb 08, 2011 5:24 am    Post subject: emerge --sync downloading entire portage tree Reply with quote

Any reason (today) why emerge --sync want to download the entire portage tree?

Looking around, and it seems that all the recent timestamps have jumped back-in-time by a few minutes. Any idea whats going on?
_________________
Athlon XP-M 2600 @ 2.3 GHz OC | Abit NF7-S r2.0 | 2x512MB PC3200 | 6600GT OC | Audigy 2 | Gentoo | 2005

Athlon 64 X2 4600 @ 2.4 GHz | Asus M2N-SLI DLX | 4x1GB PC6400 | 7600GT KO | 7HD @ 3.1TB | OpenSolaris SXCE | 2007
Back to top
View user's profile Send private message
mno
Guru
Guru


Joined: 29 Dec 2003
Posts: 452
Location: Toronto, Canada

PostPosted: Tue Feb 08, 2011 6:03 am    Post subject: Reply with quote

Seems like there have been a number of moves and changes in the tree that are silently absorbed by portage.
_________________
"Hello and goodbye. As always." | You can't use   here?? | Unanswered
Back to top
View user's profile Send private message
xiber
Apprentice
Apprentice


Joined: 28 Oct 2003
Posts: 245
Location: Fremont, CA

PostPosted: Tue Feb 08, 2011 6:14 am    Post subject: Reply with quote

From what I can find, I've just spent the last 20min downloading the entire portage tree because of timestamp changes, not actual file changes. That seems, well, wrong.
_________________
Athlon XP-M 2600 @ 2.3 GHz OC | Abit NF7-S r2.0 | 2x512MB PC3200 | 6600GT OC | Audigy 2 | Gentoo | 2005

Athlon 64 X2 4600 @ 2.4 GHz | Asus M2N-SLI DLX | 4x1GB PC6400 | 7600GT KO | 7HD @ 3.1TB | OpenSolaris SXCE | 2007
Back to top
View user's profile Send private message
ToeiRei
Veteran
Veteran


Joined: 03 Jan 2005
Posts: 1180
Location: Austria

PostPosted: Tue Feb 08, 2011 7:15 am    Post subject: Reply with quote

that's rsync in our case. Hope this doesn't happen too often.
In case you want to speed up things, always feel free to do a emerge-webrsync which will download a portage snapshot first
_________________
Please stand by - The mailer daemon is busy burning your messages in hell...
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue Feb 08, 2011 9:06 am    Post subject: Reply with quote

There is a problem with tar-1.25 and timestamps, see bug 352254.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
XQYZ
Apprentice
Apprentice


Joined: 19 Jul 2009
Posts: 231
Location: Europe

PostPosted: Tue Feb 08, 2011 1:43 pm    Post subject: Reply with quote

I noticed it last week also. Seeing as I was halfway through downloading when I noticed it, I didn't bother to abort it thought.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9245
Location: beyond the rim

PostPosted: Tue Feb 08, 2011 3:07 pm    Post subject: Reply with quote

It's a known issue apparently caused by the move to a new master rsync server.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum