Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[X, clavier] Mauvaise configuration clavier pour X (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Tue Dec 28, 2010 12:02 pm    Post subject: [X, clavier] Mauvaise configuration clavier pour X (résolu) Reply with quote

Bonjour,

Après une mise a jour, j'ai un problème de clavier. En console, tout va bien, mais en xdm/slim et X en génral, j'ai un clavier qwerty. Je ne sais pas comment avoir un clavier azerty pour me logger (surtout avec un mot de passe qui contient ,[!). Un fois logger (5 minutes pour me logger) la commande
Code:

setxkbmap -layout fr

marche bien.

mon /etc/hal/fdi/policy/10-x11-input.fdi

Code:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <!-- FIXME: Support tablets too. -->
    <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>

    <match key="info.capabilities" contains="input.touchpad">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>


    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>
      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">evdev</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>
      <merge key="input.xkb.layout" type="string">fr</merge>
      <merge key="input.xkb.variant" type="string">nodeadkeys</merge>
    </match>
  </device>
</deviceinfo>


Je n'ai pas de xorg.conf.

Merci d'avance pour votre aide. Bonnes fetes.
[tahiry]


Last edited by tahiry on Tue Dec 28, 2010 12:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Tue Dec 28, 2010 12:25 pm    Post subject: Reply with quote

Tu as quelle version de X ?

Si 1.9, crée un fichier par exemple /etc/X11/xorg.conf.d/11-keymap.conf et tu peux mettre ça dedans :
Code:
Section "InputClass"
        Identifier "My Keyboard"
        Driver "evdev"
        Option "xkbLayout"  "fr"
        MatchIsKeyboard "on"
EndSection

_________________
Ez.
Back to top
View user's profile Send private message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Tue Dec 28, 2010 12:44 pm    Post subject: Reply with quote

Merci beaucoup, ca marche.
Pour quoi (pourquoi) il faut passer par ce genre de manip ?

Merci encore.
[tahiry]
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Tue Dec 28, 2010 1:08 pm    Post subject: Reply with quote

Parce qu'X ne peut pas deviner la disposition de ton clavier :( il faut lui dire d'une manière ou d'une autre que toi tu préfères la disposition dites "fr" ; à savoir en "azerty"). Et au passage tu peux oublier hal (chouette !) X utilise maintenant evdev pour reconnaitre tes périph :D d'où le fichier de conf précédent qui dit textuellement à X : "Avec evdev, si tu trouves un clavier tu l'appèles My Keyboard et tu lui associe la disposition fr"

NB: là où la conf de X me semble claire et simple, hal me donne des boutons ...
_________________
Ez.
Back to top
View user's profile Send private message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Tue Dec 28, 2010 1:39 pm    Post subject: Reply with quote

Du coup, dans le même style il faut que je configure ma souris ? Comment je fais, je crée un autre fichier dans /etc/x11/xorg.conf.d ? (je viens de m'apercevoir que sur mon portable je n'ai plus l'émulation 3 boutons, mais quand je plug un souris usb ca marche).

Est ce que dans le répertoire /etc/x11/xorg.conf.d il y a une convention de nommage du/des ficher(s) ?

[tahiry]
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Tue Dec 28, 2010 2:00 pm    Post subject: Reply with quote

Je n'en ai pas non plus pour la souris X lui attribue des paramètres par défaut et je n'ai pas de souris à 25 boutons et vortex temporel qui nécessite une configuration particulière. :lol:
Pour le touchpad je pense qu'il va t'en falloir un dans le style utilisé pour le clavier. Je t'invite à lire le man xorg.conf et regarde la section INPUTDEVICE et INPUTCLASS. Quelque chose de ressemblant au code que je t'ai donné précédemment avec un "MatchIsTouchpad" et les options qui vont bien devraient fonctionner :wink: .

Dans le pire des cas cherche sur google tu dois avoir des pages d'exemple de configuration d'un Touchpad =), voir même sur ce forum.

Edite:
Non je ne crois pas qu'il y ait de convention particulière ... m'enfin si tu appèles le fichier de configuration pour le clavier screen.conf ... ça peut porter a confusion :lol:
_________________
Ez.
Back to top
View user's profile Send private message
tahiry
n00b
n00b


Joined: 05 May 2005
Posts: 49

PostPosted: Tue Dec 28, 2010 3:06 pm    Post subject: Reply with quote

Donc comme d'habitude les solutions sont dans les docs.

http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.8-upgrade-guide.xml

Pour la souris j'ai le fichier suivant: /etc/X11/xorg.conf.d/12-mouse.conf

Code:

Section "InputClass"
        Identifier "My Mouse"
        Driver "evdev"
        Option "Emulate3buttons" "true"
        Option "AutoServerLayout" "on"
        MatchIsTouchpad "on"
EndSection
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum