Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errore di compilazione amule-adunanza
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
luca120
n00b
n00b


Joined: 10 Jun 2009
Posts: 54

PostPosted: Sat Dec 25, 2010 9:46 am    Post subject: Errore di compilazione amule-adunanza Reply with quote

Ciao a tutto non riesco a capire quale sia il problema della compilazione!!! mi posto il risultato

Code:
 emerge -av net-p2p/amuleadu

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] net-p2p/amuleadu-2010.1  USE="gtk nls unicode -daemon -debug -geoip -remote -stats -upnp" 0 kB [1]

Total: 1 package (1 new), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/dottout

Would you like to merge these packages? [Yes/No] Yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) net-p2p/amuleadu-2010.1 from dottout
 * aMule-AdunanzA-2010.1-2.2.6.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                [ ok ]
 * Package:    net-p2p/amuleadu-2010.1
 * Repository: dottout
 * USE:  amd64 elibc_glibc gtk kernel_linux multilib nls unicode userland_GNU
>>> Unpacking source...
>>> Unpacking aMule-AdunanzA-2010.1-2.2.6.tar.bz2 to /var/tmp/portage/net-p2p/amuleadu-2010.1/work
 * Running eautoreconf in '/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6' ...
 * Running aclocal -I m4 -I m4 ...                                                                                                                    [ ok ]
 * Running autoconf ...                                                                                                                               [ ok ]
 * Running autoheader ...                                                                                                                             [ ok ]
 * Running automake --add-missing --copy --foreign ...                                                                                                [ ok ]
>>> Source unpacked in /var/tmp/portage/net-p2p/amuleadu-2010.1/work
>>> Preparing source in /var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6 ...
 * wxGTK with gtk support will be used
 * Checking wxGTK-2.8 for X support ...                                                                                                               [ ok ]

 * Requested wxWidgets:        unicode 2.8
 * Using wxWidgets:            gtk2-unicode-release-2.8

 * econf: updating aMule-AdunanzA-2010.1-2.2.6/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating aMule-AdunanzA-2010.1-2.2.6/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --with-wx-config=/usr/lib64/wx/config/gtk2-unicode-release-2.8 --with-wxbase-config=/usr/lib64/wx/config/gtk2-unicode-release-2.8 --enable-amulecmd --disable-debug --enable-optimize --disable-amule-daemon --disable-geoip --enable-nls --disable-webserver --disable-cas --disable-alcc
configure: WARNING: unrecognized options: --with-wxbase-config
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking if this is a FreeBSD 4 or earlier system... no
checking for x86_64-pc-linux-gnu-g++... x86_64-pc-linux-gnu-g++
checking whether the C++ compiler works... no
configure: error: in `/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6':
configure: error: C++ compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6/config.log
 * ERROR: net-p2p/amuleadu-2010.1 failed:
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 3379:  Called econf '--with-wx-config=/usr/lib64/wx/config/gtk2-unicode-release-2.8' '--with-wxbase-config=/usr/lib64/wx/config/gtk2-unicode-release-2.8' '--enable-amulecmd' '--disable-debug' '--enable-optimize' '--disable-amule-daemon' '--disable-geoip' '--enable-nls' '--disable-webserver' '--disable-cas' '--disable-alcc'
 *     ebuild.sh, line  552:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =net-p2p/amuleadu-2010.1',
 * the complete build log and the output of 'emerge -pqv =net-p2p/amuleadu-2010.1'.
 * This ebuild is from an overlay named 'dottout': '/var/lib/layman/dottout/'
 * The complete build log is located at '/var/tmp/portage/net-p2p/amuleadu-2010.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-p2p/amuleadu-2010.1/temp/environment'.
 * S: '/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6'

>>> Failed to emerge net-p2p/amuleadu-2010.1, Log file:

>>>  '/var/tmp/portage/net-p2p/amuleadu-2010.1/temp/build.log'

 * Messages for package net-p2p/amuleadu-2010.1:

 * ERROR: net-p2p/amuleadu-2010.1 failed:
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_configure
 *   environment, line 3379:  Called econf '--with-wx-config=/usr/lib64/wx/config/gtk2-unicode-release-2.8' '--with-wxbase-config=/usr/lib64/wx/config/gtk2-unicode-release-2.8' '--enable-amulecmd' '--disable-debug' '--enable-optimize' '--disable-amule-daemon' '--disable-geoip' '--enable-nls' '--disable-webserver' '--disable-cas' '--disable-alcc'
 *     ebuild.sh, line  552:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =net-p2p/amuleadu-2010.1',
 * the complete build log and the output of 'emerge -pqv =net-p2p/amuleadu-2010.1'.
 * This ebuild is from an overlay named 'dottout': '/var/lib/layman/dottout/'
 * The complete build log is located at '/var/tmp/portage/net-p2p/amuleadu-2010.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-p2p/amuleadu-2010.1/temp/environment'.
 * S: '/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



ho provato anche da sorgente ma quando do il comando
Code:
./configure
mi esce
Code:
./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking if this is a FreeBSD 4 or earlier system... no
checking for g++... g++
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for gawk... (cached) gawk
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking whether make sets $(MAKE)... (cached) yes
checking for flex... flex
checking lex output file root... lex.yy
checking lex library... -lfl
checking whether yytext is a pointer... yes
checking for ranlib... ranlib
checking for bison... bison -y
checking for ranlib... (cached) ranlib
checking for strip... strip
checking for ar... ar
checking for ld... ld
checking for zlib >= 1.1.4... yes (version 1.2.3)
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for File::Copy... ok
checking whether we need the GUI... yes
checking for the --with-toolkit option... will be automatically detected
checking for the --with-wxshared option... will be automatically detected
checking for the --with-wxdebug option... will be automatically detected
checking for the --with-wxversion option... will be automatically detected
checking for wx-config... /usr/bin/wx-config
checking for wxWidgets version >= 2.8.0 (--unicode=yes)... yes (version 2.8.10)
checking for wxWidgets static library... no
checking if wxWidgets was built in DEBUG mode... no
checking if wxWidgets was built in STATIC mode... no
checking which wxWidgets toolkit was selected... gtk2
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
./configure: line 8376: syntax error near unexpected token `{'
./configure: line 8376: `fi      { $as_echo "$as_me:${as_lineno-$LINENO}: result: $result$resultstr" >&5


ps ho gia installato tutte le librerie che richiede amule-adunanza!
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sat Dec 25, 2010 10:51 am    Post subject: Reply with quote

notavo:
Quote:

checking whether the C++ compiler works... no
configure: error: in `/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6':
configure: error: C++ compiler cannot create executables


Per caso hai messo delle CFLAGS o LDFLAGS "particolari/eccessive/esotiche" ?
Code:

$ uname -a
$ grep "FLAGS\|CHOST" /etc/make.conf


In caso affermativo, proverei con FLAGS "tranquille"; altrimenti proverei a ricompilere gcc.
_________________
Gentoo: il sistema più eclettico e geniale che abbia mai provato :)
Back to top
View user's profile Send private message
luca120
n00b
n00b


Joined: 10 Jun 2009
Posts: 54

PostPosted: Sat Dec 25, 2010 11:21 am    Post subject: Reply with quote

ciro64 wrote:
notavo:
Quote:

checking whether the C++ compiler works... no
configure: error: in `/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6':
configure: error: C++ compiler cannot create executables


Per caso hai messo delle CFLAGS o LDFLAGS "particolari/eccessive/esotiche" ?
Code:

$ uname -a
$ grep "FLAGS\|CHOST" /etc/make.conf


In caso affermativo, proverei con FLAGS "tranquille"; altrimenti proverei a ricompilere gcc.


dimenticavooo auguri a tutti :):):) mmm si meglio che vi posto il mio make.conf
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe  -march=native -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"
LDFLAGS="-Wl --as-needed"
MAKEOPTS="-j3"
INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="intel"
ACCEPT_LICENSE="*"
AUTOCLEAN="yes"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="-kde -qt4 -bluetooth dbus hal X gnome gtk fixlafiles cvs multilib threads dvd alsa mmx sse sse2 sse3"

GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ http://gentoo.modulix.net/gentoo/ http://mirror.netcologne.de/gentoo/ http://ftp.heanet.ie/pub/gentoo/ http://ftp.ing.umu.se/linux/gentoo/"
source /var/lib/layman/make.conf
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sat Dec 25, 2010 2:00 pm    Post subject: Reply with quote

Auguroni :)
Usando 64 bits, so essere sconsigliato il -fomit-frame-pointer che, quindi, rimuoverei dalle CFLAGS
Riguardo le LDFLAGS il -Wl,--as-needed è già contemplato
Code:

eselect news read 4
2010-08-01-as-needed-default
  Title                     --as-needed enabled in default profiles
  Author                    Tomáš Chvátal <scarabeus@gentoo.org>
  Posted                    2010-08-01
  Revision                  1

-Wl,--as-needed has been added to the default profile's LDFLAGS.

This option optimizes the linking process, only linking binaries to
libraries that are trully needed. This way, fewer libraries are loaded
at runtime and fewer packages need to be rebuilt after library updates.

To take advantage of the new default you can either rebuild world now
or just allow the system to migrate incrementally as it updates.

Please note that setting LDFLAGS="<your flags>" in your make.conf will
override the profile defaults. If you want to add additional LDFLAGS
it is recommended to use LDFLAGS="${LDFLAGS} <your flags>" instead to
avoid this.

For more information on --as-needed, read [1].
 
[1] http://www.gentoo.org/proj/en/qa/asneeded.xml


In Generale:
Code:

LDFLAGS="${LDFLAGS} <your flags>"

per esempio io ho messo:
Code:

LDFLAGS="${LDFLAGS} -Wl,--hash-style=gnu"


Prova a commentarle in make.conf e riprova la compilazione.

PS: ecco ... rileggendo mi accorgo ora che c'è un errore di sintassi proprio relativamente a LDFLAGS nel tuo make.conf omettendo la "virgola" fra -Wl e --as-needed :)
_________________
Gentoo: il sistema più eclettico e geniale che abbia mai provato :)
Back to top
View user's profile Send private message
luca120
n00b
n00b


Joined: 10 Jun 2009
Posts: 54

PostPosted: Sat Dec 25, 2010 8:52 pm    Post subject: Reply with quote

ciro64 wrote:
Auguroni :)
Usando 64 bits, so essere sconsigliato il -fomit-frame-pointer che, quindi, rimuoverei dalle CFLAGS
Riguardo le LDFLAGS il -Wl,--as-needed è già contemplato
Code:

eselect news read 4
2010-08-01-as-needed-default
  Title                     --as-needed enabled in default profiles
  Author                    Tomáš Chvátal <scarabeus@gentoo.org>
  Posted                    2010-08-01
  Revision                  1

-Wl,--as-needed has been added to the default profile's LDFLAGS.

This option optimizes the linking process, only linking binaries to
libraries that are trully needed. This way, fewer libraries are loaded
at runtime and fewer packages need to be rebuilt after library updates.

To take advantage of the new default you can either rebuild world now
or just allow the system to migrate incrementally as it updates.

Please note that setting LDFLAGS="<your flags>" in your make.conf will
override the profile defaults. If you want to add additional LDFLAGS
it is recommended to use LDFLAGS="${LDFLAGS} <your flags>" instead to
avoid this.

For more information on --as-needed, read [1].
 
[1] http://www.gentoo.org/proj/en/qa/asneeded.xml


In Generale:
Code:

LDFLAGS="${LDFLAGS} <your flags>"

per esempio io ho messo:
Code:

LDFLAGS="${LDFLAGS} -Wl,--hash-style=gnu"


Prova a commentarle in make.conf e riprova la compilazione.

PS: ecco ... rileggendo mi accorgo ora che c'è un errore di sintassi proprio relativamente a LDFLAGS nel tuo make.conf omettendo la "virgola" fra -Wl e --as-needed :)


grazie per avermi aiutato :) alla fine ho messo quello che hai messo tu! ed è andato tutto a buon fine :)

O.T per non aprire un altro topic per avere solo una risposta!!! dato che ho installato gnome-ligth non riesco a trovare il pacchetto e SOLO il pacchetto per variare il volume dal pannello!!! nelle altre distribuzioni se mi ricordo bene si chiama gnome-audio-applet o qualcosa del genere!!!
Back to top
View user's profile Send private message
lele_dj
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2007
Posts: 86

PostPosted: Sat Dec 25, 2010 10:39 pm    Post subject: Reply with quote

luca120 wrote:

........
O.T per non aprire un altro topic per avere solo una risposta!!! dato che ho installato gnome-ligth non riesco a trovare il pacchetto e SOLO il pacchetto per variare il volume dal pannello!!! nelle altre distribuzioni se mi ricordo bene si chiama gnome-audio-applet o qualcosa del genere!!!


Potrebbe essere che non hai la flag "gstreamer" attiva .... avevo riscontrato un problema simile e avevo risolto attivando la flag e ricompilando

P.S. che profilo hai attivato?

Se hai il profilo gnome la flag dovrebbe essere attiva di default ... a meno che tu non la abbia disattivata nel tuo make.conf
Back to top
View user's profile Send private message
luca120
n00b
n00b


Joined: 10 Jun 2009
Posts: 54

PostPosted: Sat Dec 25, 2010 10:54 pm    Post subject: Reply with quote

lele_dj wrote:
luca120 wrote:

........
O.T per non aprire un altro topic per avere solo una risposta!!! dato che ho installato gnome-ligth non riesco a trovare il pacchetto e SOLO il pacchetto per variare il volume dal pannello!!! nelle altre distribuzioni se mi ricordo bene si chiama gnome-audio-applet o qualcosa del genere!!!


Potrebbe essere che non hai la flag "gstreamer" attiva .... avevo riscontrato un problema simile e avevo risolto attivando la flag e ricompilando

P.S. che profilo hai attivato?

Se hai il profilo gnome la flag dovrebbe essere attiva di default ... a meno che tu non la abbia disattivata nel tuo make.conf


io ho gnome-light sono riuscito a farla comparire ma appena clicco su (volume control) mi appare
Code:
Failed to start Volume Control: Failed to execute child process "gnome-volume-control" (No such file or directory)
ho provato ad emergere quel pacchetto ma non lo trova!
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sat Dec 25, 2010 11:51 pm    Post subject: Reply with quote

Lele_dj ti invitava a controllare il profilo scelto:
Code:

$ eselct profile list

Quindi magari selezionare quello che più si addice ai tuoi gusti :)

Con una piccola ricerca si può notare che per gnome-volume-control occorre:
Code:

$ qfile -e gnome-volume-control
gnome-extra/gnome-media (/usr/bin/gnome-volume-control)
gnome-extra/gnome-media (/usr/share/gnome/help/gnome-volume-control)
gnome-extra/gnome-media (/usr/share/omf/gnome-volume-control)

In dettaglio:
Code:

$ eix gnome-media
gnome-extra/gnome-media
     Available versions:  (2) 2.30.0-r1 ~2.32.0
        {pulseaudio}
     Installed versions:  2.30.0-r1(2)(00:30:57 20/12/2010)(-pulseaudio)
     Homepage:            http://ronald.bitfreak.net/gnome-media.php
     Description:         Multimedia related programs for the GNOME desktop


Prova ad emergerlo (se hai un profilo "generico" allora prova prima ad usarne uno più "mirato" per esempio desktop/gnome).

altra utility che ritengo interessante è alsa-utils (in questo caso non so se gnome-light già la "incorpora" )
nel caso di utilizzo di alsa-utils, potrai poi impostare
Code:

# rc-update add alsasound default && rc


In terminale puoi avvalerti (da user) di
Code:

$ alsamixer

per regolare i vari livelli :)
_________________
Gentoo: il sistema più eclettico e geniale che abbia mai provato :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum