Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problema con layout tastiera su KDM dopo upgrade
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Dec 22, 2010 8:20 am    Post subject: [RISOLTO] Problema con layout tastiera su KDM dopo upgrade Reply with quote

Salve a tutti,

dopo un recente aggiornamento e dopo la ricompilazione di tutti i pacchetti che escono fuori da un
Code:
qlist -I -C x11-drivers/


il layout della tastiera di default e` quello in inglese.
Ho gia` controllato anche altri topic come questo, ma il mio file fdi e` gia` a posto, e non riesco a capire quale sia il problema. L'unico modo in cui sono riuscito a cambiare il layout e` stato quello di andare in SystemSettings->Regional & Language->keyboard layout->enable keyboard layout e selezionare solo italiano. Il probelma e` che riavviando questa impostazione viene "persa" e siamo daccapo.
C'e` qualche altro posto dove si deve cambiare questo layout per renderlo definitivamente in italiano?
Per quanto riguarda la shell non c'e` problema invece. La cosa riguarda solo KDE.

Attualmente comunque i keyboard layouts dentro system settings sono disabilitati, e lo sono sempre stati.

EDIT: ho impostato l'uso dei layout tastiera, ed ora KDE parte con il corretto layout, visto che ho messo solo quello italiano, ma KDM continua ad usare quello en_US.
Se vado in System Settings->Advanced->Login Manager, ho la possibilità di selezionare solo en_US come lingua. Perché?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Sun Dec 26, 2010 9:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Dec 22, 2010 12:54 pm    Post subject: Re: Problema con layout tastiera su KDE/KDM dopo aggiornamen Reply with quote

fbcyborg wrote:


EDIT KDM continua ad usare quello en_US.

kdm va configurato in /usr/share/config/kdm/kdm.rc
inoltre è sempre meglio passare le opzioni di setxkbamp (tipo XkbOptions) attraverso hal o /etc/X11/xorg.conf.d, altrimenti si rischia di avere cose tipo tastiera italiana che non funzionano le graffe con Alt-Gr_Maiusc_è .

adesso che il nuovo kdesettings non mostra più la sintassi di setxkbmap, è tutto più difficile.

lo ho sempre detto, io : viva kde3.5 !
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Dec 22, 2010 1:17 pm    Post subject: Reply with quote

Niente da fare.
Effettivamente nel file di configurazione di KDM, era impostato en_US, sulla variabile-parametro Language, ma anche mettendo it_IT non cambia nulla. Sembra come se non sia presente la lingua italiana. (Fra l'altro sul portatile ho impostato Language=en_US eppure questo problema non ce l'ho. Anche Systemsettings->Advanced->Login Manager->Language è impostato su US English, ma il layout in kdm è in italiano).
Inoltre, questo è il mio file /etc/hal/fdi/policy/10-keymap.fdi :
Code:
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
                <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</merge>
      </match>

      <merge key="input.xkb.layout" type="string">it</merge>
      <merge key="input.xkb.variant" type="string" />
    </match>
  </device>
</deviceinfo>


Ma sono sicuro che ci sia qualcosa che non funzioni, perché ad esempio non funziona nemmeno la combinazione di tasti CTRL+ALT+Backspace.
Sembra come se questo file venisse ignorato completamente.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Dec 22, 2010 5:27 pm    Post subject: Reply with quote

ma perché non lo molli, questo supporto hal ad X, come oramai fanno tutti?

c'è la guida ufficiale, affidabilissima da mesi.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Dec 22, 2010 5:38 pm    Post subject: Reply with quote

Non lo mollo perché ancora ho xorg-1.7 e quella guida è per 1.8. Non appena diverrà stabile seguirò quella guida.
Ma quindi fammi capire, è stato fatto un passo indietro in questo senso?
Tempo fa ci fu "un mezzo casino" perché molte impostazioni del file xorg.conf dovevano migrare su hal, e adesso si torna di nuovo a xorg.conf?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Dec 22, 2010 8:44 pm    Post subject: Reply with quote

fbcyborg wrote:

Ma quindi fammi capire, è stato fatto un passo indietro in questo senso?

così non si può dire.
di certo, la comunità ha accompagnato con freddezza lo sviluppo di hal, sia per antipatia rispetto all'uso dell'xml in /etc, sia perché, porgressivamente, ci si è accorti che le funzionalità di questo servizio era di poco rirlievo e potevano essere emulate con facilità dai programmi utente.

adesso, rimani tra i pochi che usano ancora Xorg-1.7 e di conseguenza, quando ti capita qualcosa, non trovi facilmente altri utenti che condividano le tue esperienze.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Dec 22, 2010 8:58 pm    Post subject: Reply with quote

Ho capito. Devo passare a xorg 1.8, comunque ancora non mi spiego perché questo sul mio portatile non sia successo.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Dec 26, 2010 12:42 am    Post subject: Reply with quote

Guarda io ho avuto il tuo stesso problema, e sto cercando di risolvere. Ci stavo pensando anche io a migrare a xorg 1.8 ma sinceramente vorrei risolvere prima.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Dec 26, 2010 9:59 am    Post subject: Reply with quote

nel frattempo, è diventato stabile xorg-server-1.9.

qui la guida.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Dec 26, 2010 8:51 pm    Post subject: Reply with quote

A posto! L'aggiornamento alla versione 1.9 è stato provvidenziale.

Grazie!
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum