Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] “No OpenGL support in video driver”
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
ccconnor
n00b
n00b


Joined: 26 Jul 2016
Posts: 18

PostPosted: Sat Aug 06, 2016 10:54 am    Post subject: [SOLVED] “No OpenGL support in video driver” Reply with quote

Even though I should have OpenGL support, some games say I don’t (others just refuse to launch without providing an error).

For example, here is the error message I get while attempting to run LÖVE (this isn’t a problem specific to LÖVE, by the way):
Code:
This program requires a graphics card and video drivers which support OpenGL 2.1 or OpenGL ES 2.

SDL window creation error: No OpenGL support in video driver
I have updated my drivers to the latest version (x11-drivers/ati-drivers-15.12-r1), but to no avail. I have tried eselect opengl set ati from its original setting of xorg-x11, but that didn’t work, and it broke some other things.

Here is the output of my glxinfo. If you need any more information, just ask.


Last edited by ccconnor on Thu Aug 11, 2016 8:21 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 36053
Location: 56N 3W

PostPosted: Sat Aug 06, 2016 1:47 pm    Post subject: Reply with quote

ccconnor,

Code:
name of display: :0
display: :0  screen: 0
direct rendering: Yes
indicates all is well.

Run the groups command as the user running the game.
Code:
$ groups
tty wheel uucp audio cdrom video games kvm cdrw users vboxusers scanner wireshark plugdev roy

Does video appear for you?
If not, your user will not be permitted to use direct rendering, even though you have it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ccconnor
n00b
n00b


Joined: 26 Jul 2016
Posts: 18

PostPosted: Sun Aug 07, 2016 3:21 am    Post subject: Reply with quote

NeddySeagoon wrote:
ccconnor,
Code:
name of display: :0
display: :0  screen: 0
direct rendering: Yes
indicates all is well.

Run the groups command as the user running the game.
Code:
$ groups
tty wheel uucp audio cdrom video games kvm cdrw users vboxusers scanner wireshark plugdev roy
Does video appear for you?
If not, your user will not be permitted to use direct rendering, even though you have it.
video does appear for me.
Code:
user $ groups
wheel floppy audio cdrom video usb users ccconnor
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 3553
Location: UK

PostPosted: Sun Aug 07, 2016 3:28 am    Post subject: Reply with quote

NeddySeagoon wrote:
ccconnor,

Code:
name of display: :0
display: :0  screen: 0
direct rendering: Yes
indicates all is well.

Further down it has this:
Code:
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.7, 128 bits)

That's the software renderer. There's no evidence there's any hardware acceleration even happening. We need to see Xorg.0.log to figure out if the correct driver's being loaded at all.
_________________
overlay | runit-scripts
Back to top
View user's profile Send private message
ccconnor
n00b
n00b


Joined: 26 Jul 2016
Posts: 18

PostPosted: Sun Aug 07, 2016 6:37 am    Post subject: Reply with quote

Ant P. wrote:
Further down it has this:
Code:
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.7, 128 bits)
That's the software renderer. There's no evidence there's any hardware acceleration even happening. We need to see Xorg.0.log to figure out if the correct driver's being loaded at all.
Here is my Xorg.0.log.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 36053
Location: 56N 3W

PostPosted: Sun Aug 07, 2016 10:30 am    Post subject: Reply with quote

ccconnor,

From your log
Code:
[    27.206] (==) Matched ati as autoconfigured driver 0
[    27.206] (==) Matched ati as autoconfigured driver 1
[    27.206] (==) Matched modesetting as autoconfigured driver 2
[    27.206] (==) Matched fbdev as autoconfigured driver 3
[    27.206] (==) Matched vesa as autoconfigured driver 4
Thats the order of preference for open source drivers for your hardware.
Only the ati driver has hardware acceleration.

Code:
[    27.206] (II) LoadModule: "ati"
[    27.206] (WW) Warning, couldn't open module ati
[    27.206] (II) UnloadModule: "ati"
[    27.206] (II) Unloading ati
[    27.206] (EE) Failed to load module "ati" (module does not exist, 0)
but the ati module does not exist.

Code:
[    27.215] (--) using VT number 7
[    27.222] (II) modeset(0): using drv /dev/dri/card0
[    27.222] (II) modeset(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    27.222] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[    27.222] (==) modeset(0): RGB weight 888
[    27.222] (==) modeset(0): Default visual is TrueColor
so thats the modesetting driver in use.

Looking for video-ati
Code:
$ eix video-ati
* x11-drivers/xf86-video-ati
     Available versions:  6.14.6-r1 7.5.0 (~)7.6.1 (~)7.7.0 {+glamor udev}
     Homepage:            http://www.x.org/wiki/ati/
     Description:         ATI video driver
eix says Available versions: 6.14.6-r1 7.5.0 (~)7.6.1 (~)7.7.0

x11-drivers/ati-drivers-15.12-r1, which you have is the binary blob ATI driver. Xorg will not detect that automatically.
You need an xorg.conf to tell Xorg about the binary blob.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ccconnor
n00b
n00b


Joined: 26 Jul 2016
Posts: 18

PostPosted: Sun Aug 07, 2016 10:51 am    Post subject: Reply with quote

NeddySeagoon wrote:
ccconnor,

[snip]

x11-drivers/ati-drivers-15.12-r1, which you have is the binary blob ATI driver. Xorg will not detect that automatically.
You need an xorg.conf to tell Xorg about the binary blob.
Ah, I presume that’s what this section refers to?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 36053
Location: 56N 3W

PostPosted: Sun Aug 07, 2016 11:26 am    Post subject: Reply with quote

ccconnor,

I thought
Code:
X -configure
had been broken for years

Jump to
Code:
X -configure fails with a no device found error.

If X -configure fails, you must create a stub xorg.conf file:
and use the example given.
The Identifier can be anything as long as its unique in its Section type. The section types and Identifiers are what Xorg uses to assemble the Xorg server.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ccconnor
n00b
n00b


Joined: 26 Jul 2016
Posts: 18

PostPosted: Sun Aug 07, 2016 11:42 am    Post subject: Reply with quote

NeddySeagoon wrote:
ccconnor,

I thought
Code:
X -configure
had been broken for years

Jump to
Code:
X -configure fails with a no device found error.

If X -configure fails, you must create a stub xorg.conf file:
and use the example given.
The Identifier can be anything as long as its unique in its Section type. The section types and Identifiers are what Xorg uses to assemble the Xorg server.
It seems that X -configure did not work for me. But I’m wondering, if it’s been broken for years, why is it still in the wiki article?

Anyways, I created an xorg.conf with this:
Code:
Section "Device"
        Identifier "ATI radeon 6530"
        Driver     "fglrx"
EndSection
However, upon automatic startx, I was presented with a black screen, and it seems that it didn’t detect my keyboard or mouse. Any advice?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 36053
Location: 56N 3W

PostPosted: Sun Aug 07, 2016 12:46 pm    Post subject: Reply with quote

ccconnor,

Please post your new Xorg.0.log.

It appears that either Xorg has nothing to do because ~/.xinitrc is empty and you don't have twm, xterm and xclock installed.
The input driver is missing. It wasn't, from your original log.
Code:
[    28.509] (II) Using input driver 'evdev' for 'USB OPTICAL MOUSE'
[    28.509] (**) USB OPTICAL MOUSE: always reports core events
[    28.509] (**) evdev: USB OPTICAL MOUSE: Device: "/dev/input/event8"


What does "automatic startx" mean. You can script startx. Then you need to populate ~/.xinitrc so it knows what to do, or you can use a display manager and add xdm to the default runlevel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ccconnor
n00b
n00b


Joined: 26 Jul 2016
Posts: 18

PostPosted: Sun Aug 07, 2016 1:51 pm    Post subject: Reply with quote

NeddySeagoon wrote:
ccconnor,

Please post your new Xorg.0.log.

It appears that either Xorg has nothing to do because ~/.xinitrc is empty and you don't have twm, xterm and xclock installed.
The input driver is missing. It wasn't, from your original log.
Code:
[    28.509] (II) Using input driver 'evdev' for 'USB OPTICAL MOUSE'
[    28.509] (**) USB OPTICAL MOUSE: always reports core events
[    28.509] (**) evdev: USB OPTICAL MOUSE: Device: "/dev/input/event8"
What does "automatic startx" mean. You can script startx. Then you need to populate ~/.xinitrc so it knows what to do, or you can use a display manager and add xdm to the default runlevel.
Sorry for not being clear. I meant startx on login as described here. I have i3wm installed, no DE, so startx just by itself works fine normally.

Here is the new Xorg.0.log I got.
Back to top
View user's profile Send private message
ccconnor
n00b
n00b


Joined: 26 Jul 2016
Posts: 18

PostPosted: Tue Aug 09, 2016 1:00 pm    Post subject: Reply with quote

An update: I did aticonfig --initial -f --input=/etc/X11/xorg.conf (but couldn’t do it as root, had to use sudo), and now my xorg.conf is this:
Code:
Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:0:1:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection
The weird thing is, my system boots into my graphical interface if /etc/X11/xorg.conf is missing. I suspect there is something in xorg.conf that is overwriting the necessary input drivers.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 36053
Location: 56N 3W

PostPosted: Tue Aug 09, 2016 4:11 pm    Post subject: Reply with quote

ccconnor,

You cannot use the same kernel to boot into a graphical interface if /etc/X11/xorg.conf is missing and use the ATI binary blob.
The two drivers used require different conflicting kernel options.

That it works with xorg.conf missing tells that it won't work with
Code:
Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:0:1:0"
EndSection
That Section "Device", should be all you need in xorg.conf and you need to remove kernel support for Radeon.

You can have two kernels if you need to switch between the open source driver and the binary blob but that is left as an exercise for the reader :)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ccconnor
n00b
n00b


Joined: 26 Jul 2016
Posts: 18

PostPosted: Wed Aug 10, 2016 8:27 am    Post subject: Reply with quote

NeddySeagoon wrote:
ccconnor,

You cannot use the same kernel to boot into a graphical interface if /etc/X11/xorg.conf is missing and use the ATI binary blob.
The two drivers used require different conflicting kernel options.

That it works with xorg.conf missing tells that it won't work with
Code:
Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:0:1:0"
EndSection
That Section "Device", should be all you need in xorg.conf and you need to remove kernel support for Radeon.

You can have two kernels if you need to switch between the open source driver and the binary blob but that is left as an exercise for the reader :)
Removed Radeon support from kernel, recompiled, generated new xorg.conf, and I’m able to boot into the graphical environment, but it seems I do not have direct rendering.

Here is what I get from glxinfo:
Code:
user $ glxinfo
name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13
Here is what my xorg.conf is:
Code:
user $ cat /etc/X11/xorg.conf
Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:0:1:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection
Back to top
View user's profile Send private message
ccconnor
n00b
n00b


Joined: 26 Jul 2016
Posts: 18

PostPosted: Thu Aug 11, 2016 8:20 am    Post subject: Reply with quote

I fixed it by installing ati-drivers-15.9-r1. All the other games now have OpenGL support, however LÖVE still refuses to launch, and that is an issue I will take over their forums. Thank you, NeddySeagoon, for all of your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum