Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
il sistema non parte [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Dec 16, 2010 2:39 pm    Post subject: il sistema non parte [risolto] Reply with quote

per la serie capitano sempre tutte a me...

ok, mi accingo a tornare ad installare gentoo dopo due anni di bestemmie su certi OS dimm[censura]. Ammetto che non ho dato neppure una scorsa alla documentazione dicendomi " ma cosa potrà essere cambiato mai...".
Partiziono il disco di sistema (i due per i dati sono ancora intonsi) con primaria da 1GB per /boot (lo so che è grande ma ho le mie ragioni future) e root su estesa, compilo il sistema (ho installato direttamente tutto da chroot), compilo il kernel con genkernel --menuconfig, configuro rapidamente lilo (grub continua a starmi sui cosiddetti) e riavvio.

Il kernel parte, sembra riconoscere le partizioni, avvia l'immagine, monta la root e... si blocca dicendo che non trova /dev/sdc5.

Inserisco la password di root ed effettivamente la root è montata ma nella dir dev non c'è un beneamato c**** e proc e sys non sono montate.

Che cosa mi sono perso?

ps: se qualche anima pia volesse dirmi quali sono i parametri di avvio per centos (su sdc6) perché non riesco a configurare l'avvio neanche per quello (ed il bootloader i mano ad un sistema winjdozz-like come quello (per inciso installazione di gentoo un pomeriggio, installazione di centos via http... una notte, e poi dicono che i gentooisti si complicano la vita... mah) non lo lascio neanche morto.
Devo attendermi problemi dalla convivenza di gentoo con la ciofeca (di tutte le distribuzioni RH è quella che è durata meno di tutte, due giorni ai tempi della "mitica" 5, poi non ne ho più voluto sapere)?

scusate lo sfogo, ma ho una certa premura...
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:


Last edited by djinnZ on Thu Dec 16, 2010 9:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Dec 16, 2010 3:47 pm    Post subject: Reply with quote

per me, hai il solito comunissimo pasticcio con i driver della scheda madre.
bisogna togliere l'ATA support, che è deprecato e mettere l' ATA SFF support.

quanto a centOs, posta da loro.
per lo più, le grandi distro impostano il bootloader con le UUID o con le LABEL.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Thu Dec 16, 2010 3:53 pm    Post subject: Reply with quote

anche io, che mi ricordi, ho avuto un problema simile tempo fa.

adesso non ricordo bene, ma mi pare che dentro le opzioni del kernel ci sia un modo per salvare lo /dev/ in modo che venga caricato già all'inizio.
beh, io ho impostato quella e il problema m'è scomparso.
purtroppo non ho tempo per cercare, e non mi ricordo il nome dell'opzione.

cerco e ti fo' sapere.

probabilmente ci sarà qualcosa da smanettare con udev, ma non saprei cosa...
_________________
Darkman
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Dec 16, 2010 9:22 pm    Post subject: Reply with quote

risolto disabilitando il supporto di udev al persistent cdrom (ammetto che ho pasticciato un poco con le connessioni) e rimettendo correttamente i mount in fstab (mi ero arretrato non poco), per l'altro sistema... non ho capito se devo reistallare o meno (lo odio già!).
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum