Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
glib-2.28.6 emerge failure
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
netpumber
n00b
n00b


Joined: 10 Feb 2011
Posts: 68

PostPosted: Sat Apr 30, 2011 9:01 pm    Post subject: glib-2.28.6 emerge failure Reply with quote

here is what i got.. I search on net but..nothing that can help found..
Quote:
configure: error: Cannot determine shared library suffix from libtool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-libs/glib-2.28.6/work/glib-2.28.6/config.log
* ERROR: dev-libs/glib-2.28.6 failed (configure phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 56: Called src_configure
* environment, line 5692: Called econf '--enable-debug' '--disable-xattr' '--disable-man' '--disable-gtk-doc' '--disable-fam' '--disable-selinux' '--enable-static' '--enable-regex' '--with-pcre=internal' '--with-threads=posix' '--disable-dtrace' '--disable-systemtap'
* ebuild.sh, line 557: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of 'emerge --info =dev-libs/glib-2.28.6',
* the complete build log and the output of 'emerge -pqv =dev-libs/glib-2.28.6'.
* The complete build log is located at '/var/tmp/portage/dev-libs/glib-2.28.6/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-libs/glib-2.28.6/temp/environment'.
* S: '/var/tmp/portage/dev-libs/glib-2.28.6/work/glib-2.28.6'

>>> Failed to emerge dev-libs/glib-2.28.6, Log file:

>>> '/var/tmp/portage/dev-libs/glib-2.28.6/temp/build.log'

* Messages for package dev-libs/glib-2.28.6:

* ERROR: dev-libs/glib-2.28.6 failed (configure phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 56: Called src_configure
* environment, line 5692: Called econf '--enable-debug' '--disable-xattr' '--disable-man' '--disable-gtk-doc' '--disable-fam' '--disable-selinux' '--enable-static' '--enable-regex' '--with-pcre=internal' '--with-threads=posix' '--disable-dtrace' '--disable-systemtap'
* ebuild.sh, line 557: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of 'emerge --info =dev-libs/glib-2.28.6',
* the complete build log and the output of 'emerge -pqv =dev-libs/glib-2.28.6'.
* The complete build log is located at '/var/tmp/portage/dev-libs/glib-2.28.6/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-libs/glib-2.28.6/temp/environment'.
* S: '/var/tmp/portage/dev-libs/glib-2.28.6/work/glib-2.28.6'


[file] /var/tmp/portage/dev-libs/glib-2.28.6/temp/build.log

Quote:
.....
checking for snprintf... yes
checking for wcslen... yes
checking for C99 snprintf... yes
checking for sys_errlist... yes
checking for sys_siglist... yes
checking for sys_siglist declaration... yes
checking for fd_set... yes, found in sys/types.h
checking whether realloc (NULL,) will work... yes
checking for nl_langinfo (CODESET)... yes
checking for a compliant posix_memalign() implementation... yes
checking for OpenBSD strlcpy/strlcat... no
checking for an implementation of va_copy()... yes
checking for an implementation of __va_copy()... yes
checking whether va_lists can be copied by value... yes
checking for dlopen... no
checking for NSLinkModule... no
checking for dlopen in -ldl... yes
checking for dlsym in -ldl... yes
checking for RTLD_GLOBAL brokenness... no
checking for preceeding underscore in symbols... no
checking for dlerror... yes
checking for the suffix of module shared libraries... .
configure: error: Cannot determine shared library suffix from libtool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-libs/glib-2.28.6/work/glib-2.28.6/config.log
* ERROR: dev-libs/glib-2.28.6 failed (configure phase):
* econf failed
*
* Call stack:
* ebuild.sh, line 56: Called src_configure
* environment, line 5692: Called econf '--enable-debug' '--disable-xattr' '--disable-man' '--disable-gtk-doc' '--disable-fam' '--disable-selinux' '--enable-static' '--enable-regex' '--with-pcre=internal' '--with-threads=posix' '--disable-dtrace' '--disable-systemtap'
* ebuild.sh, line 557: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of 'emerge --info =dev-libs/glib-2.28.6',
* the complete build log and the output of 'emerge -pqv =dev-libs/glib-2.28.6'.
* The complete build log is located at '/var/tmp/portage/dev-libs/glib-2.28.6/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-libs/glib-2.28.6/temp/environment'.
* S: '/var/tmp/portage/dev-libs/glib-2.28.6/work/glib-2.28.6'


Have you any idea ?

Thanks in advance..
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sat Apr 30, 2011 10:19 pm    Post subject: Reply with quote

Anything interesting in that config.log ?
Back to top
View user's profile Send private message
netpumber
n00b
n00b


Joined: 10 Feb 2011
Posts: 68

PostPosted: Sun May 01, 2011 6:44 pm    Post subject: Reply with quote

i thought that this line was interesting

configure: error: Cannot determine shared library suffix from libtool

but anyway.. here is the whole .log

http://pastebin.com/YmQ5YD96


Thanks,,for your answer..
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sun May 01, 2011 7:43 pm    Post subject: Reply with quote

I said config.log.
Also, there seems to be something funny either about your filesystem or system clock.
Back to top
View user's profile Send private message
netpumber
n00b
n00b


Joined: 10 Feb 2011
Posts: 68

PostPosted: Sun May 01, 2011 9:44 pm    Post subject: Reply with quote

oh ok sorry my mistake..

here is now the config

http://pastebin.com/YNNhKPKR

Also you are right in that you said.. something funny happens with my system clock..

When i set a new time after reboot it changed..and now after the emerging world the clock from task bar dissapeared :p

I have mess them up..:p
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sun May 01, 2011 11:52 pm    Post subject: Reply with quote

What does './libtool --config | grep '^shrext_cmds='' return for the generated libtool ?
Back to top
View user's profile Send private message
netpumber
n00b
n00b


Joined: 10 Feb 2011
Posts: 68

PostPosted: Mon May 02, 2011 11:17 am    Post subject: Reply with quote

Hmm here is the result :
Quote:

libtool --config | grep '^shrext_cmds='
shrext_cmds=".so"
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Mon May 02, 2011 3:46 pm    Post subject: Reply with quote

:roll: Not the system copy, the one generated in WORKDIR.
Back to top
View user's profile Send private message
netpumber
n00b
n00b


Joined: 10 Feb 2011
Posts: 68

PostPosted: Mon May 02, 2011 4:32 pm    Post subject: Reply with quote

Where exactly i ll run it ?

I run this after error and that what i get back..

./libtool --config | grep '^shrext_cmds='
-bash: ./libtool: No such file or directory


Where is the WORKDIR..
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Mon May 02, 2011 6:05 pm    Post subject: Reply with quote

For this package, given your log it's /var/tmp/portage/dev-libs/glib-2.28.6/.
Back to top
View user's profile Send private message
netpumber
n00b
n00b


Joined: 10 Feb 2011
Posts: 68

PostPosted: Mon May 02, 2011 6:52 pm    Post subject: Reply with quote

ok.. i go to this dir /var/tmp/portage/dev-libs/glib-2.28.6/
and run this libtool --config | grep '^shrext_cmds='
it returns : shrext_cmds=".so"

if i run this ./libtool --config | grep '^shrext_cmds='
it returns obviously this :
-bash: ./libtool: No such file or directory
Back to top
View user's profile Send private message
netpumber
n00b
n00b


Joined: 10 Feb 2011
Posts: 68

PostPosted: Tue May 03, 2011 9:27 am    Post subject: Reply with quote

after a little search i went to this dir :

cd /var/tmp/portage/dev-libs/glib-2.28.6/work/glib-2.28.6

which has all these :

Quote:
AUTHORS INSTALL.in compile gio-unix-2.0.pc.in gthread-2.0-uninstalled.pc.in
COPYING MAINTAINERS config.guess gio-windows-2.0.pc.in gthread-2.0.pc.in
ChangeLog Makefile.am config.h.in glib gtk-doc.make
ChangeLog.pre-1-2 Makefile.decl config.h.win32 glib-2.0-uninstalled.pc.in install-sh
ChangeLog.pre-2-0 Makefile.in config.h.win32.in glib-2.0.pc.in libtool
ChangeLog.pre-2-10 NEWS config.log glib-gettextize.in ltmain.sh
ChangeLog.pre-2-12 NEWS.pre-1-3 config.lt glib-zip.in m4macros
ChangeLog.pre-2-14 README config.sub gmodule makefile.msc
ChangeLog.pre-2-16 README.commits configure gmodule-2.0-uninstalled.pc.in missing
ChangeLog.pre-2-18 README.in configure.ac gmodule-2.0.pc.in mkinstalldirs
ChangeLog.pre-2-2 README.win32 configure.rej gmodule-export-2.0.pc.in msvc_recommended_pragmas.h
ChangeLog.pre-2-20 acglib.m4 depcomp gmodule-no-export-2.0-uninstalled.pc.in po
ChangeLog.pre-2-4 acinclude.m4 docs gmodule-no-export-2.0.pc.in sanity_check
ChangeLog.pre-2-6 aclocal.m4 gio gobject tests
ChangeLog.pre-2-8 autogen.sh gio-2.0-uninstalled.pc.in gobject-2.0-uninstalled.pc.in
HACKING autom4te.cache gio-2.0.pc.in gobject-2.0.pc.in
INSTALL build gio-unix-2.0-uninstalled.pc.in gthread


The i run here

tux glib-2.28.6 # ./libtool --config | grep '^shrext_cmds='
tux glib-2.28.6 #

and returns nothing ..

What that means ?
Back to top
View user's profile Send private message
netpumber
n00b
n00b


Joined: 10 Feb 2011
Posts: 68

PostPosted: Tue May 03, 2011 1:18 pm    Post subject: Reply with quote

ok.. i've made some changes in clock file and at hardware clock through BIOS and now glib compiled and installed right..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum