Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SIS]mauvaise prise en charge d'écran 22pouces
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Mon Dec 06, 2010 2:33 am    Post subject: [SIS]mauvaise prise en charge d'écran 22pouces Reply with quote

Bonjour,

je viens tout juste d'installer ma gentoo en 32, tout est impéc.
Au détail prés ! (faute de quoi je n'aurais pas posté ici) que ma résolution d'écran, un écran d'environ 476̣mm×299mm, aussi appelé "22 pouces", est mal prise en charge, dans les préférences de résolution, aucune ne convient vraiment. Tout parait élargit (ce qui est sensé être un carré est nettement rectangulaire chez moi comme ce "carré" http://fr.wikipedia.org/wiki/Fichier:Kvadrato.svg ) et les carravctères sur les tty sont vraiment très gros c'est un problème que j'ai toujours eu même sur les autres distrib' (mais pas sous windows... ), pour info voici mon contrôleur graphique :

Code:
lspci -v | grep -i vga                                                                                                             
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10) (prog-if 00 [VGA controller])


J'ai toujours eu ce problème certes, mais en m'initiant à gentoo, j'avais eu la surprise, lorsque j'ai démarrer le liveCD de gentoo, de voir un tty avec des caractères très fin, une bonne résolution d'écran en somme, j'ai donc la conviction que c'est possible d'avoir cette résolution optimale.
Pourtant, quand j'ai démarrer mon système gentoo installé (à savoir que toute l'installation s'est déroulé par un chroot depuis une ubuntu installée à coté, si sa peut avoir un rapport...), la résolution était de nouveau grossière, j'ai alors recompilé mon kernel et pris en dure les deux support suivants :

Code:
  │ Symbol: DRM_RADEON_KMS [=n]                                                                                                    │   
  │ Prompt: Enable modesetting on radeon by default - NEW DRIVER                                                                   │   
  │   Defined at drivers/gpu/drm/radeon/Kconfig:1                                                                                  │   
  │   Depends on: HAS_IOMEM [=y] && DRM_RADEON [=n]                                                                                │   
  │   Location:                                                                                                                    │   
  │     -> Device Drivers                                                                                                          │   
  │       -> Graphics support                                                                                                      │   
  │         -> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) (DRM [=y])                                          │   
  │           -> ATI Radeon (DRM_RADEON [=n])                                                                                      │   
  │                                                                                                                                │   
  │                                                                                                                                │   
  │ Symbol: DRM_I915_KMS [=n]                                                                                                      │   
  │ Prompt: Enable modesetting on intel by default                                                                                 │   
  │   Defined at drivers/gpu/drm/Kconfig:117                                                                                       │   
  │   Depends on: <choice> && DRM_I915 [=y]                                                                                        │   
  │   Location:                                                                                                                    │   
  │     -> Device Drivers                                                                                                          │   
  │       -> Graphics support                                                                                                      │   
  │         -> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) (DRM [=y])                                          │   
  │           -> Intel 830M, 845G, 852GM, 855GM, 865G (<choice> [=y])                                                              │   
  │             -> i915 driver (DRM_I915 [=y])
Mais rien n'y fait.

Quelqu'un à une idée pour cette histoire de résolution ?

BIen à vous,

Cordialement.


Last edited by Napoleon on Tue Dec 14, 2010 2:05 pm; edited 2 times in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8070
Location: ~Brussels - Belgique

PostPosted: Mon Dec 06, 2010 8:52 am    Post subject: Reply with quote

Salut,

Il est inutile de compiler les drivers pour Radeon, nVidia et Intel vu que ta carte est une SiS ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Mon Dec 06, 2010 10:33 am    Post subject: Reply with quote

Donc pour SIS, pas de KMS. Donc pour une console "jolie" => le bon vieux framebuffer : http://en.gentoo-wiki.com/wiki/Framebuffer#sisfb_2


Pour l'écran déformé :
1) X est à la résolution (en fait la dimension) native de l'écran (LCD je suppose) ? Du genre 1920x1200 ou 1920x1080 je suppose.
2) Si oui, fixer la résolution (ne pas confondre avec la dimension ;)) de l'écran à 96 ou mieux 98 dpi. => avec un point bien carré, et de taille standard. Cela devrait résoudre les problèmes de déformation et de fontes énormes.



Pour le point 2, ça dépend de la manière dont tu lances X.
- si tu lances via KDM => ajouter "-dpi 98" à la ligne ServerArgsLocal=-nolisten tcp
- si tu lances à la main, "startx -dpi 98"
- pour gdm, heu, je sais pas, faut trouver un équivalent de kdm ;)
Sinon, il y a toujours la possibilité de configurer cette valeur en live dans la session utilisateur, mais c'est à mon goût moins propre, et n'affecte pas tout le monde...


[Edit]
Pour avoir la résolution courante :
Code:
$ xdpyinfo  | grep resolution
  resolution:    98x98 dots per inch

_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3098
Location: Paris

PostPosted: Mon Dec 06, 2010 12:50 pm    Post subject: Reply with quote

Et sinon, corriger la mauvaise orthographe du titre, SVP? :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Mon Dec 06, 2010 1:21 pm    Post subject: Reply with quote

XavierMiller wrote:
Salut,

Il est inutile de compiler les drivers pour Radeon, nVidia et Intel vu que ta carte est une SiS ;)
Eh bien, c'est que d'après mes recherches (pas très fructueuses), j'ai crus comprendre que je devais prendre le support de "KMS" j'ai alors coché tout se qui portait la mention "KMS", sans faire attention outre mesure. De toute façon je n'ai trouvé rien de mieux.


guilc wrote:
Donc pour SIS, pas de KMS. Donc pour une console "jolie" => le bon vieux framebuffer : http://en.gentoo-wiki.com/wiki/Framebuffer#sisfb_2
Sir, the Sheakspear's language is really difficult, I speak arabic and latin, but I english arn't ease. any way, I will make effort to understand someting :D.
Plus sérieusement, cette ligne là, je dois la mettre dans grub.conf ?

et si je comprends toujours bien je dois y écrire :
Code:
video=uvesafb:ypan,mtrr:<largeur>x<hauteur>-32@70
avec largeur et hauteur qui sont bien les dimensions de mon écran ? et les 32@70, c'est une variable ou ça doit rester fixe ?



guilc wrote:
Pour l'écran déformé :
1) X est à la résolution (en fait la dimension) native de l'écran (LCD je suppose) ? Du genre 1920x1200 ou 1920x1080 je suppose.
Si je te suis toujours bien "<largeur>x<hauteur>" deviendra chez moi "1920x1200" (ce qui me convient assez puisque le caution de cette dimension est proche de celui des dimensions de mon écran).

guilc wrote:
2) Si oui, fixer la résolution (ne pas confondre avec la dimension ;)) de l'écran à 96 ou mieux 98 dpi. => avec un point bien carré, et de taille standard. Cela devrait résoudre les problèmes de déformation et de fontes énormes.
Je voudrais bien, mais où ? :)



guilc wrote:
Pour le point 2, ça dépend de la manière dont tu lances X.
- si tu lances via KDM => ajouter "-dpi 98" à la ligne ServerArgsLocal=-nolisten tcp
Où ajouter cette ligne, même si j'utilise GDM, je saurais ptete trouvé l'équivalent.


guilc wrote:
Sinon, il y a toujours la possibilité de configurer cette valeur en live dans la session utilisateur, mais c'est à mon goût moins propre, et n'affecte pas tout le monde...
Je suis d'accord avec toi


guilc wrote:
[Edit]
Pour avoir la résolution courante :
Code:
$ xdpyinfo  | grep resolution
  resolution:    98x98 dots per inch
La miene est de 69x86 dots per inch.

El_Goretto wrote:
Et sinon, corriger la mauvaise orthographe du titre, SVP? :)
Impossible, je suis limité en nombre de caractère et ne peux plus en rajouté un seul. Ma faute est intentionnelle, ou plutôt contrainte.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Mon Dec 06, 2010 9:08 pm    Post subject: Reply with quote

Napoleon wrote:
guilc wrote:
Pour l'écran déformé :
1) X est à la résolution (en fait la dimension) native de l'écran (LCD je suppose) ? Du genre 1920x1200 ou 1920x1080 je suppose.
Si je te suis toujours bien "<largeur>x<hauteur>" deviendra chez moi "1920x1200" (ce qui me convient assez puisque le caution de cette dimension est proche de celui des dimensions de mon écran).


Non non, on ne cherche pas celle qui convient, on recherche la résolution native de l'écran! Cela doit être spécifié dans la documentation de celui-ci! Une autre dimension c'est satan! :twisted:
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Mon Dec 06, 2010 9:25 pm    Post subject: Reply with quote

Visiblement, après un peu de google, il semble que certaines cartes SIS aient besoin d'un bios patché pour utiliser les résolutions 16/10 ou 16/9 (http://www.wimsbios.com/files/vgabiospatched/bios.jsp) comme ce fut le cas à l'époque avec les cartes intel...
Si X n'arrive pas a basculer dans la résolution native (Poussin fait bien d'insister sur ce point) de ton écran, il faudra peut-ere creuser cette piste

69x86 DPI, ouch, tes polices ne doivent pas ressembler à grand chose...
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Mon Dec 06, 2010 11:46 pm    Post subject: Reply with quote

Poussin wrote:
Non non, on ne cherche pas celle qui convient, on recherche la résolution native de l'écran! Cela doit être spécifié dans la documentation de celui-ci! Une autre dimension c'est satan! :twisted:
Bon, déja la documentation de mon écran que j'ai longtemps gardée avant de la jetée (acheté en 2007 quand même) faudra y repassé. Mais qu'importe, j'ai lu dérrière mon écran sa marque "MAG TECHNOLOGY" et le numéro de produit "BP2219W", en fesant des recherches dessus, je suis tomber sur une descriptions :

Quote:
22" TFT Widescreen LCD Monitor w/ DVI • 1680x1050 max resolution • Response time: 5ms • Input: VGA/DVI • Built-in Speakers • 0.285 Dot Pitch


Et ailleurs encore j'ai trouver cela


guilc wrote:
Visiblement, après un peu de google, il semble que certaines cartes SIS aient besoin d'un bios patché pour utiliser les résolutions 16/10 ou 16/9 (http://www.wimsbios.com/files/vgabiospatched/bios.jsp) comme ce fut le cas à l'époque avec les cartes intel...
Il faut dire que j'ai toujours voulu changer de BIOS au profit d'un BIOS libre :D, je pourrais, le temps du flash, me procuré un onduleur (parceque franchement, la panne de courant qui arrive au mauvais moment c'est pas tip top.
Mais je ne comprends pas un détail : Si le liveCD de gentoo (un certain install-x86-minimal-2008.0 je crois) à réussi à m'afficher une résolution correcte, n'est-ce pas la preuve que mon GPU a été correctement reconnu et que ça peut aussi être le cas sur mon installation actuelle ?

guilc wrote:
69x86 DPI, ouch, tes polices ne doivent pas ressembler à grand chose...
Tu ne crois pas si bien dire :/ sur un écran aussi grand (plus de 50cm de large sur 30 de long), les tty m'affichent une résolution de 80 caractères en largeur sur 30 de hauteur. Autant dire qu'un écran plus petit fonctionnerait mieux ...
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Dec 07, 2010 10:41 am    Post subject: Reply with quote

Donc la seule et unique résolution que tu dois utiliser sous X est 1680x1050, rien d'autre, qui donnera nécessairement un mauvais résultat.


Attention, j'ai l'impression que tu mélanges un peu deux choses :
- console, 80x30 caractères => pour changer ça, il faut dans ton cas utiliser le frambuffer sisfb (ou uvesafb), en lui indiquant la bonne résolution. Pour cela, il "suffit" d'activer le driver dans le noyau (http://en.gentoo-wiki.com/wiki/Framebuffer#Framebuffer-specific_Drivers) et de passer la bonne option en ligne de commande.

- sous X : affichage déformé
1) parce que la résolution n'est pas 1680x1050 => à configurer dans le xorg.conf si X ne l'autodétecte pas, ce qu'il sait faire en général, si l'écran parle correctement le EDID)
2) parce que tu as une valeur dpi extrêmement fantaisiste (69x86 !!) => voir plus haut

Ca te fais donc 3 points à configurer ;)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Dec 07, 2010 12:19 pm    Post subject: Reply with quote

guilc wrote:
Donc la seule et unique résolution que tu dois utiliser sous X est 1680x1050, rien d'autre, qui donnera nécessairement un mauvais résultat.
Mais si c'est la bonne résolution à choisir pour mon écran, pourquoi donnera-t-elle nécessairement un mauvais résultat ?



guilc wrote:
Attention, j'ai l'impression que tu mélanges un peu deux choses :
- console, 80x30 caractères => pour changer ça, il faut dans ton cas utiliser le frambuffer sisfb (ou uvesafb), en lui indiquant la bonne résolution. Pour cela, il "suffit" d'activer le driver dans le noyau (http://en.gentoo-wiki.com/wiki/Framebuffer#Framebuffer-specific_Drivers) et de passer la bonne option en ligne de commande.
OK donc c'est réglable ça, au moins.

guilc wrote:
- sous X : affichage déformé
1) parce que la résolution n'est pas 1680x1050 => à configurer dans le xorg.conf si X ne l'autodétecte pas, ce qu'il sait faire en général, si l'écran parle correctement le EDID)
2) parce que tu as une valeur dpi extrêmement fantaisiste (69x86 !!) => voir plus haut
Je ne sais pas si ça augure que X ne saura pas géré ma résolution d'écran, en éditant un fichier de configuration, mais dans un programme KDE "taille et orientation" qui règle la résolution d'écran, les seuls résolution possibles sont la 1280×1024, 1024×768, 800×600 et la 640×480. j'espère, en tout cas, que ça n'a rien à voir avec la possibilité pour X de gérer mon écran.
D'autre part, j'avais lu dans la doc concernant X que si l'on entrait une mauvaise résolution dans le dossier de configuration on risquait d'endommager l'écran « Veuillez utiliser les valeurs indiquées dans le manuel de votre moniteur. Si vous utilisez des valeurs incorrectes, vous pourriez endommager votre écran. ». Suis-je, ne serait-ce qu'un tan soit peut, concerné par ce risque ? Car, à la vérité, je préférerais m'accommodé d'une mauvaise résolution que de perdre mon écran, d'autant que je n'ai pas de quoi me payé un autre :D Ou du moins, savoir les risques que j'en court me fera redoublé de vigilance.


Autre chose : Autant maintenant on incrimine une mauvaise configuration de X, autan j'ai l'impression que dorénavant on écarte de plus en plus la piste du contrôleur graphique. Mais on est-t-on bien certain ? Car le même écran, sur un autre ordinateur avec une distrib' Linux fonctionne sans la moindre configuration.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Dec 07, 2010 1:00 pm    Post subject: Reply with quote

Napoleon wrote:
guilc wrote:
Donc la seule et unique résolution que tu dois utiliser sous X est 1680x1050, rien d'autre, qui donnera nécessairement un mauvais résultat.
Mais si c'est la bonne résolution à choisir pour mon écran, pourquoi donnera-t-elle nécessairement un mauvais résultat ?

Je reformule : toute autre résolution que celle là donnera des mauvais résultats

Quote:
guilc wrote:
- sous X : affichage déformé
1) parce que la résolution n'est pas 1680x1050 => à configurer dans le xorg.conf si X ne l'autodétecte pas, ce qu'il sait faire en général, si l'écran parle correctement le EDID)
2) parce que tu as une valeur dpi extrêmement fantaisiste (69x86 !!) => voir plus haut
Je ne sais pas si ça augure que X ne saura pas géré ma résolution d'écran, en éditant un fichier de configuration, mais dans un programme KDE "taille et orientation" qui règle la résolution d'écran, les seuls résolution possibles sont la 1280×1024, 1024×768, 800×600 et la 640×480. j'espère, en tout cas, que ça n'a rien à voir avec la possibilité pour X de gérer mon écran.
D'autre part, j'avais lu dans la doc concernant X que si l'on entrait une mauvaise résolution dans le dossier de configuration on risquait d'endommager l'écran « Veuillez utiliser les valeurs indiquées dans le manuel de votre moniteur. Si vous utilisez des valeurs incorrectes, vous pourriez endommager votre écran. ». Suis-je, ne serait-ce qu'un tan soit peut, concerné par ce risque ? Car, à la vérité, je préférerais m'accommodé d'une mauvaise résolution que de perdre mon écran, d'autant que je n'ai pas de quoi me payé un autre :D Ou du moins, savoir les risques que j'en court me fera redoublé de vigilance.

X gère absolument n'importe quoi comme résolution, même des résolutions non-standard.
Après, il va limiter les résolution proposées en fonction de la carte graphique, et des informations communiquées par l'écran via EDID sur ce qu'il sait afficher et à quelle fréquence.
On peut "forcer" l'utilisation d'une résolution particulière en ajoutant des "modeline" dans le xorg.conf. Cela est nécessaire soit quand la communication EDID avec l'écran ne se fait pas, ou se fait mal.
La carte graphique peut aussi "refuser" de passer dans la résolution demandée, c'est dans ces cas qu'il faut patcher le bios de la carte graphique. Cela arrive avec certaines cartes qui codent en dur les résolutions possible (les (très) anciennes intel, et visiblement les sis).
Et en pratique, on n'endommage rien : les écrans sont ainsi fait que si on lui envoie un signal hors résolution et/ou hors fréquence, il passe en protection : ça se voit tout de suite, l'écran devient noir, et la petite diode témoins change en général de couleur (sur le mien, elle devient orange clignotant par exemple). Bref, c'est prévu.


Quote:
Autre chose : Autant maintenant on incrimine une mauvaise configuration de X, autan j'ai l'impression que dorénavant on écarte de plus en plus la piste du contrôleur graphique. Mais on est-t-on bien certain ? Car le même écran, sur un autre ordinateur avec une distrib' Linux fonctionne sans la moindre configuration.

On parle de configuration pour bien marcher avec le controleur graphique. Il n'est absolument pas écarté. Seulement, suivant les distribs, les outils d'autodétection installés ne sont pas nécessairement les mêmes, donc le résultat final pas forcément le même. Sous Gentoo, c'est relativement "nu", donc faut mettre les mains dans le cambouis ;)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Dec 07, 2010 1:51 pm    Post subject: Reply with quote

Au passage, mets nous quelque part ton /Var/log/Xorg.0.log
Qu'on voie un petit peu l'état des lieux :)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Dec 07, 2010 2:13 pm    Post subject: Reply with quote

guilc wrote:
Au passage, mets nous quelque part ton /Var/log/Xorg.0.log
Qu'on voie un petit peu l'état des lieux :)


Si tu parles bien de /var/log/Xorg.0.log (attention à la casse !) et je pense que c'est celui là, eh bien le voici.


EDIT :

guilc wrote:
Seulement, suivant les distribs, les outils d'autodétection installés ne sont pas nécessairement les mêmes, donc le résultat final pas forcément le même. Sous Gentoo, c'est relativement "nu", donc faut mettre les mains dans le cambouis ;)
Je n'ai absolument aucun problème avec ça :D Seulement je me demandais si une solution simple et tout aussi fonctionnelle ne consisterait pas à lancé mon liveCD et à copier les fichiers de configuration qu'il a généré à fin de, si ce n'est les copier brutalement, s'en inspiré pour éditer mon propre fichier de conf.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Dec 07, 2010 2:39 pm    Post subject: Reply with quote

Tiens tiens...
Dans ton fichier de log on apprends que l'écran envoie bien le mode qu'il faut via EDID :
Code:
Modeline "1680x1050"x0.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz)



MAIS, X a décidé de choisir le driver "vesa" au lieu du driver "sis". Avec le driver vesa (aui est un driver générique qui marche sur toutes les cartes), seules les résolutions... vesa sont disponibles ! Donc pas la résolution de ton écran => tu bascules en 1280x1024

Essaye de rajouter un truc dans ce genre dans ton xorg.conf pour forcer xorg à choisir le driver sis au lieu du driver vesa :
Code:
Section "Device"
Identifier "Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter"
Driver "sis"
BusID "PCI:1:0:0"
EndSection

_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Dec 07, 2010 3:40 pm    Post subject: Reply with quote

guilc wrote:

Essaye de rajouter un truc dans ce genre dans ton xorg.conf pour forcer xorg à choisir le driver sis au lieu du driver vesa :
Code:
Section "Device"
Identifier "Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter"
Driver "sis"
BusID "PCI:1:0:0"
EndSection
J'ai fais cela en copiant xorg.conf.exemple en xorg.conf puis on y ajoutant la section sus-cité. Sauf qu'après avoir tué X, ce dernier n'arrive pas à re-démarrer et m'affiche un message d'erreur dont voila tout ce que j'ai pu en copier avec GPM, avant qu'il ne disparaisse :

Code:
rg X Server 1.7.7                                                     │
 │ Release Date: 2010-05-04                                                 │
  │ X Protocol Version 11, Revision 0                                        │
   │ Build Operating System: Linux 2.6.34-gentoo-r12 i686                     │
    │ Current Operating System: Linux OperateurNoir 2.6.34-gentoo-r12 #3 SMP S │
     │ Kernel command line: root=/dev/sda3                                      │
      │ Build Date: 06 December 2010  05:37:35PM                                 │
       │                                                                          │
        │ Current version of pixman: 0.18.2                                        │
    │        Before reporting problems, check http://wiki.x.org                │
     │        to make sure that you have the latest version.                    │
      │ Markers: (--) probed, (**) from config file, (==) default setting,       │
       │        (++) from command line, (!!) notice, (II) informational,          │
        │        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.     │
         │ (==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec  7 15:29:17 2010     │
          │ (==) Using config file: "/etc/X11/xorg.conf"                             │
           │ (==) ServerLayout "Main Layout"             
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Dec 07, 2010 4:07 pm    Post subject: Reply with quote

Le message d'erreur n'est pas la dedans.
Remets le nouveau /var/log/Xorg.0.log => il doit contenir l'erreur
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Dec 07, 2010 4:20 pm    Post subject: Reply with quote

le voici le nouveau.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Dec 07, 2010 4:37 pm    Post subject: Reply with quote

On dirait que c'est le même qu'avant. C'est le log d'un serveur X qui démarre ça.
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Dec 07, 2010 4:52 pm    Post subject: Reply with quote

Effectivement, il n'y a pas d'erreur et c'est toujours vesa qui gère l'affichage. Pourrais-tu nous donner ton /etc/X11/xorg.conf ainsi que le retour de 'lspci' ?

Rien à voir : c'est volontaire la disposition de clavier "us" ?
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Dec 07, 2010 4:53 pm    Post subject: Reply with quote

guilc wrote:
On dirait que c'est le même qu'avant. C'est le log d'un serveur X qui démarre ça.
si les dernières lignes montrent que X démarre c'est que, aprés que le démmarage échoua, j'ai supprimer xorg.conf et relancé X, qui cette fois-ci réussi mais avec toujours une mauvaise résolution d'écran évidement.
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Dec 07, 2010 6:13 pm    Post subject: Reply with quote

Napoleon wrote:
guilc wrote:
On dirait que c'est le même qu'avant. C'est le log d'un serveur X qui démarre ça.
si les dernières lignes montrent que X démarre c'est que, aprés que le démmarage échoua, j'ai supprimer xorg.conf et relancé X, qui cette fois-ci réussi mais avec toujours une mauvaise résolution d'écran évidement.

Le fichier /etc/var/log/Xorg.0.log ENTIER renseigne sur le dernier démarrage de Xorg... Donc en plus des requêtes de mon précédent message (que tu as du manquer car tu écrivais, en même temps, ton message) tu as gagné le droit de nous communiquer, de nouveau, /etc/var/log/Xorg.0.log mais, cette fois, juste après le "crash". Tu peux par exemple le déplacer dans ton répertoire personnel ('mv /etc/var/log/Xorg.0.log ~') avant de supprimer la configuration de X qui pose problème (ou plutôt de la déplacer : "mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak" pour ne pas avoir à tout réécrire si nous trouvons une erreur minime) et de relancer Xorg ('startx') depuis lequel tu nous communiqueras ~/Xorg.0.log.
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Dec 07, 2010 7:17 pm    Post subject: Reply with quote

Magic Banana wrote:
Rien à voir : c'est volontaire la disposition de clavier "us" ?
Euh, non je n'ai pas de disposition us, j'ai azerty sur X et sur les TTY.

Pour le /etc/X11/xorg.conf je l'ai rm juste après, pour pouvoir redémarrer X. et voici mon lspci.
(Petit aparté : j'utilise wgetpaste depuis root, dois-je évité de faire une pareille chose ?)


Magic Banana wrote:
tu as gagné le droit de nous communiquer, de nouveau, /etc/var/log/Xorg.0.log mais, cette fois, juste après le "crash". Tu peux par exemple le déplacer dans ton répertoire personnel ('mv /etc/var/log/Xorg.0.log ~') avant de supprimer la configuration de X qui pose problème (ou plutôt de la déplacer : "mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak" pour ne pas avoir à tout réécrire si nous trouvons une erreur minime) et de relancer Xorg ('startx') depuis lequel tu nous communiqueras ~/Xorg.0.log.
Je réedite la mauvaise configuration, relance X pour en récupéré le xorg.conf et vous dit quoi.
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Dec 07, 2010 7:43 pm    Post subject: Reply with quote

voici /etc/var/log/xorg.0.log tel qu'il était immédiatement après l'échec de redémarrage de Xorg
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Dec 07, 2010 7:50 pm    Post subject: Reply with quote

Erf, la, je demande a voir la conf xorg.conf que tu as mise, parce que il échoue à charger le driver... matrox...
A mon avis, tu as un souci dans ce fichier de configuration.

Pas besoin qu'il soit complet : de nos jous, l'autodétection marche plutôt bien. Un fichier xorg.conf avec SEULEMENT la section device pour sis devrait suffire...
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Dec 07, 2010 8:01 pm    Post subject: Reply with quote

voici le xorg.conf que j'ai utilisé, la section que tu m'as dit d'ajouté est tout à la fin.

Last edited by Napoleon on Tue Dec 07, 2010 8:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2, 3, 4  Next
Page 1 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum