Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[mplayer/vdpau] 720p qui saccade :s
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Thu Dec 02, 2010 6:59 pm    Post subject: [mplayer/vdpau] 720p qui saccade :s Reply with quote

Bonjours, j'utilise actuelement mplayer-9999 pour lire mes video sous ma chere gentoo ~amd64 mais voila: la vdpau saccade énormément et ce meme avec de la 720p et les derniers drivers nvidia a jours (je viens de les compiler a l'instant)

coté mplayer j'ai:

Code:
adamaru@StarK ~ $ emerge -vp mplayer

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-video/mplayer-9999  USE="X a52 alsa ass cddb cdio dirac dts dv dvd dvdnav enca encode external-ffmpeg faac faad gif iconv ipv6 jpeg libcaca live mad mmx mng mp3 network opengl osdmenu png quicktime rar real rtc samba schroedinger sdl shm speex sse sse2 ssse3 theora toolame tremor truetype twolame unicode vdpau vorbis x264 xscreensaver xv xvid xvmc -3dnow -3dnowext -aalib (-altivec) -amr (-aqua) -bidi -bindist -bl -bluray -bs2b -cdparanoia -cpudetection -custom-cpuopts -debug -dga -directfb -doc -dvb -dxr3 -esd -fbcon -ftp -ggi -gsm -jack -joystick -jpeg2k -ladspa -libmpeg2 -lirc -lzo -md5sum -mmxext -mpg123 -nas -nut -openal -oss -pnm -pulseaudio -pvr -radio -rtmp -tga -v4l -v4l2 (-vidix) -vpx (-win32codecs) -xanim -xinerama -zoran" VIDEO_CARDS="-mga -s3virge -tdfx -vesa" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


coté config de mplayer (niveau utilisateur)
Code:
adamaru@StarK ~ $ cat ~/.mplayer/config
# Write your default config options here!

# Virer xscreesaver pendant le visionage \o/
stop-xscreensaver="yes"
utf8=1
subcp=cp1252
vo=vdpau
vc=ffh264vdpau,

niveau usage du cpu: pour ainsi dire null
coté materiel la cg est une nvidia GT240 et le cpu est un I3 cadencé a 3.6ghz

une idée pour cette vdpau "defectueuse" ?
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Dec 02, 2010 8:00 pm    Post subject: Reply with quote

Accessoirement, sans vdpau ça marche fluide ?
Parce que bon, un core i3 c'est largement suffisant pour du 720p...

Si sans vdpau ça saccade => fichier pourri mal encodé. Sinon, problème de vdpau.
Ca permettra déjà d'isoler le problème à ce niveau :)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Thu Dec 02, 2010 11:45 pm    Post subject: Reply with quote

effectivement: ca saccade encore même en xv, étrange :s
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Fri Dec 03, 2010 12:21 am    Post subject: Reply with quote

Donc essaye avec d'autres fichiers HD. ça ne devrait absolument pas saccader sur un core i3, même en 1080p
essaye par exemple http://www.sintel.org/ qui marche très bien chez moi sur mon Q9300 et même sur mon laptop en SL9400 en xv, même dans sa version format cinéma 2K (2048). La, je vote pour un problème relatif au fichier HD lui même, pas à mplayer ni à vdpau

[EDIT]
Et accessoirement, pas besoin de la version 9999 : la version ~amd64 convient tout à fait pour ça, ça fait un moment que le nécessaire pour faire du vdpau des inclu dans cette version !
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Fri Dec 03, 2010 2:22 pm    Post subject: Reply with quote

J'ai eu un problème récemment avec un fichier en 60fps, en effet mplayer se synchronise sur le rafraîchissement de l'écran et la plupart des dalles LCD/TFT/ton_acronyme_favori reportent une fréquence de 50 ou 60Hz seulement. Si c'est ton cas ça se résoud très facilement avec un -framedrop dans la ligne de commande (ou dans le mplayer.conf).
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Fri Dec 03, 2010 7:47 pm    Post subject: Reply with quote

j'ai testé avec le meme fichier mais en le lisant depuis vlc sous un windows (passage par samba) : aucun probleme

coté saccades en fait je n'ai pas été tres "clair" , le film "parait" fluide mais on vois que par moment ca "raccroche" genre un dixieme de seconde mais on ne voit que ça
coté usage de la 9999 c'est surtout car jessaie de gagner des prefs pour mes encodages avec mencoder que j''utilise derriere mediatomb

j'ai testé avec le -framedrop : le probleme perssiste :'(

je viens de tester avec un vlc "local" : meme probleme :s
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Sun Dec 05, 2010 2:39 pm    Post subject: Reply with quote

Je serais aussi curieux de connaitre le framerate de ta video, car chez moi c'est ce qui fout tout en l'air niveau perf. J'ai une conf bien plus modeste, et je n'utilise pas les drivers proprio nvidia, donc pas de vdpau
Souvent framedrop empire les choses, surtout avec x264. Essaye aussi le -nocache
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Sun Dec 05, 2010 11:22 pm    Post subject: Reply with quote

Code:
adamaru@StarK ~ $ mplayer /mnt/Zeus/movies/Inception.mkv
MPlayer 32672-4.4.5 (C) 2000-2010 MPlayer Team
Lecture de /mnt/Zeus/movies/Inception.mkv
Fichier de type libavformat détecté.
[matroska,webm @ 0x940320] max_analyze_duration reached
[matroska,webm @ 0x940320] Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (h264), -vid 0, Inception.2010.MULTi.1080p.BluRay.x264-DREAM
[lavf] stream 1: audio (ac3), -aid 0, -alang fre, Français VFF Ac3 5.1 @ 640 kbps
[lavf] stream 2: audio (dca), -aid 1, -alang eng, Anglais DTS-HD MA @ 3689 kbps
[lavf] stream 3: subtitle (unknown), -sid 0, -slang fre, Français forcé
[lavf] stream 4: subtitle (unknown), -sid 1, -slang fre, Français
VIDEO:  [H264]  1920x1080  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Information sur le clip :
 title: Inception.2010.MULTi.1080p.BluRay.x264-DREAM
==========================================================================
Codec vidéo forcé : ffh264vdpau
Ouverture du décodeur vidéo : [ffmpeg] FFmpeg's libavcodec codec family
Codec vidéo choisi : [ffh264vdpau] vfm : ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Ouverture décodeur audio : [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 640.0 kbit/41.67% (ratio: 80000->192000)
Codec audio sélectionné : [ffac3] afm : ffmpeg (FFmpeg AC-3)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Démarre la lecture...
[VD_FFMPEG] Essaie pixfmt=0.
L'aspect du film est 1.78:1 - pré-redimensionnement à l'aspect correct.
VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration
[VD_FFMPEG] MPEG2 accéléré XVMC.


Code:
adamaru@StarK ~ $ ls -ash /mnt/Zeus/movies/Inception.mkv
17G /mnt/Zeus/movies/Inception.mkv


avec le -nocache le probleme persiste tout de meme
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Wed Dec 08, 2010 2:35 pm    Post subject: Reply with quote

Bon, déjà ta video est en 1080p, et 17G çà fait un beau 1080p
Sinon, 24 fps, donc ntsc classique. Pour info, ce genre de video est normalement fluide chez moi avec un petit core2duo/ich9, une 8400GS, driver libre nouveau.
Ensuite, vdpau je n'utilise pas : as tu essayé sans ?
Enfin, 2 pistes :
rechercher "fast" et "skiploopfilter" dans la conf de mplayer et appliquer ces options SANS vdpau (elles ne marchent pas avec)
utiliser la version dev de mplayer multithreadé : recherche ici "mplayer multithread"
Espérant aider
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Wed Dec 08, 2010 6:15 pm    Post subject: Reply with quote

Question bête mais est-ce normal :
Code:
VIDEO:  [H264]  1920x1080  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)


Me semble qu'il y a beaucoup de 0 sur cette ligne ... je pencherai pour un encodage foireux, ou au moins une entête tronquée/illisible (c'est ballot pour un fichier de 17Go).
_________________
Ez.
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Thu Dec 16, 2010 7:56 pm    Post subject: Reply with quote

hum je penche aussi vers un encodage foireu étant donné que toutes les options que m'a indiqué razer ne changent rien, vlc est apparement plus "tolérant" avec ce genre de fichiers, mais je préfere de loin l'interface de mplayer (minimaliste mais efficace)

je trouve tout de meme étonant que mplayer se fasse batre par vlc a ce niveau O_o
[hs]c'est vrais que mencoder n'est plus supporté/developé ? j'ai vu ca sur un fofo et j'ai manqué l'arret cardiaque[/hs]
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Thu Dec 16, 2010 11:08 pm    Post subject: Reply with quote

MEncoder fait partie du projet MPlayer, maintenant ça dépend d'où le gars sort son info. C'est sur que si ça fait 1 ans qu'il est sur le tag rc3 de mplayer il a de quoi penser que rien ne bouge ... alors qu'en fait voila t'as 1 ou 2 tag rc4 par mois :lol:
_________________
Ez.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum