Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge]Failed Patch cups-1.3.11-pdf-m4.patch(résolu)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Fri Dec 03, 2010 2:43 pm    Post subject: Reply with quote

Napoleon wrote:
Code:
# emerge -p dev-perl/XML-Parser

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-perl/XML-Parser-2.36-r1


Code:
# emerge -p dev-util/intltool

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-util/intltool-0.41.1

Cela signifie que dev-util/intltool, tout comme dev-perl/XML-Parser dont il dépend, sont installés. Pourtant tu nous as montré que la configuration (et donc l'installation) de dev-util/intltool échoue pour cause de dev-perl/XML-Parser absent ! Y a-t-il quelqu'un ici qui comprenne quelque chose :?:
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Fri Dec 03, 2010 2:45 pm    Post subject: Reply with quote

Oui : perl-cleaner --all
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Fri Dec 03, 2010 2:50 pm    Post subject: Reply with quote

[quote="boozo"
Donc 1° refait un #emerge --sync ; vire ce -cups de je ne sais pas trop ou tu l'a mis et reprend dans l'ordre les choses pour world on verra ensuite pour remettre d'aplomb quand tu auras un environnement graphique (et relu la doc :twisted: )[/quote]J'ai donc mis à jour l'arbre de portage (je ne le referais pas aujourd'hui car, selon la doc ce n'est pas une bonne netiquette que de le faire trop souvent ;) comme quoi je l'ai lue cette doc !) puis j'ai enlever -cups de USE, refait un emerge -vaNuD world et au bout du 13ème (un comble) paquet sur 26 j'ai eu :

Code:
!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/gnome-base/libbonobo-2.24.3/work/libbonobo-2.24.3/config.log
que voici
et un peut plus bas :
Code:
>>> Failed to emerge gnome-base/libbonobo-2.24.3, Log file:

>>>  '/var/log/portage/gnome-base:libbonobo-2.24.3:20101203-142458.log'
que voila

Mais je vous rassure, ces derniers temps j'ai très peut de chance en tout pas qu'avec Gentoo, Donc c'est à peut prés normal que s'il y'avait une chance sur un million pour que ça foire ce soit avec moi :D Murfy powaaaa !


Poussin wrote:
On ne sera probablement pas d'accord avec moi, mais je vais le dire quand même. Je trouve que ce n'est pas une bonne idée d'installer tout depuis le chroot. Une fois ce qui est nécessaire installer, autant redémarrer dans ton nouvel environnement et tout installer depuis cet endroit. J'ai jadis utilisé ta méthode (en 2004, ça a peut-être changé) mais j'ai eu des soucis.
Tu t'en doutais un peut, mais personnellement je ne vois pas ce que ça change fondamentalement que se soit en chroot ou nativement.

Poussin wrote:
Je ne pense pas que tu doives réinstallé tout depuis le début. Gentoo n'est jamais mal installé. Malgré ce que tu en penses, je suis d'accord avec boozo pour dire que tu as du tombé sur une version de l'arbre portage avec une coquille dedans (à une heure près ça peut avoir été corrigé).
Je ne pense pas non plus que ce soit une bonne chose de reprendre à zéro mais, maintenant je me souviens que quand j'avais des problème à demmarer X et que ce problème tout bête se résumait à installer un DM, le message d'erreur de X incluait une autre erreur à la résolution de laquelle j'ai peut être un peut trop trifouillé, car c'est depuis ce moment là que je ne m'en sort plus.


Poussin wrote:
Si tu as encore un soucis avec XML-parser. Si cela n'a pas été fait, tu peux toujours emerge -av1 XML-parser. Si cela a été fait: perl-cleaner --all
Déja fait comme dit plus haut, avec un message d'erreur.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Fri Dec 03, 2010 2:55 pm    Post subject: Reply with quote

Tu as bien fait
Code:

perl-cleaner --all
??
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Fri Dec 03, 2010 3:04 pm    Post subject: Reply with quote

Poussin wrote:
perl-cleaner --all

guilc wrote:
Oui : perl-cleaner --all

C'est que ça en dit des choses. Bon c'est bourin de tout copier mais sai-t-on jamais XD
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Fri Dec 03, 2010 3:19 pm    Post subject: Reply with quote

Bah laisse le finir : ca veut dire que tu as fait une MAJ de perl, mais que les modules sont toujours compilés pour l'ancienne version de perl.
perl-cleaner --all les recompile. (la marche à suivre était décrite dans le message de fin d'emerge de perl : il faut lire les messages d'elog :P )
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Fri Dec 03, 2010 3:19 pm    Post subject: Reply with quote

Ca c'est arreté sur une erreur? parce que dans ce que tu as collé, il est au 3eme package de ce qu'il a détecté comme "à fixer" et il fait son boulot.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Fri Dec 03, 2010 3:21 pm    Post subject: Reply with quote

guilc wrote:
Bah laisse le finir : ca veut dire que tu as fait une MAJ de perl, mais que les modules sont toujours compilés pour l'ancienne version de perl.
perl-cleaner --all les recompile. (la marche à suivre était décrite dans le message de fin d'emerge de perl : il faut lire les messages d'elog :P )


ET dans eselect:
Code:

eselect news list
...
  [1]   read    2010-10-22  Perl 5.12 upgrade procedure
...


D'où, le message plus haut, au milieu de lire la doc et les elog -> eselect news :)
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Fri Dec 03, 2010 5:18 pm    Post subject: Reply with quote

guilc wrote:
Bah laisse le finir : ca veut dire que tu as fait une MAJ de perl, mais que les modules sont toujours compilés pour l'ancienne version de perl.
perl-cleaner --all les recompile. (la marche à suivre était décrite dans le message de fin d'emerge de perl : il faut lire les messages d'elog :P )
Donc après avoir fait perl-cleaner --all (dont le rendu est présent dans un précédant post) ça a du arrangée ?
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Fri Dec 03, 2010 5:36 pm    Post subject: Reply with quote

Napoleon wrote:
guilc wrote:
Bah laisse le finir : ca veut dire que tu as fait une MAJ de perl, mais que les modules sont toujours compilés pour l'ancienne version de perl.
perl-cleaner --all les recompile. (la marche à suivre était décrite dans le message de fin d'emerge de perl : il faut lire les messages d'elog :P )
Donc après avoir fait perl-cleaner --all (dont le rendu est présent dans un précédant post) ça a du arrangée ?

Le "rendu" comme tu dis (ça s'appelle en fait une "sortie") de 'perl-cleaner --all' que tu nous as montré n'est pas complet. Si tu l'a laissé procéder jusqu'à la fin et qu'il s'est terminé sans erreur, il y a moyen que tout aille pour le mieux dans le meilleur des mondes (ou, précisément, que la configuration précédant l'installation de dev-util/intltool se passe sans encombres).
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Fri Dec 03, 2010 6:05 pm    Post subject: Reply with quote

en effet banana, je l'ai laissé finir jusqu'au bout sans aucune erreur, je vais maintenant tenter un emerge -vaNuD world
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Fri Dec 03, 2010 7:51 pm    Post subject: Reply with quote

Victoire, il semblerais que le dernier emerge -vaNuD world n'ai renvoyé aucune erreur (c'est vous dire que je ne m'y attendais plus si bien que dans mon esprit emerge commençait a être associé aux erreurs qu'il renvois :D) !

Je pense que je n'aurais peut être plus d'erreur, je vais ajouté certaines variables USE (dont j'aurais bientôt besoin) pour voir ce que donne emerge -vaNuD world avec.
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Fri Dec 03, 2010 10:16 pm    Post subject: Reply with quote

Et le "résolu" ? Où est-il dans le titre ? :wink:
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Fri Dec 03, 2010 10:43 pm    Post subject: Reply with quote

Magic Banana wrote:
Et le "résolu" ? Où est-il dans le titre ? :wink:
J'attendais la fin d' l'emerge -vaNuD world mais … :/ il ne m'a sorti aucune erreur ! Samba ! (désolé pour flash).

Pour information, j'ai aussi ajouté quelques autres USEs par la suite et re-emerger mon world sans erreur non plus, je vais alors emerger KDE pour voir ce que ça donne.

Néanmoins, je pense affirmé sans me trompé que le sujet est bel et bien résolu, grâce aux interventions de chaqu'un, chapeau blanc à tout le monde bana (qui pour le coup est vraiment magic), boozo, poussin, guilc (auquel je cède les droit sur les photographies qu'il prend de moi) et Ezka ! Merci de m'avoir ouvert les portes de gentoo.

Merci encore.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Fri Dec 03, 2010 11:13 pm    Post subject: Reply with quote

Napoleon wrote:
guilc (auquel je cède les droit sur les photographies qu'il prend de moi)

ou ça ou ça ?
L'avatar c'est un autoportrait :p
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Fri Dec 03, 2010 11:42 pm    Post subject: Reply with quote

guilc wrote:
Napoleon wrote:
guilc (auquel je cède les droit sur les photographies qu'il prend de moi)

ou ça ou ça ?
L'avatar c'est un autoportrait :p
MDR, je fesais allusion au fait que, vue de chez les autres membres du forum, ça donnait l'impression que tu les prenais en photographie, d'où le fait que je te cède les droits sur les clichés que prends ton avatard :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum