Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[X.org]startx ne demare pas[resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Nov 30, 2010 1:44 pm    Post subject: [X.org]startx ne demare pas[resolu] Reply with quote

Bonjour,

Je viens de finir mon installation de Gentoo, et suis à l'étape 12, comme je souhaite installer KDE, la page relative à cette étape ma dirigée vers la documentation Gentoo relative au bureau. Dans cette page il y avais bien un lien vers le guide de configuration de KDE, mais j'ai présumé que cette page de documentation, affin d'être mené à bien requerrait, d'avoir suivit, au préalable, le guide de configuration de X.
C'est ce que je fit, tout d'abord, evdev est bien compilé en dure avec mon noyau, puis, j'ai réalisé mon make.conf (et tout particulièrement les variable VIDEO_CARDS) à l'aide d'un membre de #gentoofr :

Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"
MAKEOPTS="-j3"
VIDEO_CARDS="vesa sis"
INPUT_DEVICES="evdev"
USE="3dfx  -3dnow  X  -Xaw3d  a52  aac  aalib  accessibility  acl  acpi  -aim  alsa  -altivec  ao  apm  atm  avahi  bash-completion  bcmath  bidi  -bluetooth bzip2  calendar  caps  cdda  cddb  cdinstall  cdparanoia  cdr  cjk  clamav  cracklib  crypt  cscope  css  cups  cvs  cxx  dbase  dga  djvu  dv  dvd  dvdr  emacs  encode  enscript  esd  evo  exif  fbcon  ffmpeg  firefox  flac  ftp  gif  gimp  ginac  gnome  gnustep  gpm  gtk  gzip  handbook  icu  imagemagick  imap  inifile     -ipod  ipv6  jabber  jack  jingle  -joystick  jpeg  jpeg2k  kde  kontact  lame  latex  lcms  libcaca  libgda  libnotify  lirc  lm_sensors lzma  lzo  mad  maildir  mailwrapper  matroska  matrox  mbox  milter  mime  mng  modules  mozilla  mp3  mp4  mpeg  mpi  mplayer  mtp  musepack  nas  netboot  netcdf  networkmanager  nntp  nptl  nsplugin  ogg  old-linux  openal  openexr  osc  oss  pdf  plasma  plotutils  png  posix  pulseaudio  qmail-spp  qt4  quicktime  radius  raw  rss  sasl  semantic-desktop  skey  smp  snmp  source  speex  spell  svg  svga  syslog  szip  theora  tiff  truetype  udev  unicode     usb  v4l  v4l2  vcd  vim-syntax  vnc  vorbis  wavpack  x264  xface  xml  xscreensaver  xvid  zsh-completion "

GENTOO_MIRRORS="rsync://gentoo.c3sl.ufpr.br/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/ ftp://trumpetti.atm.tut.fi/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ http://mirror.ovh.net/gentoo-distfiles/ http://de-mirror.org/distro/gentoo/ ftp://de-mirror.org/distro/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo http://mirror.netcologne.de/gentoo/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp6.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp6.uni-muenster.de/pub/linux/distributions/gentoo http://gentoo.channelx.biz/ http://gentoo-euetib.upc.es/mirror/gentoo/"
D'ailleurs, pour en vérifier la cohérence, voici le rendu de lspci -vv

après quoi, j'ai bien fait dans l'ordre :

Code:
# env-update
# source /etc/profile
# /etc/init.d/hald start
# rc-update add hald default


mais au moment de faire startx, j'ai eu, un instant, un écran noir, puis aussitôt j'ai eu de nouveau mon tty avec le message d'erreur suivant :
Code:
xauth:  creating new authority file /root/.serverauth.4087


X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.34-gentoo-r12 i686
Current Operating System: Linux OperateurNoir 2.6.34-gentoo-r12 #2 SMP Sun Nov 28 20:53:07 Local time zone must be set--see zic  i686
Kernel command line: root=/dev/sda3
Build Date: 30 November 2010  02:30:33AM
 
Current version of pixman: 0.18.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 30 13:17:17 2010
(==) Using default built-in configuration (30 lines)
(EE) Failed to load module "fbdev" (module does not exist, 0)
/etc/X11/xinit/xinitrc: line 58: twm: command not found
/etc/X11/xinit/xinitrc: line 62: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 60: xterm: command not found


waiting for X server to shut down error setting MTRR (base = 0xd0000000, size = 0x08000000, type = 1) Inappropriate ioctl for device (25)



Ne voyant pas trop ou se situerait mon erreur je viens sollicité votre aimable assistance,
Un grand merci par anticipation,

À bientôt,

Bonne journée !


Last edited by Napoleon on Wed Dec 01, 2010 12:00 am; edited 1 time in total
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Nov 30, 2010 1:57 pm    Post subject: Reply with quote

Napoleon wrote:
Code:
/etc/X11/xinit/xinitrc: line 58: twm: command not found
/etc/X11/xinit/xinitrc: line 62: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 60: xterm: command not found


Manifestement tu n'as installé ni gestionnaire de fenêtres (X essaie de lancer 'twm', le gestionnaire de fenêtre le plus basique du monde) ni terminal X (X essaie de lancer 'xterm', le terminal X le plus basique du monde). Installe donc KDE !

EDIT : lis-tu les documentations que tu nous pointes ?
Guide de configuration de X wrote:
Si vous n'avez pas encore installé de gestionnaire de fenêtres, tout ce que vous verrez sera un écran noir. Comme cela peut également signifier qu'il y a un problème dans la configuration, il est recommandé d'installer twm ou xterm uniquement pour tester que X tourne bien.

Une fois que l'un de ces programmes est installé, relancer startx. Quelques fenêtres xterm devraient alors apparaître, ce qui permet plus facilement de vérifier que X fonctionne correctement. Une fois que vous êtes satisfait du résultat, vous pouvez désinstaller ces paquets de test avec la commande emerge --unmerge twm xterm exécutée en tant que super utilisateur root. Vous n'avez plus besoin d'eux une fois que votre environnement de bureau est configuré.
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Nov 30, 2010 2:03 pm    Post subject: Reply with quote

:oops: Tout bêtement… :D je vais tester ça magic banana (la honte), et c'était juste à la suite en plus…
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Nov 30, 2010 2:40 pm    Post subject: Reply with quote

On me dit dans la salon IRC, qu'avant cette erreure de dwm , il y a tout de même une erreur avec fbdev « (EE) Failed to load module "fbdev" (module does not exist, 0) » et au vu de :

Code:
 # emerge -vpN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "net-dns/avahi[mdnsresponder-compat]".
!!! One of the following packages is required to complete your request:
- net-dns/avahi-0.6.25-r1 (Change USE: +mdnsresponder-compat)
(dependency required by "net-print/cups-1.3.11-r3" [ebuild])
(dependency required by "x11-libs/gtk+-2.20.1-r1" [ebuild])
(dependency required by "app-editors/emacs-23.2-r2" [ebuild])
(dependency required by "virtual/emacs-23" [ebuild])
(dependency required by "app-emacs/autoconf-mode-2.65" [ebuild])
(dependency required by "sys-devel/autoconf-2.65-r1" [ebuild])
(dependency required by "world" [argument])


On m'a conseillé de faire :

Code:
# echo 'net-dns/avahi mdnsresponder-compat' >> /etc/portage/package.use
#emerge -vpN

Tout est OK dedan ?
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Nov 30, 2010 4:25 pm    Post subject: Reply with quote

Lis les messages d'erreur avant de nous demander de le faire !
Code:
Change USE: +mdnsresponder-compat


Mieux : essaie de comprendre ce que tu fais en lisant la documentation officielle francophone sur la variable USE.

Le message d'erreur, comme les gentooistes de l'IRC, te suggère l'ajout d'un paramètre à cette variable USE. La commande que les gentooistes de l'IRC t'ont indiquée ne modifie cette variable USE que pour un paquet spécifique (paragraphe "Déclarer des paramètres USE spécifiques à des paquets" dans la documentation pointée ci-dessus).
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Nov 30, 2010 5:17 pm    Post subject: Reply with quote

merci pour la précision Magic Banana,

j'ai fait cela, pour plusieurs paquets, jusqu'à tomber sur une dépendance circulaire. Le gentooiste qui m'épaulait m'a indiqué qu'un paramètre de la variable USE devait être défectueux, et qu'il n'y avait d'autre solution que de tâtonner jusqu'à ne plus avoir de dépendance circulaire circulaire, c'est ce que je fit jusqu'à isoler le paramètre "avahi" sans lequel emerge -vpN n'affichait pas de dépendance circulaire.

Le gentooiste en question, qui était parti depuis quelques minutes, m'avais précisé que dés qu'il n'y avait plus de dépendance circulaire, je n'avais plus qu'à vérifier qu' « avec -vpN qu'il n'y a pas d'erreur » pour entamer des instructions qu'il m'a données.

Mais, n'ai-je bien plus d'erreur dans le résultat d'emerge -vpN ?

EDIT : NOn en fait y'en a pas :D
Back to top
View user's profile Send private message
Magic Banana
Veteran
Veteran


Joined: 13 Dec 2005
Posts: 1906
Location: Belo Horizonte, Minas Gerais, Brasil

PostPosted: Tue Nov 30, 2010 6:44 pm    Post subject: Reply with quote

156 paquets à installer : pratique pour réchauffer un empereur par ce froid sibérien. Ça pourrait même t'éviter une Bérézina ! De mon côté, j'ai trouvé une autre solution au froid que la compilation de masse : la migration vers le Brésil (on frôle les 30°C là :P ).

EDIT : sinon, ton serveur X, il démarre ? Si oui, ajoute donc un petit "résolu" au titre de ce fil.
Back to top
View user's profile Send private message
Napoleon
Apprentice
Apprentice


Joined: 03 Nov 2010
Posts: 283

PostPosted: Tue Nov 30, 2010 11:58 pm    Post subject: Reply with quote

Magic Banana wrote:
156 paquets à installer : pratique pour réchauffer un empereur par ce froid sibérien. Ça pourrait même t'éviter une Bérézina ! De mon côté, j'ai trouvé une autre solution au froid que la compilation de masse : la migration vers le Brésil (on frôle les 30°C là :P ).

EDIT : sinon, ton serveur X, il démarre ? Si oui, ajoute donc un petit "résolu" au titre de ce fil.
mdr, cest pas de bon coeur que je le fais, mon serveur X demarre bien. Parcontre, si jai tarder a repondrem cest que je travaillais a linstallation de kde [installation qui a echouee come toute les tentatives dinstalation dun navigateur graphique...], jaitais juste venu tager le sujet en resolu :D
PS: men voulez pas si jecris mal cest juste que jai pas trouver le temps de changer ma disposition de clavier.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum