Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XFCE4.7] Comment éteindre ou redémarrer (presque résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
debimax
n00b
n00b


Joined: 14 Nov 2010
Posts: 16
Location: Grenoble

PostPosted: Tue Nov 23, 2010 4:20 pm    Post subject: [XFCE4.7] Comment éteindre ou redémarrer (presque résolu) Reply with quote

Bonjour

Je viens de basculer ma gentoo en ~x86 et j'ai donc la nouvelle version de xorg et d'xfce.
Je n'arrive plus à dégriser éteindre ou redémarrer

C'était géré jusqu'à présent avec hal mais xorg n'utilsant plus hal il ne serait pas étonnant qu'xfce change aussi.

Je n'arrive pas à trouver sur le net si quelqu'un peut m'aider.

Merci


Last edited by debimax on Sat Nov 27, 2010 9:27 am; edited 1 time in total
Back to top
View user's profile Send private message
chris256
n00b
n00b


Joined: 04 Jun 2006
Posts: 21

PostPosted: Tue Nov 23, 2010 10:42 pm    Post subject: Reply with quote

Bonjour,



Ce problème est présent dans la F.A.Q d' Xfce

La solution avec sudo marche trés bien , par contre dans mon cas le bon chemin c'est :

Code:
/usr/lib64/xfce4/session/xfsm-shutdown-helper


Donc à verifier .Il me semble qu'il y a également une autre méthode avec consolekit/polkit mais je n'ai jamais essayé .
_________________
Sorry for my bad English , I'm French .
Back to top
View user's profile Send private message
debimax
n00b
n00b


Joined: 14 Nov 2010
Posts: 16
Location: Grenoble

PostPosted: Wed Nov 24, 2010 9:35 am    Post subject: Reply with quote

Je n'utilise pas sudo donc je vais donc rechercher avec consolekit/polkit.

merci pour l'idée.
Back to top
View user's profile Send private message
mdos
n00b
n00b


Joined: 28 Sep 2008
Posts: 18

PostPosted: Wed Nov 24, 2010 11:07 am    Post subject: Reply with quote

salut,

j'ai eu le même type de problème avec la maj de xfce4
je l'ai résolu avec un revdep-rebuild
Back to top
View user's profile Send private message
debimax
n00b
n00b


Joined: 14 Nov 2010
Posts: 16
Location: Grenoble

PostPosted: Wed Nov 24, 2010 2:15 pm    Post subject: Reply with quote

J'ai maintenant avancé et le problème vient de slim

J'ai viré slim

J'ai mis la ligne "exec ck-launch-session startxfce4" dans le fichier .xinitrc et je lance la session avec startx

J'obtiens alors démarrer éteindre veille et hibernation 8)

Maintenant je vais remettre slim regarder comment configurer slim.
Back to top
View user's profile Send private message
elyes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Wed Nov 24, 2010 7:59 pm    Post subject: Reply with quote

salut,

j'ai également le même problème...
pour l'instant j'utilise directement slim pour rebooter, éteindre ... dans l'attente de trouver une solution.


http://slim.berlios.de/manual.php
Quote:

You may shutdown, reboot, suspend, exit or even launch a terminal from the SLiM login screen. To do so, enter the appropriate value in the username field, and the root password in the password field:

* To launch a terminal, enter console as the username (defaults to xterm which must be installed separately... edit /etc/slim.conf to change terminal preference)
* For shutdown, enter halt as the username
* For reboot, enter reboot as the username
* For suspend, enter suspend as the username
* To exit to the shell, enter exit as the username


cordialement,
Elyes
Back to top
View user's profile Send private message
debimax
n00b
n00b


Joined: 14 Nov 2010
Posts: 16
Location: Grenoble

PostPosted: Wed Nov 24, 2010 10:13 pm    Post subject: Reply with quote

elyes wrote:
salut,

j'ai également le même problème...
pour l'instant j'utilise directement slim pour rebooter, éteindre ... dans l'attente de trouver une solution.
Bonjour elyes

Visiblement c'est ce bug https://bugs.gentoo.org/show_bug.cgi?id=342291

Je regarderai demain plus attentivement.
Back to top
View user's profile Send private message
debimax
n00b
n00b


Joined: 14 Nov 2010
Posts: 16
Location: Grenoble

PostPosted: Sat Nov 27, 2010 9:28 am    Post subject: Reply with quote

je viens de tester avec gdm et c'est tout bon. :D

Je confirme donc un bug avec slim, je n'ai pas encore réussi à trouver pourquoi ca bloque avec slim

edit: Nous ne somme pas les seuls https://bugs.gentoo.org/show_bug.cgi?id=346037
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum