Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XCAS] problème compilation (resolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
debimax
n00b
n00b


Joined: 14 Nov 2010
Posts: 16
Location: Grenoble

PostPosted: Sun Nov 14, 2010 8:14 am    Post subject: [XCAS] problème compilation (resolu) Reply with quote

bonjour

Je viens de remettre sur pied ma gentoo et je souhaite installer xcas.

J'ai trouvé cet ebuild http://gitweb.thetys-retz.net/overlay/tree/HEAD:/sci-mathematics/giac

J'ai installé avant fltk, gsl , pari, ntl, mpfr et gmp

Tout ce passe bien au début de la compilation mais j'ai cette erreur
Code:
/bin/sh ../libtool --tag=CXX   --mode=compile i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..  -DIN_GIAC -I. -I.. -I. -I..       -O2 -march=i686 -pipe -fno-strict-aliasing -MT rpn.lo -MD -MP -MF .deps/rpn.Tpo -c -o rpn.lo rpn.cc
libtool: compile:  i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -DIN_GIAC -I. -I.. -I. -I.. -O2 -march=i686 -pipe -fno-strict-aliasing -MT rpn.lo -MD -MP -MF .deps/rpn.Tpo -c rpn.cc  -fPIC -DPIC -o .libs/rpn.o
rpn.cc:1387: erreur: explicit qualification in declaration of ‘giac::_concat_CONCAT_s’
rpn.cc:1387: erreur: ‘giac::_concat_CONCAT_s’ declared as reference but not initialized
rpn.cc:1388: erreur: ‘__CONCAT’ was not declared in this scope
make[2]: *** [rpn.lo] Erreur 1
make[2]: quittant le répertoire « /var/tmp/portage/sci-mathematics/giac-0.9.0/work/giac-0.9.0/src »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /var/tmp/portage/sci-mathematics/giac-0.9.0/work/giac-0.9.0 »
make: *** [all] Erreur 2
* ERROR: sci-mathematics/giac-0.9.0 failed:
*   emake failed


c'est la même chose si je compile à la main avec ./configure make

J'ai posté aussi sur le site de xcas http://pcm1.e.ujf-grenoble.fr/XCAS/viewtopic.php?f=5&t=714 mais je n'ai pas eu encore de réponse.
J'y ai ai posté aussi le configure mais je vois vois ce qui peut poser problème

avez vous une idée merci de m'aider


Last edited by debimax on Mon Nov 22, 2010 9:24 pm; edited 2 times in total
Back to top
View user's profile Send private message
debimax
n00b
n00b


Joined: 14 Nov 2010
Posts: 16
Location: Grenoble

PostPosted: Tue Nov 16, 2010 12:02 pm    Post subject: Reply with quote

c'est réglé pour le problème (voir le lien sur le forum), j'ai crée un patch pour modifier deux lignes du code de xcas.

Cependant il faut la version 1.3 de fltk (ni la 2 ni la 1.1) pour compiler xcas et j'ai du installer avec ./configure make la version 1.3 dans /usr/local

Moi qui voulais faire un ebuild pour xcas, ce n'est pas gagné.
Back to top
View user's profile Send private message
corrosif
Apprentice
Apprentice


Joined: 21 Dec 2003
Posts: 184
Location: France

PostPosted: Fri Nov 19, 2010 10:37 pm    Post subject: Reply with quote

Bonjour debimax,

Si ça peut t'aider, j'ai réalisé à l'époque des ebuilds qui fonctionnaient pour une ancienne version de xcas (et les libs associées).
Je n'ai plus eu le temps depuis de les maintenir, mais cela pourra peut-être te servir comme base?

Voici mes ebuilds:

sci-mathematics/giac-0.5.0
https://bugs.gentoo.org/show_bug.cgi?id=94539

x11-libs/flvw-20000224
https://bugs.gentoo.org/show_bug.cgi?id=94403

sci-mathematics/xcas-0.5.0
https://bugs.gentoo.org/show_bug.cgi?id=94542
_________________
S'il n'y a pas de solution, alors il n'y a pas de problème (logique Shadok).
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sat Nov 20, 2010 12:11 am    Post subject: Reply with quote

Hello, peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)
Back to top
View user's profile Send private message
debimax
n00b
n00b


Joined: 14 Nov 2010
Posts: 16
Location: Grenoble

PostPosted: Mon Nov 22, 2010 9:22 pm    Post subject: Reply with quote

@corrosif merci beaucoup je vais regarder tes liens.

J'ai du faire un patch pour pouvoir le compiler avec un ebuild mais ce que j'aimerai faire, c'est d'inclure dans xcas la bonne version de fltk. (voir le lien sur le forum de xcas)

Déjà j'ai xcas compilé manuellement. C'est déjà ca je peux donc travailler.

@geekounet désolé je suis newbi, Je ne ferai plus l'erreur.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum