Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Résolu][NVIDIA] installation impossible du driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 179

PostPosted: Fri Oct 29, 2010 10:09 am    Post subject: [Résolu][NVIDIA] installation impossible du driver Reply with quote

Bonjour,

Je suis en phase de mise à niveau de mon installation gentoo. Je suis donc passé en 2.6.36,
fait un emerge -DuNav @world @system, revdep-rebuild etc.

Le problème est que je n'arrive pas à mettre à jour mon driver nvidia. J'ai donc commencé par le
supprimer complètement, et j'ai retenté une nouvelles install.

Dans mon make.conf, j'ai :
Code:
INPUT_DEVICES="evdev"
VIDEO_CARDS="nvidia"


Quand je veux installer les drivers voilà le build.log:
Code:
# emerge -v x11-base/xorg-drivers
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-drivers/nvidia-drivers-256.53  USE="acpi gtk -custom-cflags (-multilib)" 0 kB
[ebuild  N    ] media-video/nvidia-settings-256.52  0 kB
[ebuild   R   ] x11-base/xorg-drivers-1.9  INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -elographics -fpit -joystick -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="nvidia -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -intel -mach64 -mga -neomagic (-newport) -nouveau -nv -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo) -xgi" 0 kB

Total: 3 packages (2 new, 1 reinstall), Size of downloads: 0 kB


>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 3) x11-drivers/nvidia-drivers-256.53
 * NVIDIA-Linux-x86-256.53.run RMD160 SHA1 SHA256 size ;-) ...                                                                                        [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                [ ok ]
 * Package:    x11-drivers/nvidia-drivers-256.53
 * Repository: gentoo
 * Maintainer: cardoe@gentoo.org jer@gentoo.org,spock@gentoo.org
 * USE:  acpi elibc_glibc gtk kernel_linux userland_GNU x86
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.36-gentoo/build
 * Found sources for kernel version:
 *     2.6.36-gentoo
 * Checking for MTRR support ...                                                                                                                      [ ok ]
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86-256.53.run to /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work ...
 * Applying 256.35-unified-arch.patch ...                                                                                                             [ ok ]
 * Converting /kernel/Makefile.kbuild to use M= instead of SUBDIRS= ...                                                                               [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work ...
 * Preparing nvidia module
make -j3 HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/2.6.36-gentoo/build HOST_CC=i686-pc-linux-gnu-gcc clean module
NVIDIA: calling KBUILD...
make -C /lib/modules/2.6.36-gentoo/build \
KBUILD_SRC=/usr/src/linux-2.6.36-gentoo \
KBUILD_EXTMOD="/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel" -f /usr/src/linux-2.6.36-gentoo/Makefile \
modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (                \
echo;                                                           \
echo "  ERROR: Kernel configuration is invalid.";               \
echo "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo "         Run 'make oldconfig && make prepare' on kernel src to fix it.";  \
echo;                                                           \
/bin/false)
mkdir -p /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/.tmp_versions ; rm -f /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/.tmp_versions/*
make -f /usr/src/linux-2.6.36-gentoo/scripts/Makefile.build obj=/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel
(cat /dev/null;   echo kernel//var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nvidia.ko;) > /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/modules.order
  cc -Wp,-MD,/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/.nv.o.d  -nostdinc -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.4.5/include -I/usr/src/linux-2.6.36-gentoo/arch/x86/include -Iinclude  -I/usr/src/linux-2.6.36-gentoo/include -include include/generated/autoconf.h   -I/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -Os -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i686 -mtune=generic -Wa,-mtune=generic32 -ffreestanding -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Wframe-larger-than=2048 -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack   -I/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel -Wall -MD -Wno-cast-qual -Wno-error -D__KERNEL__ -DMODULE -DNVRM -DNV_VERSION_STRING=\"256.53\" -UDEBUG -U_DEBUG -DNDEBUG  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(nv)"  -D"KBUILD_MODNAME=KBUILD_STR(nvidia)"  -c -o /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nv.o /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nv.c
  cc -Wp,-MD,/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/.nv-vm.o.d  -nostdinc -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.4.5/include -I/usr/src/linux-2.6.36-gentoo/arch/x86/include -Iinclude  -I/usr/src/linux-2.6.36-gentoo/include -include include/generated/autoconf.h   -I/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -Os -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i686 -mtune=generic -Wa,-mtune=generic32 -ffreestanding -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Wframe-larger-than=2048 -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack   -I/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel -Wall -MD -Wno-cast-qual -Wno-error -D__KERNEL__ -DMODULE -DNVRM -DNV_VERSION_STRING=\"256.53\" -UDEBUG -U_DEBUG -DNDEBUG  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(nv_vm)"  -D"KBUILD_MODNAME=KBUILD_STR(nvidia)"  -c -o /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nv-vm.o /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nv-vm.c
  cc -Wp,-MD,/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/.nv_gvi.o.d  -nostdinc -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.4.5/include -I/usr/src/linux-2.6.36-gentoo/arch/x86/include -Iinclude  -I/usr/src/linux-2.6.36-gentoo/include -include include/generated/autoconf.h   -I/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -Os -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i686 -mtune=generic -Wa,-mtune=generic32 -ffreestanding -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Wframe-larger-than=2048 -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack   -I/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel -Wall -MD -Wno-cast-qual -Wno-error -D__KERNEL__ -DMODULE -DNVRM -DNV_VERSION_STRING=\"256.53\" -UDEBUG -U_DEBUG -DNDEBUG  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(nv_gvi)"  -D"KBUILD_MODNAME=KBUILD_STR(nvidia)"  -c -o /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nv_gvi.o /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nv_gvi.c
  cc -Wp,-MD,/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/.os-agp.o.d  -nostdinc -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.4.5/include -I/usr/src/linux-2.6.36-gentoo/arch/x86/include -Iinclude  -I/usr/src/linux-2.6.36-gentoo/include -include include/generated/autoconf.h   -I/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -Os -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i686 -mtune=generic -Wa,-mtune=generic32 -ffreestanding -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Wframe-larger-than=2048 -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack   -I/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel -Wall -MD -Wno-cast-qual -Wno-error -D__KERNEL__ -DMODULE -DNVRM -DNV_VERSION_STRING=\"256.53\" -UDEBUG -U_DEBUG -DNDEBUG  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(os_agp)"  -D"KBUILD_MODNAME=KBUILD_STR(nvidia)"  -c -o /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/os-agp.o /var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/os-agp.c
/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nv.c:426: erreur: unknown field âioctlâ specified in initializer
/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nv.c:426: attention : initialization from incompatible pointer type
make[4]: *** [/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel/nv.o] Erreur 1
make[4]: *** Attente des tâches non terminées....
make[3]: *** [_module_/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/kernel] Erreur 2
make[2]: *** [sub-make] Erreur 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Erreur 1
make: *** [module] Erreur 2
emake failed
 * ERROR: x11-drivers/nvidia-drivers-256.53 failed:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS=  IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux           SYSOUT=/lib/modules/2.6.36-gentoo/build HOST_CC=i686-pc-linux-gnu-gcc clean module
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 4156:  Called linux-mod_src_compile
 *   environment, line 3066:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                                               CROSS_COMPILE=${CHOST}-                             LDFLAGS=\"$(get_abi_LDFLAGS)\"                                           ${BUILD_FIXES}                                          ${BUILD_PARAMS}             ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *
 * If you need support, post the output of 'emerge --info =x11-drivers/nvidia-drivers-256.53',
 * the complete build log and the output of 'emerge -pqv =x11-drivers/nvidia-drivers-256.53'.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/temp/environment'.
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/'

>>> Failed to emerge x11-drivers/nvidia-drivers-256.53, Log file:

>>>  '/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/temp/build.log'

 * Messages for package x11-drivers/nvidia-drivers-256.53:

 * ERROR: x11-drivers/nvidia-drivers-256.53 failed:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS=  IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux           SYSOUT=/lib/modules/2.6.36-gentoo/build HOST_CC=i686-pc-linux-gnu-gcc clean module
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 4156:  Called linux-mod_src_compile
 *   environment, line 3066:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                                               CROSS_COMPILE=${CHOST}-                             LDFLAGS=\"$(get_abi_LDFLAGS)\"                                           ${BUILD_FIXES}                                          ${BUILD_PARAMS}             ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *
 * If you need support, post the output of 'emerge --info =x11-drivers/nvidia-drivers-256.53',
 * the complete build log and the output of 'emerge -pqv =x11-drivers/nvidia-drivers-256.53'.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/temp/environment'.
 * S: '/var/tmp/portage/x11-drivers/nvidia-drivers-256.53/work/'


J'ai vérifié côté kernel et tout est bon :
Code:
# locate autoconf.h | grep 2.6.36
/usr/src/linux-2.6.36-gentoo/include/generated/autoconf.h
# locate auto.conf
/usr/src/linux-2.6.36-gentoo/include/config/auto.conf
/usr/src/linux-2.6.36-gentoo/include/config/auto.conf.cmd


Et le fb nvidia et rt-nvidia sont bien désactivés.

Une petite idée ?
_________________
- zerros -


Last edited by zerros on Fri Oct 29, 2010 12:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Fri Oct 29, 2010 10:52 am    Post subject: Reply with quote

A priori, la série 256 des drivers semble incompatible avec le 2.6.36.
Soit tu repasse en 2.6.35, soit tu upgrades nvidia en 260.19.12 (hardmaské dans portage), soit... tu passes à nouveau ;)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Fri Oct 29, 2010 10:55 am    Post subject: Reply with quote

Juste pour information, le 260.19.12 fonctionne très bien, et il est très stable. Il fonctionne également avec le 2.6.35.7 je crois.
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Fri Oct 29, 2010 10:56 am    Post subject: Reply with quote

Hello,
Oui c'est un problème connu sur le bugzilla,
J'ai ce problème là aussi, perso je reste en 2.6.35 pour l'instant... mais une des solutions simple serait de démasquer les prochaines versions du driver nvidia et de les installer (v260.19.x).
Avec ceux là ça passerait.

EDIT: mouarf, doublement grillé par Crok et guilc...
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 179

PostPosted: Fri Oct 29, 2010 11:03 am    Post subject: Reply with quote

euh ... merci pour cette infos. Ca ne fait pas longtemps que je tourne sur gentoo, et comment puis-je un maské une version d'un paquet ?
J'ai bien compris comment le faire pour un paquet entier, mais pas pour une version en particulier ?
_________________
- zerros -
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Fri Oct 29, 2010 11:42 am    Post subject: Reply with quote

zerros wrote:
comment puis-je un maské une version d'un paquet ?

Code:
echo =x11-drivers/nvidia-drivers-260.19.12 >> /etc/portage/package.unmask

;-)
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 179

PostPosted: Fri Oct 29, 2010 11:45 am    Post subject: Reply with quote

Merci. en furetant sur le net j'ai trouvé comment faire. Avant aujourd'hui, je ne savais pas qu'il était possible d'unmasker une version spécifique
d'un package.

nice. tout refonctionne. Merci :)
_________________
- zerros -
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum