Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with kernel 2.6.36 and wifi pcmcia cards [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 655
Location: Bangkok, Thailand

PostPosted: Sun Oct 24, 2010 7:14 am    Post subject: Problems with kernel 2.6.36 and wifi pcmcia cards [SOLVED] Reply with quote

I posted this on the portage forum but got no responses so I will try here. :D I am trying out the new kernel 2.6.36 on my laptop and when the pcmcia service gets started it fails with a message:

    * Starting pcmcia ...
    cardmgr[13945]: no pcmcia driver in /proc/devices
    * cardmgr failed to start. Make sure that you have PCMCIA
    * modules built or support compiled into the kernel [ !! ]
    agate ~ # lsmod | grep pcmcia
    pcmcia 24422 0
    pcmcia_rsrc 7052 1 yenta_socket
    pcmcia_core 8237 3 pcmcia,yenta_socket,pcmcia_rsrc

Searching I find references in kernel commits that the cardmgr support may be removed in 2.6.36 and indeed the wifi card initialises without problem! However, if you need to restart the card the script fails because the pcmcia service is a pre-req.

Further research showed we should now be using the sys-apps/pcmciautils package but that does not contain any scripts, so I hacked /etc/init.d/pcmcia to always return 0 and that solved the problem restarting the interface with the Gentoo net.xxx0 scripts.

The next problem is using the ath5k driver. I currently use the madwifi-ng package (ath_pci) but would like to use the drivers in the kernel. However, I cannot get the wlan0 interface to appear without messing around activating ath0 first. This tells me I need some other module loaded?

TIA
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling


Last edited by binro on Sun Oct 24, 2010 2:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 655
Location: Bangkok, Thailand

PostPosted: Sun Oct 24, 2010 2:22 pm    Post subject: Reply with quote

OK, problems solved. :D The solution to the first problem is as advised here: http://www.kernel.org/pub/linux/utils/kernel/pcmcia/cardmgr-to-pcmciautils.html, basically you disembowel /etc/init.d/pcmcia to not actually do anything. I assume this should be addressed by the devs at some stage.

The second problem with wlan0 was because you cannot have the ath5k and ath_pci modules available at the same time. Removing all traces of the madwifi-ng modules, particularly from lib/modules/2.6.36-gentoo/net, enabled the wlan0 interface to come active.

HTH
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum