Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Emerge problema pacchetti bloccati QT
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 8:02 pm    Post subject: Reply with quote

Noooo :), ovvio che ho reinstallato i pacchetti ma solo quelli minimi per avviare kde ;)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 24, 2010 8:13 pm    Post subject: Reply with quote

Boh, io non sono riuscito a mettere x11-libs/qt-4.6.2 insieme agli altri qt-*-4.6.3 ....
Aspetterò qt-4.6.3.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Oct 28, 2010 8:38 am    Post subject: Reply with quote

Niente.

Per il momento l'unica soluzione che ho trovato sul mio sistema è quella di mascherare temporaneamente i seguenti pacchetti:
Code:
=x11-libs/qt-core-4.6.3
=x11-libs/qt-dbus-4.6.3
=x11-libs/qt-sql-4.6.3-r2
=x11-libs/qt-xmlpatterns-4.6.3
=x11-libs/qt-script-4.6.3
=x11-libs/qt-test-4.6.3
=x11-libs/qt-gui-4.6.3
=x11-libs/qt-qt3support-4.6.3
=x11-libs/qt-webkit-4.6.3-r1
=x11-libs/qt-opengl-4.6.3
=x11-libs/qt-multimedia-4.6.3
=x11-libs/qt-svg-4.6.3
=x11-libs/qt-assistant-4.6.3

Altrimenti mi risultava impossibile fare l'emerge -uDN world.

Sarò un caso isolato. Comunque continuo a chiedermi come mai rilascino tutti quei pacchetti aggiornati se qt è ancora alla versione 4.6.2. Forse sarebbe stato meglio aspettare che fossero tutti alla versione 4.6.3.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
bender86
Guru
Guru


Joined: 18 Mar 2005
Posts: 466

PostPosted: Mon Nov 01, 2010 7:37 am    Post subject: Reply with quote

fbcyborg wrote:
Sarò un caso isolato. Comunque continuo a chiedermi come mai rilascino tutti quei pacchetti aggiornati se qt è ancora alla versione 4.6.2. Forse sarebbe stato meglio aspettare che fossero tutti alla versione 4.6.3.

x11-libs/qt è hard masked (il motivo è spiegato nell'ebuild ed è abbastanza convincente), quindi può capitare che non sia aggiornato come quelli stabili. In sostanza, non usarlo; installa i singoli pacchetti x11-libs/qt-*.
Nel tuo file world ci sono sia x11-libs/qt che uno dei x11-libs/qt-* (o, più probabilmente, un pacchetto che dipende da essi, come kde), quindi portage cerca di installare contemporaneamente entrambe le versioni. Elimina x11-libs/qt.

In generale, quando ti capita di essere un caso isolato prova a rifare emerge --sync. A volte risolve.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Nov 01, 2010 9:53 am    Post subject: Reply with quote

Grazie per la spiegazione. Sinceramente avevo notato (ovviamente) che fosse hard masked, ma sono sempre stato convinto che x11-libs/qt fosse necessario, come lo sono gli altri x11-libs/qt-*.
Una cosa strana è che non c'è mai stata una volta che l'emerge --depclean mi abbia voluto far rimuovere quel pacchetto.
È una situazione che mi porto avanti da molto tempo oramai, e un emerge --sync non ha mai risolto il problema.

Effettivamente, ora che vedo questo:
Code:
# equery d x11-libs/qt
 * These packages depend on x11-libs/qt:

la cosa mi convince ancor di più!

Grazie!!! Ora torna tutto!
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum