Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Emerge problema pacchetti bloccati QT
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 12:53 am    Post subject: [RISOLTO] Emerge problema pacchetti bloccati QT Reply with quote

Salve a tutti, avrei un paio di problemi e spero che qualcuno possa aiutarmi. Quando vado a fare "emerge -NDupv world" mi trovo questo:

[uninstall ] media-fonts/gnu-gs-fonts-std-8.11
[blocks b ] media-fonts/gnu-gs-fonts-std ("media-fonts/gnu-gs-fonts-std" is blocking media-fonts/urw-fonts-2.4.9)
[ebuild U ] x11-libs/qt-core-4.6.3 [4.6.2-r1] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -doc -optimized-qmake -pch" 157,221 kB
[ebuild U ] x11-libs/qt-script-4.6.3 [4.6.2] USE="exceptions iconv (-aqua) -debug -pch" 0 kB
[blocks b ] <x11-libs/qt-script-4.6.3 ("<x11-libs/qt-script-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-sql-4.6.3-r2)
[ebuild U ] x11-libs/qt-sql-4.6.3-r2 [4.6.2] USE="exceptions iconv qt3support sqlite (-aqua) -debug (-firebird) -freetds% -mysql -odbc -pch -postgres" 0 kB
[blocks b ] <x11-libs/qt-sql-4.6.3 ("<x11-libs/qt-sql-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-webkit-4.6.3-r1)
[ebuild U ] x11-libs/qt-test-4.6.3 [4.6.2] USE="exceptions iconv (-aqua) -debug -pch" 0 kB
[blocks b ] <x11-libs/qt-test-4.6.3 ("<x11-libs/qt-test-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-sql-4.6.3-r2)
[ebuild U ] x11-libs/qt-dbus-4.6.3 [4.6.2] USE="exceptions (-aqua) -debug -pch" 0 kB
[blocks b ] <x11-libs/qt-dbus-4.6.3 ("<x11-libs/qt-dbus-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-sql-4.6.3-r2)
[ebuild U ] x11-libs/qt-xmlpatterns-4.6.3 [4.6.2] USE="(-aqua) -debug -pch" 0 kB
[blocks b ] <x11-libs/qt-xmlpatterns-4.6.3 ("<x11-libs/qt-xmlpatterns-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-sql-4.6.3-r2)
[ebuild U ] x11-libs/qt-gui-4.6.3 [4.6.2] USE="accessibility cups dbus exceptions glib mng qt3support tiff (-aqua) -debug -gtk -nas -nis -pch -raster -trace% -xinerama" 0 kB
[blocks b ] <x11-libs/qt-gui-4.6.3 ("<x11-libs/qt-gui-4.6.3" is blocking x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-sql-4.6.3-r2)
[ebuild U ] x11-libs/qt-qt3support-4.6.3 [4.6.2] USE="accessibility exceptions kde (-aqua) -debug -pch -phonon" 0 kB
[blocks b ] <x11-libs/qt-qt3support-4.6.3 ("<x11-libs/qt-qt3support-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-sql-4.6.3-r2)
[ebuild U ] x11-libs/qt-svg-4.6.3 [4.6.2] USE="exceptions iconv (-aqua) -debug -pch" 0 kB
[blocks b ] <x11-libs/qt-svg-4.6.3 ("<x11-libs/qt-svg-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-webkit-4.6.3-r1, x11-libs/qt-sql-4.6.3-r2)
[ebuild R ] media-libs/mesa-7.8.2 USE="nptl xcb -debug (-gallium) -motif -pic (-selinux)" VIDEO_CARDS="-intel -mach64 -mga -nouveau -r128 -radeon -savage -sis -svga -tdfx -via (-radeonhd%)" 0 kB
[ebuild NS ] sys-kernel/gentoo-sources-2.6.34-r12 [2.6.34-r11] USE="symlink -build -deblob" 212 kB
[ebuild U ] x11-libs/qt-opengl-4.6.3 [4.6.2] USE="exceptions qt3support (-aqua) -debug -pch" 0 kB
[blocks b ] >x11-libs/qt-webkit-4.6.2-r9999 (">x11-libs/qt-webkit-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks b ] <x11-libs/qt-opengl-4.6.3 ("<x11-libs/qt-opengl-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-sql-4.6.3-r2, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-webkit-4.6.3-r1)
[ebuild U ] x11-libs/qt-webkit-4.6.3-r1 [4.6.2-r1] USE="dbus exceptions kde (-aqua) -debug -pch" 0 kB
[blocks b ] >x11-libs/qt-opengl-4.6.2-r9999 (">x11-libs/qt-opengl-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks b ] >x11-libs/qt-svg-4.6.2-r9999 (">x11-libs/qt-svg-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks b ] >x11-libs/qt-sql-4.6.2-r9999 (">x11-libs/qt-sql-4.6.2-r9999" is blocking x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks b ] >x11-libs/qt-test-4.6.2-r9999 (">x11-libs/qt-test-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks b ] >x11-libs/qt-script-4.6.2-r9999 (">x11-libs/qt-script-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks b ] >x11-libs/qt-qt3support-4.6.2-r9999 (">x11-libs/qt-qt3support-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks b ] >x11-libs/qt-xmlpatterns-4.6.2-r9999 (">x11-libs/qt-xmlpatterns-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks b ] >x11-libs/qt-dbus-4.6.2-r9999 (">x11-libs/qt-dbus-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2)
[blocks b ] >x11-libs/qt-core-4.6.2-r9999 (">x11-libs/qt-core-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-gui-4.6.2, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)
[blocks b ] <x11-libs/qt-webkit-4.6.3 ("<x11-libs/qt-webkit-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3, x11-libs/qt-svg-4.6.3, x11-libs/qt-opengl-4.6.3, x11-libs/qt-core-4.6.3, x11-libs/qt-dbus-4.6.3, x11-libs/qt-script-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-sql-4.6.3-r2)
[blocks b ] >x11-libs/qt-gui-4.6.2-r9999 (">x11-libs/qt-gui-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-webkit-4.6.2-r1, x11-libs/qt-xmlpatterns-4.6.2, x11-libs/qt-core-4.6.2-r1, x11-libs/qt-svg-4.6.2, x11-libs/qt-test-4.6.2, x11-libs/qt-opengl-4.6.2, x11-libs/qt-qt3support-4.6.2, x11-libs/qt-script-4.6.2, x11-libs/qt-dbus-4.6.2)

Total: 27 packages (22 upgrades, 2 new, 2 in new slots, 1 reinstall, 1 uninstall), Size of downloads: 195,630 kB
Conflict: 22 blocks

Quello che vi chiedo è: conviene rimuovere tutti i pacchetti qt implicati e poi installarli nuovamente o altro? Mi piacerebbe risolvere il problema attraverso una soluzione elegante anche complessa che mi permette di mantere il sistema pulito.


Last edited by stifler83 on Sun Oct 24, 2010 6:09 pm; edited 2 times in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Oct 24, 2010 9:18 am    Post subject: Reply with quote

i font media-fonts/gnu-gs-fonts-std sembrano incompatibili con media-fonts/urw-fonts.
devi scegliere tra i primi e i secondi.

per capire quale pacchetto ne richiama l'installazione, rilancia il comando emerge con l'opzione -t.

per le qt, probabilmente hai ragione: disinstallando preventivamente le vecchie versioni semplifichi la vita ad emerge nella risoluzione delle dipendenze. puoi preventivamente usare quickpkg per salvare una versione di backup dei binari.

se non lo hai già fatto, ti consiglio di aggiornare portage alla versione 2.2*, anche se, per ragioni misteriose, è ancora mascherata.
l'aggiornamento delle librerie, infatti, desincronizza spesso il sistema. in precedenza revdep-rebuild era l'unico strumento di controllo della coerenza globale. adesso emerge esegue dei check efficaci, conserva la stabilità provvisoria del sistema e suggerisce, se necessario, l'uso di emerge @preserverd-rebuild per coordinare l'upgrade.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sun Oct 24, 2010 9:34 am    Post subject: Reply with quote

per caso hai compilato pacchetti con ACCEPT_KEYWORDS="~x86" dentro al make.conf?
forse non sapevi che i pacchetti mascherati vanno messi in /etc/portage/package.keywords
questo e soltanto una spiegazione che tu lo sappia oppure meno. perche' questa ne puo essere la causa del tuo problema.


se e' cosi ora ti stai trovando due versioni differti qt dello stesso pacchetto una stabile e laltra no. si, la cosa migliore che puoi fare eliminare manulmente tutti pacchetti bloccati

Code:
i [ebuild U ] x11-libs/qt-script-4.6.3 [4.6.2] USE="exceptions iconv (-aqua) -debug -pch" 0 kB
[blocks b ] <x11-libs/qt-script-4.6.3 ("<x11-libs/qt-script-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-

questo e il pacchetto da eliminare x11-libs/qt-script-4.6.3
emerge -C x11-libs/qt-script-4.6.3
Code:
[ebuild U ] x11-libs/qt-sql-4.6.3-r2 [4.6.2] USE="exceptions iconv qt3support sqlite (-aqua) -debug (-firebird) -freetds% -mysql -odbc -pch -postgres" 0 kB
[blocks b ] <x11-libs/qt-sql-4.6.3 ("<x11-libs/qt-sql-4.6.3" is blocking x11-libs/qt-gui-4.6.3, x11-libs/qt-xmlpatterns-4.6.3, x11-libs/qt-test-4.6.3,


uguale anche questo x11-libs/qt-sql-4.6.3 e con tutti gli altri miraccomando controlla bene.

Code:
x11-libs/qt-script-4.6.2   x11-libs/qt-sql-4.6.2

questa e' la versione stabile che ti interessa [4.6.2]


questo lo fai con tutti, poi lanci un bel emerge -DuNav world per aggiornare l'intero sistema e dare anche una controllata anche alle use flags

e alla fine dell' aggiornameto lanci un emerge --depclean che serve per eliminare tutti i pacchetti orfani di sistema, e tutte le dipendenze dei pacchetti eliminati. E in fine revdep-rebuild per finire in belleza l'intera opera :)
_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 12:48 pm    Post subject: Reply with quote

Scusate, come blocco un pacchetto su emerge per evitare quando utilizzo -depclean che vengono rimossi alcuni pacchetti che vede come dipendenze orfane ma che in realtà non lo sono e che comunque non voglio eliminare?
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Sun Oct 24, 2010 12:59 pm    Post subject: Reply with quote

naturalmente quello che ti serve non lo devi eliminare, quello che ti ho detto d lanciare un emerge --depclean per dare una ripulita completa al sistema, e tenere roba stabile nel sistema.
emerge --depclean, fa ve sempre lanciato dopo un aggiornamento mai prima, toglie solo quello dove non a nulla per apogiarsi pacchetti orfani etc ma non sei obligato a darlo la cosa principale e che esegui la prima parte cioie la rimozione dei pacchetti bloccati io per esempio lo uso
_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 2:11 pm    Post subject: Reply with quote

Vi ringrazio ho eliminato i pacchetti a mano ed ora sto ricompilando il tutto. Per quanto riguarda la seconda cosa che ho chiesto, forse non sono riuscito a spiegarmi.

kde-base/kdm
selected: 4.4.5
protected: none
omitted: none

posso settare manualmente il pacchetto come protected ?
Ci tengo a precisare che il pacchetto sopra è casuale me ne serviva uno come esempio.
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sun Oct 24, 2010 2:15 pm    Post subject: Reply with quote

se hai installato kde e con emerge --depclean ti vuole rimuovere kdm vuol dire che c'è qualcosa che non va nel world file, controlla cosa contiene /var/lib/portage/world
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 2:22 pm    Post subject: Reply with quote

Scusa, se leggi bene il post sopra ho sottolineato che kdm è un pacchetto di esempio, io voglio solo sapere se è possibile settare manualmente protected ad un pacchetto tutto qui.
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sun Oct 24, 2010 2:26 pm    Post subject: Reply with quote

che io sappia puoi aggiungerlo al world file manualmente, oppure riemergere quel singolo pacchetto che verrebbe aggiunto automaticamente al world file, in questo modo con emerge --depclean non verrebbero rimossi
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 3:38 pm    Post subject: Reply with quote

puoi spiegarti meglio? :)
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sun Oct 24, 2010 3:50 pm    Post subject: Reply with quote

Code:
# echo "kde-base/kdm" >> /var/lib/portage/world


ma non sono sicuro che sia la soluzione più elegante
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 24, 2010 5:41 pm    Post subject: Reply with quote

Per evitare che "nomepacchetto" ti venga portato via con un depclean:
Code:
emerge --noreplace nomepacchetto

Anche io avevo avuto il tuo stesso problema.

Per quanto riguarda la questione iniziale invece: sembra la solita pippa di qt-* e company. Ogni volta che capita questo inconveniente, rimuovo "tutto" manualmente e reinstallo subito, e tutto fila liscio. È comunque una scocciatura. Nel mio caso non ho messo ACCEPT_KEYWORDS="~amd64", ma il problema si verifica lo stesso.

Credo che opererò anche questa volta nello stesso modo.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 6:07 pm    Post subject: Reply with quote

Premetto che nemmeno io ho usato ACCEPT_KEYWORDS="~amd64", quindi confermo che è proprio una pippa il pacchetto di QT e company.
Ho rimosso e installato di nuovo tutti i pacchetti qt che andavano in blocco e adesso è tutto perfettamente funzionante. Vi ringrazio per l'aiuto. 8)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 24, 2010 6:24 pm    Post subject: Reply with quote

Ottimo, lo sto facendo anche io, e nella fattispecie:
Code:
emerge -Cav qt-webkit qt-xmlpatterns qt-opengl qt-core qt-script qt-assistant qt-multimedia qt-svg qt-dbus qt-sql qt-gui qt-script qt-qt3support qt-test && emerge -av qt-webkit qt-xmlpatterns qt-opengl qt-core qt-script qt-assistant qt-multimedia qt-svg qt-dbus qt-sql qt-gui qt-script qt-qt3support qt-test && emerge -uDNav world

_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 24, 2010 6:49 pm    Post subject: Reply with quote

Un momento!
Io così non ho risolto un cavolo! Non ho risolto per il semplice motivo che x11-libs/qt-4.6.3 non è in portage!!!!!!
Sono stato costretto a rimettere qt-4.6.2! Come hai fatto a risolvere?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 6:58 pm    Post subject: Reply with quote

Guarda io ho risolto facendo come ho scritto, io però ho pure il portage alla 2.2 non so se questo cambi qualcosa :)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 24, 2010 7:05 pm    Post subject: Reply with quote

Anche io ho portage 2.2!
Il problema è che il pacchetto x11-libs/qt è alla versione 4.6.2, ma tutte le sue dipendenze sono alla versione 4.6.3! Se faccio come ho scritto prima, ovvero:
Code:
emerge -Cav qt-webkit qt-xmlpatterns qt-opengl qt-core qt-script qt-assistant qt-multimedia qt-svg qt-dbus qt-sql qt-gui qt-script qt-qt3support qt-test && emerge -av qt-webkit qt-xmlpatterns qt-opengl qt-core qt-script qt-assistant qt-multimedia qt-svg qt-dbus qt-sql qt-gui qt-script qt-qt3support qt-test

aggiorno tutti questi pacchetti alla versione 4.6.3, ma poi quando voglio aggiornare il sistema me li vuole riportare alla versione 4.6.2 perché non esiste una versione 4.6.3 in portage, del pacchetto qt.

È un po' un casino!
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 7:08 pm    Post subject: Reply with quote

Guarda io non ho nessun problema di nessun tipo c'ho tutto up to date e nessuna richiesta di downgrade o altro.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 24, 2010 7:10 pm    Post subject: Reply with quote

Tu che profilo hai?
Code:
eselect profile list


Non vorrei che fosse un problema del fatto che non ho selezionato questo:
Code:
default/linux/amd64/10.0/desktop/kde

ma questo:
Code:
default/linux/amd64/10.0/desktop

_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 7:22 pm    Post subject: Reply with quote

Ti confermo che ho il tuo stesso profilo.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 24, 2010 7:31 pm    Post subject: Reply with quote

mmmmh... scusa, se fai eix qt, cosa ti esce?
A me esce questo:
* x11-libs/qt
Available versions: (4) {M}4.5.3 [M]~4.6.1 {M}4.6.2
{dbus kde opengl qt3support}
Homepage: http://qt.nokia.com/
Description: The Qt toolkit is a comprehensive C++ application development framework

Mentre invece se faccio eix di uno qualsiasi di quei pacchetti che ho scritto prima (riporto l'esempio di qt-core), esce:
x11-libs/qt-core
Available versions: (4) 4.5.3-r2 4.6.2-r1 4.6.3 [M]~4.7.0
{aqua debug doc +exceptions +glib iconv optimized-qmake pch private-headers qt3support ssl}
Installed versions: 4.6.2-r1(4)(09:00:58 PM 10/24/2010)(exceptions glib iconv qt3support ssl -aqua -debug -doc -optimized-qmake -pch)
Homepage: http://qt.nokia.com/
Description: The Qt toolkit is a comprehensive C++ application development framework
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 7:40 pm    Post subject: Reply with quote

Allora:

* x11-libs/qt
Available versions: (4) [M]4.5.3 [M]~4.6.1 [M]4.6.2
{dbus kde opengl qt3support}
Homepage: http://qt.nokia.com/
Description: The Qt toolkit is a comprehensive C++ application development framework

[I] x11-libs/qt-core
Available versions: (4) 4.5.3-r2 4.6.2-r1{tbz2} 4.6.3 [M]~4.7.0
{aqua debug doc +exceptions +glib iconv optimized-qmake pch private-headers qt3support ssl}
Installed versions: 4.6.3(4)(16:34:10 24/10/2010)(exceptions glib iconv qt3support ssl -aqua -debug -doc -optimized-qmake -pch)
Homepage: http://qt.nokia.com/
Description: The Qt toolkit is a comprehensive C++ application development framework
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 24, 2010 7:42 pm    Post subject: Reply with quote

OK, come me.

Allora qualcosa non torna. Tu hai risolto tutto quel bordello di blocchi, dando questo comando o in quale altro modo (più precisamente quale?):
Code:
emerge -Cav qt-webkit qt-xmlpatterns qt-opengl qt-core qt-script qt-assistant qt-multimedia qt-svg qt-dbus qt-sql qt-gui qt-script qt-qt3support qt-test && emerge -av qt-webkit qt-xmlpatterns qt-opengl qt-core qt-script qt-assistant qt-multimedia qt-svg qt-dbus qt-sql qt-gui qt-script qt-qt3support qt-test

Così facendo tutti questi pacchetti passano dalla versione 4.6.2 alla 4.6.3. Ovviamente qt rimane alla 4.6.2 perché la 4.6.3 non c'è.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Sun Oct 24, 2010 7:47 pm    Post subject: Reply with quote

Guarda io ho semplicemente preso tutti i pacchetti bloccati ed ho fatto emerge -C :)
Per il resto ti posso dire che ho messo nel make.conf le qt kde gtk tutto quello che riguarda "la parte grafica" e l'ho disabilitato. Quando sono andato a compilare kde ho abilitato solo le use flags obbligatorie. Quindi potrebbe essere che te hai compilato qualcosa piu di me che ha portato in cascata qualche altro pacchetto rompi palle.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 24, 2010 7:52 pm    Post subject: Reply with quote

Cioé, fammi capire, dopo che hai fatto l'emerge -C di tutti quei pacchetti non li hai reinstallati più? (O magari te li ha ritirati dietro l'emerge -uDN world).
È chiaro che così facendo sblocchi la situazione ma non puoi non reinstallare quei pacchetti.. credo che si creerebbe un bel casino grafico senza le librerie qt.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum