Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problema con xine-lib
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Wed Oct 20, 2010 7:23 pm    Post subject: problema con xine-lib Reply with quote

Buonasera a tutti! Ho installato gentoo e ora sto cercando di configurare kde4 ma mi è sorto un grosso problema durante l'installazione: quando vado a fare l'emerge di kdebase-meta per esempio per installare i pacchetti base o anche di kdebase-startkde mi da errore nella compilazione del pacchetto xine-lib. Mi spiego meglio: nel primo caso se faccio l'emerge di kdebase-meta, mi chiede di ricompilare PyQt4 con le use sql e webkit abilitate: ricompilando il PyQt4, mi ricompila anche xine-lib e mi da il seguente errore a fine compilazione:
Code:
usr/lib/xine/plugins/1.28 group_games.lo demux_eawve.lo demux_idcin.lo demux_ipmovie.lo demux_roq.lo demux_vqa.lo demux_wc3movie.lo demux_str.lo demux_film.lo demux_smjpeg.lo demux_4xm.lo demux_vmd.lo ../../src/xine-engine/libxine.la 
/bin/sed: can't read /usr/lib/liblcms.la: No such file or directory
libtool: link: `/usr/lib/liblcms.la' is not a valid libtool archive
make[2]: *** [xineplug_dmx_mng.la] Error 1
make[2]: *** Waiting for unfinished jobs....
libtool: link: i686-pc-linux-gnu-gcc -shared  .libs/group_games.o .libs/demux_eawve.o .libs/demux_idcin.o .libs/demux_ipmovie.o .libs/demux_roq.o .libs/demux_vqa.o .libs/demux_wc3movie.o .libs/demux_str.o .libs/demux_film.o .libs/demux_smjpeg.o .libs/demux_4xm.o .libs/demux_vmd.o   -Wl,-rpath -Wl,/var/tmp/portage/media-libs/xine-lib-1.1.18.1/work/xine-lib-1.1.18.1/src/xine-engine/.libs ../../src/xine-engine/.libs/libxine.so  -march=i686 -Wl,-O1 -Wl,--as-needed   -pthread -Wl,-soname -Wl,xineplug_dmx_games.so -o .libs/xineplug_dmx_games.so
libtool: link: ( cd ".libs" && rm -f "xineplug_dmx_games.la" && ln -s "../xineplug_dmx_games.la" "xineplug_dmx_games.la" )
make[2]: Leaving directory `/var/tmp/portage/media-libs/xine-lib-1.1.18.1/work/xine-lib-1.1.18.1/src/demuxers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/xine-lib-1.1.18.1/work/xine-lib-1.1.18.1/src'
make: *** [all-recursive] Error 1
 #[31;01m*#[0m ERROR: media-libs/xine-lib-1.1.18.1 failed:
 #[31;01m*#[0m   emake failed
 #[31;01m*#[0m
 #[31;01m*#[0m Call stack:
 #[31;01m*#[0m     ebuild.sh, line   54:  Called src_compile
 #[31;01m*#[0m   environment, line 2702:  Called _eapi2_src_compile
 #[31;01m*#[0m     ebuild.sh, line  646:  Called die
 #[31;01m*#[0m The specific snippet of code:
 #[31;01m*#[0m         emake || die "emake failed"
 #[31;01m*#[0m
 #[31;01m*#[0m If you need support, post the output of 'emerge --info =media-libs/xine-lib-1.1.18.1',
 #[31;01m*#[0m the complete build log and the output of 'emerge -pqv =media-libs/xine-lib-1.1.18.1'.
 #[31;01m*#[0m The complete build log is located at '/var/tmp/portage/media-libs/xine-lib-1.1.18.1/temp/build.log'.
 #[31;01m*#[0m The ebuild environment file is located at '/var/tmp/portage/media-libs/xine-lib-1.1.18.1/temp/environment'.
 #[31;01m*#[0m S: '/var/tmp/portage/media-libs/xine-lib-1.1.18.1/work/xine-lib-1.1.18.1'
al che andando a controllare l'emerge --info =media-libs/xine-lib-1.1.18.1 mi da il seguente output:
Code:
Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.4.3, glibc-2.11.2-r0, 2.6.34-gentoo-r6 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.34-gentoo-r6-i686-Intel-R-_Core-TM-2_Duo_CPU_T7100_@_1.80GHz-with-gentoo-1.12.13
Timestamp of tree: Wed, 20 Oct 2010 10:15:02 +0000
app-shells/bash:     4.1_p7
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.65-r1
sys-devel/automake:  1.9.6-r3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ ftp://de-mirror.org/distro/gentoo/ ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://ftp.snt.ipv6.utwente.nl/pub/os/linux/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync11.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk hal iconv ipv6 jpeg kde lcms ldap libnotify mad mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pdf perl png ppds pppd python qt3support qt4 readline sdl spell ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php-5.2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

=================================================================
                        Package Settings
=================================================================

media-libs/xine-lib-1.1.18.1 was built with the following:
USE="-X -a52 -aac -aalib -alsa (-altivec) -css -directfb -dts -dxr3 -esd -fbcon -flac -gnome -gtk -imagemagick -ipv6 -jack -libcaca -mad -mmap -mng -modplug -musepack -nls -opengl -oss -pulseaudio (-real) -samba -sdl -speex -theora -truetype -v4l -vcd -vidix (-vis) -vorbis -wavpack -win32codecs -xcb -xinerama -xv -xvmc"
CFLAGS="-O2 -march=i686 -pipe -frename-registers -ffunction-sections"
CXXFLAGS="-O2 -march=i686 -pipe -frename-registers -ffunction-sections"
non so cosa fare! ho provato a ricompilare anche lo xine-lib da solo ed è andato a buon solo aggiungendo USE="-*" all'inizio del comando..credevo ci fossero problemi nel make ma ho abilitato solo la use kde..Ho provato anche a cambiare profilo ma niente..cosa potrei fare? grazie anticipatamente dell'aiuto

Last edited by GoraNz on Thu Oct 21, 2010 8:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Wed Oct 20, 2010 7:54 pm    Post subject: Reply with quote

L'errore vero e proprio si cela alcune righe prima di quelle riportate. Magari potresti modificare direttamente il primo post ampliando il log di emerge :wink:
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Oct 20, 2010 7:57 pm    Post subject: Reply with quote

magari, leggendo qualche linea in più, nel primo code di errore, ne potrebbe uscire qualche idea.

in ogni caso, compilare un pacchetto come xine-lib senza alcuna use (neppure X e opengl), mi sembra davvero un eccesso di minimalismo.
eppure, attualmente, bachi di compilazione, per xine-lib, non ce ne dovrebbero essere.

prova a disinstallare del tutto il pacchetto (magari dopo un quichpkg xine-lib di backup) e poi a dare un emerge -uDN world.
quando hai finito, richiama l'emerge di kdebase-meta. se si torna ad arrestare, forza la procedura chiamando emerge con l'opzione --resume --skipfirst.
di xine-lib te ne potrai occupare dopo.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Thu Oct 21, 2010 8:10 pm    Post subject: Reply with quote

scusate per la stupidità ma ho copiato male il tutto. Ora l'ho ampliato e compare l'errore nel make 2..comunque ho provato a disinstallare il pacchetto e a riprovare con l'emerge di kdebase-meta ma nulla uguale..mi manca la prova con il --resume --skipfirst ma volevo prima sapere se c'era un modo di risolvere tramite il posting dell'errore. grazie comunque dell'aiuto
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Thu Oct 21, 2010 8:52 pm    Post subject: Reply with quote

prova a dare lafilefixer --justfixit, e poi riprovare la compilazione
Back to top
View user's profile Send private message
GoraNz
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 181
Location: Latina, Pisa

PostPosted: Thu Oct 21, 2010 10:46 pm    Post subject: Reply with quote

Grande! Ora sto ricompilando il pyqt4 con use webkit e sql e sta installando ora xine-lib senza problemi! Ha risolto la cosa in 2 secondi proprio..grazie mille! Prima di chiudere il topic volevo vedere se anche l'installazione del kde va a buon fine: appena e' tutto finito lo chiudo. Ultima cosa: ma questi .la file e .la archivi cosa sono? Ho cercato su google ma avendo solo il cellulare per navigare, con portatile impegnato, non ho potuto ottenere grandi info..grazie ancora per l'aiuto
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Fri Oct 22, 2010 9:17 am    Post subject: Reply with quote

di preciso non so, da quanto dice il manuale sono "libtool control file name"

http://www.gnu.org/software/libtool/manual/html_node/Linking-libraries.html
Back to top
View user's profile Send private message
Cristian75
Apprentice
Apprentice


Joined: 30 Nov 2005
Posts: 234

PostPosted: Fri Oct 22, 2010 9:37 am    Post subject: Reply with quote

Sono sicuro che non avrai piu problemi a compilare, quel comando è miracoloso :D
_________________
La musica che ascolto : http://www.last.fm/user/Cristian75/
La mia Webradio ---> http://95.211.15.229:8000/
utente numero 381833 su Linux Counter
http://counter.li.org.
Coltiva Linux che tanto Windows si pianta da solo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum