Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[nss-3.12.8]nss make failed (solved)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Sat Oct 16, 2010 7:21 am    Post subject: [nss-3.12.8]nss make failed (solved) Reply with quote


Je n'arrive pas a "upgrader" nss.
au début, j'ai eu une erreur liée a nspr donc j'ai re-compiler nspr (ainsi que les depends pkg de nspr)

là j'ai une erreur, que je n'arrive a résoudre:

i686-pc-linux-gnu-gcc -o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/hash.o -c -O2 -fno-strict-aliasing -ansi -D_POSIX_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE -fPIC -Di386 -DLINUX2_1  -Wall -Werror-implicit-function-declaration -Wno-switch -pipe -DLINUX -Dlinux -DHAVE_STRERROR -DXP_UNIX -UDEBUG -DNDEBUG -D_REENTRANT -DNSS_ENABLE_ECC -DUSE_UTIL_DIRECTLY -I/usr/include/nspr -I../../../dist/Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/include -I../../../dist/public/nss -I../../../dist/private/nss -I/usr/include/nspr -I../../../dist/Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/include/dbm -I../../../dist/public/nspr  -O2 -march=native -pipe hash.c
rm -f Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/libnssb.a
ar cr Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/libnssb.a Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/arena.o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/error.o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/errorval.o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/hashops.o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/libc.o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/tracker.o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/item.o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/utf8.o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/list.o Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/hash.o
ranlib Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/libnssb.a
../../../coreconf/nsinstall/Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/nsinstall -t -m 664 Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/libnssb.a ../../../dist/Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/lib
make[2]: quittant le répertoire « /var/tmp/portage/dev-libs/nss-3.12.8/work/nss-3.12.8/mozilla/security/nss/lib/base »
cd dev; make libs
make[2]: entrant dans le répertoire « /var/tmp/portage/dev-libs/nss-3.12.8/work/nss-3.12.8/mozilla/security/nss/lib/dev »
/proc/10293/cmdline: ../../../coreconf/nsinstall/Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/nsinstall -D Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ

/bin/sh: line 1: 10293 Abandon                 ../../../coreconf/nsinstall/Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/nsinstall -D Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ
make[2]: *** [Linux2.6_x86_i686-pc-linux-gnu-gcc_glibc_PTH_OPT.OBJ/devslot.o] Erreur 134
make[2]: quittant le répertoire « /var/tmp/portage/dev-libs/nss-3.12.8/work/nss-3.12.8/mozilla/security/nss/lib/dev »
make[1]: *** [libs] Erreur 2
make[1]: quittant le répertoire « /var/tmp/portage/dev-libs/nss-3.12.8/work/nss-3.12.8/mozilla/security/nss/lib »
make: *** [libs] Erreur 2
emake failed
 * ERROR: dev-libs/nss-3.12.8 failed:
 *   nss make failed
 * Call stack:
 *, line  56:  Called src_compile
 *   environment, line 2667:  Called die
 * The specific snippet of code:
 *       emake -j1 CC="$(tc-getCC)" || die "nss make failed"
 * If you need support, post the output of 'emerge --info =dev-libs/nss-3.12.8',
 * the complete build log and the output of 'emerge -pqv =dev-libs/nss-3.12.8'.
 * The complete build log is located at '/var/tmp/portage/dev-libs/nss-3.12.8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/nss-3.12.8/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/nss-3.12.8/work/nss-3.12.8'

le log complet:

ci-dessous emerge --info =dev-libs/nss-3.12.8:

# emerge --info =dev-libs/nss-3.12.8
Portage (default/linux/x86/10.0/desktop, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35-zen2 i686)
                        System Settings
System uname: Linux-2.6.35-zen2-i686-Intel-R-_Celeron-R-_CPU_2.60GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 16 Oct 2010 06:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm AdobeFlash-10.1"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news nodoc parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr fr_FR"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/vdr-devel /usr/local/portage/layman/x11 /usr/local/portage/layman/hardened-development /usr/local/portage/local-overlay"
USE="X a52 aac acl acpi alsa berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cups cupsddk cxx dbus dri dts dvb dvd dvdr dvdread dxr3 emboss encode exif fam ffmpeg firefox flac gdbm gif gnutls gpm gtk hal hardened iconv java jpeg jpeg2k lame lcms ldap libnotify lock mad mikmod mmx mng modules mp3 mp4 mpeg mplayer mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pae pam pango pcre pdf perl png ppds pppd python qt3support quicktime readline reflection scanner sdl session spell sse sse2 ssl startup-notification svg symlink sysfs tcpd theora thunar tiff truetype unicode usb v4l v4l2 vcd vdr vorbis win32codecs x264 x86 xcb xcomposite xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" PHP_TARGETS="php-5.2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"


Last edited by elyes on Thu Oct 21, 2010 6:48 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Oct 16, 2010 7:35 am    Post subject: Reply with quote

Il semblerait que ce soit cela :
Merci de respecter les règles du forum.

Mon site perso :
Mon PORTDIR_OVERLAY : ou layman -a xwing
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 27 Apr 2008
Posts: 121
Location: Calvados Normandie France

PostPosted: Thu Oct 21, 2010 6:48 pm    Post subject: Reply with quote


en passant à gcc-4.4.5, le problème est résolu.

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum