Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ok] !!! CANNOT IMPORT HTTP.CLIENT: No module named httplib
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Oct 15, 2010 10:48 am    Post subject: [ok] !!! CANNOT IMPORT HTTP.CLIENT: No module named httplib Reply with quote

uno dei miei sistemi, costruito in chroot, produce l'errore l'errore in oggetto come di seguito:
Code:

s939 ~ # emerge -1 baselayout --nodeps
... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/baselayout-2.0.1
 * baselayout-2.0.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...              [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]

 * Using bashrcng profile [ 1.1.4 ]

 * Activating shmfs plugin:
 *   SHM TYPE : tmpfs on /var/tmp/portage/sys-apps/baselayout-2.0.1
 *   Dropping clean caches ...                                                                                                                        [ ok ]
 *   Tweaking Memory Allocator Policy ...                                                                                                             [ ok ]
 *   Mounting the Shared Memory Filesystem ...                                                                                                        [ ok ]
 * CPV:  sys-apps/baselayout-2.0.1
 * REPO: gentoo
 * USE:  elibc_glibc kernel_linux userland_GNU x86
>>> Unpacking source...
>>> Unpacking baselayout-2.0.1.tar.bz2 to /var/tmp/portage/sys-apps/baselayout-2.0.1/work
>>> Source unpacked in /var/tmp/portage/sys-apps/baselayout-2.0.1/work
>>> Compiling source in /var/tmp/portage/sys-apps/baselayout-2.0.1/work/baselayout-2.0.1 ...
make -j9 -s
>>> Source compiled.
>>> Test phase [not enabled]: sys-apps/baselayout-2.0.1

>>> Install baselayout-2.0.1 into /var/tmp/portage/sys-apps/baselayout-2.0.1/image/ category sys-apps
make -j9 -s OS=Linux LIB=lib DESTDIR=/var/tmp/portage/sys-apps/baselayout-2.0.1/image/ install
>>> Completed installing baselayout-2.0.1 into /var/tmp/portage/sys-apps/baselayout-2.0.1/image/

>>> Done.
!!! CANNOT IMPORT HTTP.CLIENT: No module named httplib

>>> Installing (1 of 1) sys-apps/baselayout-2.0.1
 * Running lafilefixer ...                                                                                                                            [ ok ]
 * Wiping /var/tmp/portage
 *
 *   Unmounting memory device(s):
 *     [ tmpfs ] on /var/tmp/portage/sys-apps/baselayout-2.0.1 ...                                                                                    [ ok ]
 *     Restoring memory allocator policy ...                                                                                                          [ ok ]
 *
 * now /var/tmp/portage it's spick and span!

>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

non ho alba di come muovermi.
idee?
_________________
vu vu vu
gentù
mi piaci tu


Last edited by cloc3 on Fri Oct 15, 2010 11:55 am; edited 1 time in total
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Fri Oct 15, 2010 11:34 am    Post subject: Reply with quote

Httplib dovrebbe essere un modulo di python, prova a ricompilarlo (se funziona la compilazione almeno per python).
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Oct 15, 2010 11:55 am    Post subject: Reply with quote

si, grazie. è stato sufficiente ricompilare python. ma la versione 2.6.
non ne uscivo perché sto usando portage con la USE python3 e pensavo che il vecchio fosse fuori gioco.

edit: forse ho anche individuato la causa all'origine del pasticcio.
l'upgrade di openssl condotto male.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum