Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[iPhone] Synchronisation avec Amarok
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ShreCkito
n00b
n00b


Joined: 25 Dec 2007
Posts: 24

PostPosted: Tue Oct 12, 2010 5:33 pm    Post subject: [iPhone] Synchronisation avec Amarok Reply with quote

Bonsoir à tous,

J'essaie de connecter mon iPhone, pour pouvoir gérer la musique via Amarok. Cela est apparemment possible au vu des différentes sources que j'ai trouvé. Le problème est qu'elles sont assez vieilles et que je n'arrive pas au résultat voulu à ce jour.

J'ai compilé Amarok avec l'use "ipod", Emergé "libimobiledevice", "libgpod". A force de mélanger les différents posts que j'ai trouvé (avec pour certains des dates très différentes), je suis complétement perdu, sur la méthode à appliquer à aujourd'hui.

Mon iOS est le 4.1.

Quelqu'un aurait il tenté l'expérience récemment et pourrait m'aiguiller ?

Peut-être que ca aidera, mon "dmesg | less" à la connexion de l'iphone :
Quote:
usb 1-2: new high speed USB device using ehci_hcd and address 6 ipheth 1-2:4.2: Apple iPhone USB Ethernet device attached
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Tue Oct 12, 2010 6:04 pm    Post subject: Reply with quote

C'est possible de faire ça ? Parce qu'au temps ancien de l'ipod touch c'était la croix et la bannière pour synchroniser quoi que ce soit hors itunes ... non seulement il fallait utiliser un iOS cracké mais en plus il fallait passer par un montage ssh en wifi, à cause de l'USB crypté ... bref la loose =D
_________________
Ez.
Back to top
View user's profile Send private message
Tanki
Apprentice
Apprentice


Joined: 29 Mar 2005
Posts: 195
Location: Bordeaux/France

PostPosted: Tue Oct 12, 2010 11:52 pm    Post subject: Reply with quote

as tu emergé ifuse ?
si oui as tu tenté de monter ton iphone avec :
Code:

ifuse /point/de/montage


:?:

chez moi ça marche très bien avec gtkpod et mon ipod touch 3G en iOS 4
_________________
Kick Ass !
Dell XPS 13 Developer Edition 9350 | Intel Core i7 @2.20 GHz | 16 Go DDR3 | SSD Samsung PM951 NVMe 512Go
Back to top
View user's profile Send private message
22decembre
Guru
Guru


Joined: 08 May 2010
Posts: 308
Location: Paris, banlieue sud (Massy et alentours)

PostPosted: Sun Oct 17, 2010 8:53 am    Post subject: Reply with quote

Tanki wrote:
as tu emergé ifuse ?
si oui as tu tenté de monter ton iphone avec :
Code:

ifuse /point/de/montage


:?:

chez moi ça marche très bien avec gtkpod et mon ipod touch 3G en iOS 4


Alors ? Si ceci ne marche pas, essaye de voir quelles sont tes interfaces internet... le rendu de dmesg ressemble furieusement à la connexion de mon windows mobile (aussi ethernet over usb) qui m'ajoute une interface rndis. J'ai donc dû créer une règle de pare-feu adéquate. As-tu un pare-feu donc ?
_________________
Portable Gentoo installé depuis ~fevrier 2010, kde4 ( doc : http://www.22decembre.eu/gentoo-portable/)
Serveur Maison Gentoo depuis ~avril 2010 (doc : http://www.22decembre.eu/gentoo-serveur/)
http://www.22decembre.eu
Back to top
View user's profile Send private message
ShreCkito
n00b
n00b


Joined: 25 Dec 2007
Posts: 24

PostPosted: Tue Oct 19, 2010 7:05 pm    Post subject: Reply with quote

Bonsoir,

Désolé de la réponse tardive, ai eut beaucoup de taff.
ifuse ne marche pas chez moi. L'iPhone se monte avec ifuse, à priori tout va bien, mais gtkpod me ressort une erreur quand je veux le recharger (Je n'ai pas le message entier, il est mangé par la dimension du pop-up qui apparait).

Par contre, pour ma part, pas de parefeu. Donc aucune idée.
Back to top
View user's profile Send private message
Tanki
Apprentice
Apprentice


Joined: 29 Mar 2005
Posts: 195
Location: Bordeaux/France

PostPosted: Tue Oct 19, 2010 10:19 pm    Post subject: Reply with quote

hum on dirait un soucis de config de gtkpod

si ton iphone à l'air d'etre bien monté, peux tu lister le contenu du répertoire ?
as tu quelque chose qui ressemble à ça :
Code:

tanki@mozafoka /mnt $ ls ipod/ -l
total 0
-rw-r--r-- 1 tanki users   0  3 mai   13:36 com.apple.itdbprep.postprocess.lock
-rw-r--r-- 1 tanki users   0  3 mai   13:36 com.apple.itunes.lock_sync
drwxr-xr-x 2 tanki users  68 18 déc.   2009 DCIM
drwxr-xr-x 2 tanki users 102  5 oct.  14:17 Downloads
drwxr-xr-x 6 tanki users 204  5 mai   18:02 iTunes_Control
drwxr-xr-x 2 tanki users  68 18 déc.   2009 Photos
drwxr-xr-x 2 tanki users  68  3 mai   13:36 Podcasts
drwxr-xr-x 2 tanki users  68  5 mai   18:32 PublicStaging
drwxr-xr-x 2 tanki users  68  3 mai   13:36 Purchases
drwxr-xr-x 2 tanki users  68  3 mai   13:37 Recordings
drwxr-xr-x 2 tanki users 102  5 mai   21:20 Safari


si tu as ce contenu c'est une bonne chose

il te reste plus qu'a démarrer gtkpod, tu n'as pas à configurer d'ipod, avec la derniere version il configure le repository pour ton ipod une fois que celui ci est monté correctement avec ifuse


les softs et les version que j'ai :
Code:

ifuse 1.0.0
libimobiledevice 1.0.2
libplist 1.3
usbmuxd  1.0.5
gtkpod 0.99.16
libgpod 0.7.95


avec tout ça, ça marche comme il faut :)
_________________
Kick Ass !
Dell XPS 13 Developer Edition 9350 | Intel Core i7 @2.20 GHz | 16 Go DDR3 | SSD Samsung PM951 NVMe 512Go
Back to top
View user's profile Send private message
Tanki
Apprentice
Apprentice


Joined: 29 Mar 2005
Posts: 195
Location: Bordeaux/France

PostPosted: Wed Oct 20, 2010 12:19 pm    Post subject: Reply with quote

le lendemain ...

pff j'avais pas percuté c'est avec amarok, alors là je sèche un peu vu que je ne le connais pas
tu as les USE qu'il faut :?:
_________________
Kick Ass !
Dell XPS 13 Developer Edition 9350 | Intel Core i7 @2.20 GHz | 16 Go DDR3 | SSD Samsung PM951 NVMe 512Go
Back to top
View user's profile Send private message
ShreCkito
n00b
n00b


Joined: 25 Dec 2007
Posts: 24

PostPosted: Wed Oct 20, 2010 7:27 pm    Post subject: Reply with quote

J'ai bien les même versions que toi.
Je viens de tenter, au final, Amarok ou autre, si j'arrive à gérer la musique, peu importe.

Code:
tux ~ # ls -l /mnt/ipod/
total 0
drwxr-xr-x 2 root root  68 20 sept. 11:41 ApplicationArchives
drwxr-xr-x 3 root root 136 10 oct.  20:34 Books
-rw-r--r-- 1 root root   0 28 juin  11:26 com.apple.dbaccess.lock
-rw-r--r-- 1 root root   0 28 juin  11:26 com.apple.itdbprep.postprocess.lock
-rw-r--r-- 1 root root   0 28 juin  11:26 com.apple.itunes.lock_sync
drwxr-xr-x 4 root root 136 28 juin  11:33 DCIM
drwxr-xr-x 2 root root 102 18 oct.  02:19 Downloads
drwxr-xr-x 6 root root 204 10 oct.  20:20 iTunes_Control
drwxr-xr-x 5 root root 272 20 oct.  20:27 PhotoData
drwxr-xr-x 3 root root 136 20 sept. 12:16 Photos
drwxr-xr-x 2 root root  68 28 juin  11:26 Podcasts
drwxr-xr-x 2 root root  68 28 juin  16:18 PublicStaging
drwxr-xr-x 2 root root  68 28 juin  11:26 Purchases
drwxr-xr-x 2 root root 136  2 sept. 20:20 Recordings
drwxr-xr-x 2 root root  68 13 oct.  22:51 Safari


Mon ls semble donc bon. Par contre, lorsque je clic sur "Load" voilà le message complet d'erreur (j'arrive à aggrandir la fenêtre en fait ...) :

Quote:
ERROR initialising iPod: Problem creating iPod directory or file: '/mnt/ipod/iTunes_Control'.


J'ai tenté de créer moi même ce dossier, une fois fait je ne peux plus monter l'ipod avec ifuse. J'ai tenté un :
Code:
chmod 777 /mnt/ipod/

Un peu bourrin, mais au moins ... Autre message d'erreur tout aussi peu encourageant.

Le montage se fait bien à priori mais derrière pour accéder à ce foutu iPhone . . .
Merci des lumières dans tous les cas.

Edit : Tiens, en lançant gtkpod en root (pas terrible), après 1 ou 2 message d'erreur, j'ai accès à mes musiques ... Une idée ??!
Back to top
View user's profile Send private message
Tanki
Apprentice
Apprentice


Joined: 29 Mar 2005
Posts: 195
Location: Bordeaux/France

PostPosted: Wed Oct 20, 2010 9:37 pm    Post subject: Reply with quote

bon je crois que j'ai trouvé
il semblerait qu'il s'agisse d'un pitit problème avec usbmux

que te donne un
Code:
groups usbmux


et aussi un
Code:
groups
:?:

usbmux et moi même appartenons au même group plugdev
sinon tu peux te rajouter au groupe usbmux ya pas de raison pour que ça marche pas

Code:
gpasswd -a usbmux

_________________
Kick Ass !
Dell XPS 13 Developer Edition 9350 | Intel Core i7 @2.20 GHz | 16 Go DDR3 | SSD Samsung PM951 NVMe 512Go
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum