Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] emerge pulseaudio errore
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Cristian75
Apprentice
Apprentice


Joined: 30 Nov 2005
Posts: 234

PostPosted: Mon Oct 11, 2010 7:10 pm    Post subject: [Risolto] emerge pulseaudio errore Reply with quote

Salve ragazzi ho un problema con la mia cara gentoo

Code:
ERROR: media-sound/pulseaudio-0.9.21.1 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 3358:  Called _eapi2_src_compile
 *     ebuild.sh, line  646:  Called die
 * The specific snippet of code:
 *         emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =media-sound/pulseaudio-0.9.21.1',
 * the complete build log and the output of 'emerge -pqv =media-sound/pulseaudio-0.9.21.1'.
 * The complete build log is located at '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/temp/environment'.
 * S: '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/work/pulseaudio-0.9.21.1'

ditemi tutto quello che vi serve sapere e vi posto tutto.
_________________
La musica che ascolto : http://www.last.fm/user/Cristian75/
La mia Webradio ---> http://95.211.15.229:8000/
utente numero 381833 su Linux Counter
http://counter.li.org.
Coltiva Linux che tanto Windows si pianta da solo


Last edited by Cristian75 on Mon Oct 11, 2010 11:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
Meconiotronic
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2007
Posts: 99

PostPosted: Mon Oct 11, 2010 7:23 pm    Post subject: Reply with quote

Innanzitutto la riga contenente l'errore poi se su pastebin puoi incollare il contenuto di build.log sarebbe meglio.

Combinazione l'ho installato prprio ieri senza problemi risolvendo così tutti i problemi audio che avevo da anni!
Back to top
View user's profile Send private message
Cristian75
Apprentice
Apprentice


Joined: 30 Nov 2005
Posts: 234

PostPosted: Mon Oct 11, 2010 10:20 pm    Post subject: Reply with quote

Salve rieccomi posto le prime richieste
build.log ---> http://pastebin.com/rvM5hbBK

prime righe del errore generato dal emerge
Code:

Merging translations into daemon/pulseaudio.desktop.
Merging translations into daemon/pulseaudio-kde.desktop.
/bin/grep: /usr/lib/libFLAC.la: No such file or directory
/bin/sed: can't read /usr/lib/libFLAC.la: No such file or directory
libtool: link: `/usr/lib/libFLAC.la' is not a valid libtool archive
make[3]: *** [libpulsecommon-0.9.21.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/work/pulseaudio-0.9.21.1/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/work/pulseaudio-0.9.21.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/work/pulseaudio-0.9.21.1'
make: *** [all] Error 2
 * ERROR: media-sound/pulseaudio-0.9.21.1 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 3330:  Called _eapi2_src_compile
 *     ebuild.sh, line  646:  Called die
 * The specific snippet of code:
 *         emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =media-sound/pulseaudio-0.9.21.1',
 * the complete build log and the output of 'emerge -pqv =media-sound/pulseaudio-0.9.21.1'.
 * The complete build log is located at '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/temp/environment'.
 * S: '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/work/pulseaudio-0.9.21.1'

>>> Failed to emerge media-sound/pulseaudio-0.9.21.1, Log file:

>>>  '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/temp/build.log'

 * Messages for package media-sound/pulseaudio-0.9.21.1:

 * ERROR: media-sound/pulseaudio-0.9.21.1 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 3330:  Called _eapi2_src_compile
 *     ebuild.sh, line  646:  Called die
 * The specific snippet of code:
 *         emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =media-sound/pulseaudio-0.9.21.1',
 * the complete build log and the output of 'emerge -pqv =media-sound/pulseaudio-0.9.21.1'.
 * The complete build log is located at '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/temp/environment'.
 * S: '/var/tmp/portage/media-sound/pulseaudio-0.9.21.1/work/pulseaudio-0.9.21.1

grazie.
_________________
La musica che ascolto : http://www.last.fm/user/Cristian75/
La mia Webradio ---> http://95.211.15.229:8000/
utente numero 381833 su Linux Counter
http://counter.li.org.
Coltiva Linux che tanto Windows si pianta da solo
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Mon Oct 11, 2010 10:27 pm    Post subject: Reply with quote

Emergi "dev-util/lafilefixer" e controlla di aver installato il pacchetto "app-portage/gentoolkit", poi esegui
Code:
lafilefixer --justfixit && revdep-rebuild --verbose --ignore
Back to top
View user's profile Send private message
Cristian75
Apprentice
Apprentice


Joined: 30 Nov 2005
Posts: 234

PostPosted: Mon Oct 11, 2010 11:19 pm    Post subject: Reply with quote

Grazie mille ora sembra che abbia risolto.
toglimi una curiosità.
esattamente cosa abbiamo fatto con quel comando e per quale motivo abbiamo dovuto usarlo ?
ho sbagliato io qualcosa nella gestione della distro ?
_________________
La musica che ascolto : http://www.last.fm/user/Cristian75/
La mia Webradio ---> http://95.211.15.229:8000/
utente numero 381833 su Linux Counter
http://counter.li.org.
Coltiva Linux che tanto Windows si pianta da solo
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Tue Oct 12, 2010 6:24 am    Post subject: Reply with quote

l'output dell'errore era molto chiaro
Code:
/usr/lib/libFLAC.la: No such file or directory
quindi sei dovuto correre ai ripari con quei tools.

P.S. ogni volta che termini un'aggiornamento è buono che tu lanci sempre quei tools, documentati a riguardo se vuoi approfondire
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Cristian75
Apprentice
Apprentice


Joined: 30 Nov 2005
Posts: 234

PostPosted: Tue Oct 12, 2010 3:24 pm    Post subject: Reply with quote

ago wrote:
l'output dell'errore era molto chiaro
Code:
/usr/lib/libFLAC.la: No such file or directory
quindi sei dovuto correre ai ripari con quei tools.

P.S. ogni volta che termini un'aggiornamento è buono che tu lanci sempre quei tools, documentati a riguardo se vuoi approfondire

ok grazie mille.
_________________
La musica che ascolto : http://www.last.fm/user/Cristian75/
La mia Webradio ---> http://95.211.15.229:8000/
utente numero 381833 su Linux Counter
http://counter.li.org.
Coltiva Linux che tanto Windows si pianta da solo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum