Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Couldn't load plugin .so when starting ppp init... [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
jorro
n00b
n00b


Joined: 09 Feb 2010
Posts: 20

PostPosted: Sun Oct 10, 2010 12:28 pm    Post subject: Couldn't load plugin .so when starting ppp init... [solved] Reply with quote

Hi everyone,

I recently got a Huawei E1550 HSDPA USB stick. It works perfectly on my Thinkpad, but on my Netbook I get this strange error message when running the init script:

Code:

bigfin linux # /etc/init.d/net.ppp0 start
 * Service net.ppp0 starting
/usr/sbin/pppd: /usr/lib/pppd/2.4.5/.so: cannot open shared object file: No such file or directory
/usr/sbin/pppd: Couldn't load plugin .so
 * Service net.ppp0 started


The stick loads correctly, the kernel settings are Ok, just the stick doesn't connect. I don't really get why he wants to load ".so". The settings are the same as on the Thinkpad:

Code:

bigfin linux # cat /etc/conf.d/net
 config_ppp0="ppp"
 link_ppp0="/dev/ttyUSB0"
 plugins_ppp0=""
 username_ppp0="nobody"
 password_ppp0="nothing"
 pppd_ppp0="lock defaultroute noipdefault noauth usepeerdns 460800"
 phone_number_ppp0="*99#"
 chat_ppp0="
        'ABORT' 'BUSY'
        'ABORT' 'NO ANSWER'
        'ABORT' 'NO CARRIER'
        'ABORT' 'NO DIALTONE'
        'ABORT' 'Invalid Login'
        'ABORT' 'Login incorrect'
        'TIMEOUT' '5'
        '' 'ATZ'
        'OK' 'AT+CPIN?'
        'READY-AT+CPIN=XXXX-OK' ''
        'OK' 'ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0'
        'OK' 'AT+CGDCONT=1,\\\"IP\\\",\\\"internet\\\"'
        'OK' 'ATDT\T'
        'CONNECT' ''
        '~--' ''
 "


My emerge --info:

Code:

bigfin linux # emerge --info ppp
Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.11.2-r0, 2.6.34-gentoo-r6 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.34-gentoo-r6-i686-Intel-R-_Atom-TM-_CPU_N270_@_1.60GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 08 Oct 2010 18:35:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests buildsyspkg distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/zugaina /usr/portage/local/layman/sunrise /usr/portage/local/layman/emacs"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3ddnow X a52 aac aalib acl acpi alsa automount avhi bash-completion bindist bluetooth branding bzip2 cairo caps cdb cddb cli consolekit cracklib crypt cups curl cvs cxx dbus directfb dri dts dvb emacs emboss encode esd exif fam ffmpg firefox flac fortran gd gdbm gif git gpm gps gstreamer gtk gtk2 hal iconv ieee1394 ipv6 ispell java javascript jpeg latex lcms libnotify lm_sensors mad mailwrapper mikmod mmx mng modules mp3 mp4 mpeg mudflap mysql ncurses nls nptl nptlonly nptonly nsplugin nxclient ofensive ogg opengl openmp pam pango pcre pdf perl pmu png posix ppds ppp pppd prediction python qt3 qt3support qt4 quicktime readline reflection samba sdl server session speechd spell ssl startup-notification subversion svg symlink sysfs tcpd threads tiff transcode truetype type1 unicode usb v4l v4l2 vim-syntax vorbis wifi win32codecs x264 x86 xcb xine xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en de" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

net-dialup/ppp-2.4.5 was built with the following:
USE="gtk ipv6 pam -activefilter -atm -dhcp -eap-tls -radius"


I tried the unstable 2.4.5 to see if anything changes, the same happens with the stable 2.4.4-r24 and 2.4.4-r25.

Any Ideas?

Thanks,

Jorro


Last edited by jorro on Tue Feb 01, 2011 12:38 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46326
Location: 56N 3W

PostPosted: Sun Oct 10, 2010 1:34 pm    Post subject: Reply with quote

jorro,

Can you connect with wvdial ?

wvdial is more primitive, it gets the serial link up then blindly starts PPP and hopes for the best.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jorro
n00b
n00b


Joined: 09 Feb 2010
Posts: 20

PostPosted: Sun Oct 10, 2010 1:57 pm    Post subject: Reply with quote

Hi,

NeddySeagoon wrote:
Can you connect with wvdial ?

wvdial is more primitive, it gets the serial link up then blindly starts PPP and hopes for the best.


This works. I get a connection and can open web pages etc. Thanks.

Still, I would prefer using the init script. :)

Thanks for the quick reply,

Jorro
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46326
Location: 56N 3W

PostPosted: Sun Oct 10, 2010 2:30 pm    Post subject: Reply with quote

jorro,

Thats odd. Its using the same PPP in both cases.

I don't unserstand the .so problem as .so is a library extension - there should be something before the .so
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
couchbotato
n00b
n00b


Joined: 07 Oct 2010
Posts: 45
Location: Finland

PostPosted: Sun Oct 10, 2010 2:35 pm    Post subject: Reply with quote

I had this same problem and I solved it buying a 3G router.
It would be nice to have solution for this though.

edit: mine was Huawei e1552
Back to top
View user's profile Send private message
jorro
n00b
n00b


Joined: 09 Feb 2010
Posts: 20

PostPosted: Sun Oct 10, 2010 2:36 pm    Post subject: Reply with quote

Hi again,

NeddySeagoon wrote:
Thats odd. Its using the same PPP in both cases.

I don't unserstand the .so problem as .so is a library extension - there should be something before the .so


Yes, thats the point that confuses me. the libraries are there, just he tries to load something weird. This is the strange part:

Code:
/usr/sbin/pppd: /usr/lib/pppd/2.4.5/.so: cannot open shared object file: No such file or directory


The libraries are there, everything in the folder as it should be. I don't know what he tries to do there.
Back to top
View user's profile Send private message
jorro
n00b
n00b


Joined: 09 Feb 2010
Posts: 20

PostPosted: Sun Oct 10, 2010 10:16 pm    Post subject: Reply with quote

couchbotato wrote:
I had this same problem and I solved it buying a 3G router.
It would be nice to have solution for this though.

edit: mine was Huawei e1552


Well, I know it works. There is no problem on my main Notebook. So, somehow it should work on the Netbook too.
Back to top
View user's profile Send private message
StevePER
n00b
n00b


Joined: 28 Jan 2004
Posts: 50
Location: Perth, Australia

PostPosted: Sun Jan 30, 2011 11:57 pm    Post subject: Reply with quote

Old thread I know, but I just had the same problem and fixed it by commenting out the following line from /etc/conf.d/net
Code:
#plugins_ppp0=""

I'm using a Huawei E160e.
Back to top
View user's profile Send private message
jorro
n00b
n00b


Joined: 09 Feb 2010
Posts: 20

PostPosted: Mon Jan 31, 2011 9:02 pm    Post subject: Reply with quote

StevePER wrote:
...commenting out the following line from /etc/conf.d/net
Code:
#plugins_ppp0=""



Nice. That worked. Now I am at the next error (which I will take care of when I find the time :) )

Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum