Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RESOLU] [XORG] Probleme de Fonts en dualscreen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
256JMaN
n00b
n00b


Joined: 20 May 2006
Posts: 37

PostPosted: Sat Oct 09, 2010 7:34 am    Post subject: [RESOLU] [XORG] Probleme de Fonts en dualscreen Reply with quote

Bonjour à tous !

Voila mon petit problème :

Sur ma config je dispose d'un ecran TFT 19' classique qui à une résolution de 1280x1024 branché en DVI et juste à coté j'ai ma télé LCD 22" (résolution 1360x768 branché en VGA) que j'ajoute en twinview via nvidia-settings quand bon me semble.

Le soucis, c'est que je ne comprends pas pourquoi mes fonts qui etaient normal en single screen "rétrécissent" en dualscreen. j'ai l'impression qu'une font en taille 9 à la taille d'une font de 3 (ce qui est pas tres agréable pour lire, du coup je suis obligé de la passé en taille 18 pour pouvoir lire les info sans ma loupe, et quand je revient en singlescreen je doit les remettre ne taille 9 pour ne pas avoir des écriture énorme)

J'ai remarqué que sur chromium le fonts des menu subissent ce rétrécissement et pas le contenu affiché par ce dernier.

j'utilise KDE et voici mon xorg.conf

Code:

  # nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (root@livecd)  Sun Sep  5 09:34:06 Local time zone must be set--see zic manual page 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Thu Apr 22 20:35:23 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "OEM 22W_LCD_TV"
    HorizSync       31.5 - 80.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9800 GT"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1280+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "CRT: nvidia-auto-select +1280+0, DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Last edited by 256JMaN on Sat Oct 09, 2010 9:43 am; edited 1 time in total
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sat Oct 09, 2010 9:10 am    Post subject: Reply with quote

Salut,

ça sent le DPI foireux en dual head. Essaye de forcer le DPI, soit grâce à une appli de ton DM (Gnome, KDE, Xfce..), soit vian xrandr --dpi , soit encore directement dans xorg.conf.

Exemple ici : http://wiki.archlinux.org/index.php/Xorg#Display_Size_and_DPI
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
256JMaN
n00b
n00b


Joined: 20 May 2006
Posts: 37

PostPosted: Sat Oct 09, 2010 9:42 am    Post subject: Reply with quote

Super !
(j'aurai du y penser quand même :roll: )

dans kde j'ai modifié cette option : systemsettings ; apparence > Polices > force Fonts DPI et on choisis 120 ou 96

Et mes yeux te disent merci ! 8O
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Oct 09, 2010 2:26 pm    Post subject: Reply with quote

Pour nvidia, tu peux aussi le régler dans le xorg.conf, en ajoutant ceci dans la section Device (option du driver nvidia) :
Code:
Option      "DPI"                   "98x98"

Cela à l'avantage de ne pas dépendre de kde ou autre.


Accessoirement, pourquoi je met 98dpi ?
Ben essaye ;) Le rendu des fontes à l'écran est LARGEMENT meilleur à 98dpi que 96dpi (qui pourtant est la valeur "standard" ;))
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum