Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X11 errors with ATi Mobility card
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
r0ck80y
Tux's lil' helper
Tux's lil' helper


Joined: 03 May 2007
Posts: 98

PostPosted: Wed Oct 06, 2010 2:09 pm    Post subject: X11 errors with ATi Mobility card Reply with quote

Hi,

I emerged the closed-source 'ati-drivers' for the ATi Mobility Radeon HD 5470 card on my pc. I was a bit confused between 'radeon' and 'fglrx' and chose the latter (and added the same in the VIDEO_CARDS section in make.conf file). after installing i ran the initial 'aticonfig' command as instructed and it generated the following xorg.conf file:
Code:
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:2:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection


It wasn't working till i added the following in the file:
Code:
Section "Module"
        #Load  "dri"
        Load  "glx
EndSection



Now when i run 'startx', i get the following errors but there are no issues in booting into x-environment:
Code:
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)
(WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found


There are no errors in running fgl_glxgears and the fglrxinfo output is as follows:
Code:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 5400 Series
OpenGL version string: 4.0.10151 Compatibility Profile Contex


Also i have the following enabled in kernel:
Code:
Graphics support  --->
       <*> /dev/agpgart (AGP Support)  --->
              <* >   Intel 440LX/BX/GX, I8xx and E7x05 chipset support
        [*] VESA VGA graphics support
        < > ATI Radeon display support


Do i need to disable the starred ones above for this to work?

TIA
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Wed Oct 06, 2010 2:27 pm    Post subject: Reply with quote

Quote:
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)
(WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found


That's actually normal, i get them same errors on my home system with ati.
I never had to add the module section. Not sure about that, maybe you didn't do "eselect opengl set ati" first though it appears your using ati opengl.
Back to top
View user's profile Send private message
r0ck80y
Tux's lil' helper
Tux's lil' helper


Joined: 03 May 2007
Posts: 98

PostPosted: Wed Oct 06, 2010 2:38 pm    Post subject: Reply with quote

rh1 wrote:


That's actually normal, i get them same errors on my home system with ati.
I never had to add the module section. Not sure about that, maybe you didn't do "eselect opengl set ati" first though it appears your using ati opengl.


Ok... yeah i set ati as the opengl interface. So you mean its in fully working condition? I can, say, play games and enable framebuffer without any hiccups? Anything else should i add in the xorg.conf file?

I remember nvidia-drivers used to provide a control panel to do some 3d settings. Is there something similar for ati-drivers (In windows theres the catalyst control panel)?
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Wed Oct 06, 2010 3:26 pm    Post subject: Reply with quote

The catalyst control center is there. Look for /opt/bin/amdcccle.( i think). You need to run it as root to change things.
Back to top
View user's profile Send private message
r0ck80y
Tux's lil' helper
Tux's lil' helper


Joined: 03 May 2007
Posts: 98

PostPosted: Wed Oct 06, 2010 4:29 pm    Post subject: Reply with quote

rh1 wrote:
The catalyst control center is there. Look for /opt/bin/amdcccle.( i think). You need to run it as root to change things.

Ohh right! Thanks :)

Also, i was able to remove the error by referring to the very last section of this page -> http://en.gentoo-wiki.com/wiki/Fglrx
Adding the following in the xorg.conf file fixed the error:
Code:
...
Section "Files"
    ModulePath "/usr/lib64/xorg/modules"
    ModulePath "/usr/lib64/opengl/xorg-x11/extensions/"
EndSection
...


but the last warning line is still there:
Code:
(WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found

Not sure what "instance" it is looking for :?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum