Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[LAMP] Error: circular dependencies (en cours)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Gyn
n00b
n00b


Joined: 23 Sep 2010
Posts: 12

PostPosted: Wed Oct 06, 2010 12:27 pm    Post subject: [LAMP] Error: circular dependencies (en cours) Reply with quote

Bonjour,

J'aimerai installer un serveur web.
Pour ce faire j'utilise ce tuto : http://fr.gentoo-wiki.com/wiki/LAMP

Je mets bien les uses dans mon make.conf :

Quote:
USE="-gtk -kde gd qt4 kde dvd alsa cdr apache2 mysql php unicode ssl crypt ctype pcre session"


puis je lance la commande emerge :

Quote:
emerge -av apache php dev-db/mysql phpmyadmin


et j'ai l'erreur suivante :

Quote:
* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

[ebuild N ] dev-db/mysql-5.1.50-r1 USE="community perl ssl -big-tables -cluster -debug -embedded -extraengine -latin1 -max-idx-128 -minimal -pbxt -profiling (-selinux) -static -test -xtradb" 24,423 kB
[ebuild N ] dev-util/cmake-2.8.1-r2 USE="ncurses qt4 -emacs -vim-syntax" 3,522 kB
[ebuild N ] x11-libs/qt-gui-4.6.2 USE="accessibility cups dbus exceptions glib mng qt3support tiff (-aqua) -debug -gtk -nas -nis -pch -raster -xinerama" 156,838 kB
[ebuild N ] net-print/cups-1.3.11-r2 USE="X acl dbus jpeg ldap pam perl php png ppds python ssl tiff -avahi -gnutls -java -kerberos -samba -slp -static -xinetd -zeroconf" LINGUAS="-de -en -es -et -fr -he -id -it -ja -pl -sv -zh_TW" 3,711 kB
[ebuild N ] dev-lang/php-5.2.14 USE="apache2 berkdb bzip2 cli crypt ctype exif filter gd gdbm hash iconv ipv6 json ldap mysql ncurses nls pcre posix readline reflection session simplexml spell spl ssl tokenizer truetype unicode xml xmlreader xmlwriter zlib -adabas -bcmath -birdstep -calendar -cdb -cgi -cjk -concurrentmodphp -curl -curlwrappers -db2 -dbase -dbmaker -debug -discard-path -doc -embed -empress -empress-bcs -esoob -fdftk -firebird -flatfile -force-cgi-redirect -frontbase -ftp -gd-external -gmp -imap -inifile -interbase -iodbc -kerberos -kolab -ldap-sasl -libedit -mcve -mhash -msql -mssql -mysqli -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -postgres -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets -solid -sqlite -suhosin -sybase-ct -sysvipc -threads -tidy -wddx -xmlrpc -xpm -xsl -yaz -zip" 8,852 kB
[ebuild N ] www-servers/apache-2.2.16 USE="ldap ssl -debug -doc (-selinux) -static -suexec -threads" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias -asis -auth_digest -authn_dbd -cern_meta -charset_lite -dbd -dumpio -ident -imagemap -log_forensic -proxy -proxy_ajp -proxy_balancer -proxy_connect -proxy_ftp -proxy_http -substitute -version" APACHE2_MPMS="-event -itk -peruser -prefork -worker" 4,726 kB
[ebuild N ] dev-libs/apr-util-1.3.9 USE="berkdb gdbm ldap mysql -doc -freetds -odbc -postgres -sqlite -sqlite3" 773 kB
[ebuild N ] virtual/mysql-5.1 0 kB

Total: 8 packages (8 new), Size of downloads: 202,842 kB

* Error: circular dependencies:

('ebuild', '/', 'dev-db/mysql-5.1.50-r1', 'merge') depends on
('ebuild', '/', 'dev-util/cmake-2.8.1-r2', 'merge') (buildtime)
('ebuild', '/', 'virtual/mysql-5.1', 'merge') (runtime_post)
('ebuild', '/', 'dev-lang/php-5.2.14', 'merge') depends on
('ebuild', '/', 'www-servers/apache-2.2.16', 'merge') (buildtime)
('ebuild', '/', 'virtual/mysql-5.1', 'merge') (buildtime)
('ebuild', '/', 'net-print/cups-1.3.11-r2', 'merge') depends on
('ebuild', '/', 'dev-lang/php-5.2.14', 'merge') (buildtime)
('ebuild', '/', 'virtual/mysql-5.1', 'merge') depends on
('ebuild', '/', 'dev-db/mysql-5.1.50-r1', 'merge') (runtime)
('ebuild', '/', 'x11-libs/qt-gui-4.6.2', 'merge') depends on
('ebuild', '/', 'net-print/cups-1.3.11-r2', 'merge') (buildtime)
('ebuild', '/', 'www-servers/apache-2.2.16', 'merge') depends on
('ebuild', '/', 'dev-libs/apr-util-1.3.9', 'merge') (buildtime)
('ebuild', '/', 'dev-libs/apr-util-1.3.9', 'merge') depends on
('ebuild', '/', 'virtual/mysql-5.1', 'merge') (buildtime)
('ebuild', '/', 'dev-util/cmake-2.8.1-r2', 'merge') depends on
('ebuild', '/', 'x11-libs/qt-gui-4.6.2', 'merge') (buildtime)

* Note that circular dependencies can often be avoided by temporarily
* disabling USE flags that trigger optional dependencies.

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


J'ai cherche mais a part comprendre que c'est un problème de dépendance surement lié a mon USE je ne sais pas quel option est a activer ou désactiver.
A vos âmes charitables.

Gyn.
Back to top
View user's profile Send private message
sylvain_
n00b
n00b


Joined: 13 Aug 2007
Posts: 56

PostPosted: Sun Oct 10, 2010 1:12 pm    Post subject: Reply with quote

essayes comme ça dit, de désactiver des use flags
par exemple, celui-ci http://gentoo-portage.com/Search?search=&use=php on voit bien qu'il ne sert pas à apache par exemple (je sais c'est bizarre). tant qu'à pcre et session, fais la recherche mais à priori ils sont déjà dans ton profil
emerge --info pour le vérifier
essayes aussi de taper plutôt "emerge phpmyadmin", ça devrait installer par dépendance php et apache déjà si mes souvenirs sont bons.
_________________
hunhun ça vaux mieux que pan tu l'aura
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum