Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[pdf] non li leggo nel browser[risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Oct 01, 2010 3:40 pm    Post subject: [pdf] non li leggo nel browser[risolto] Reply with quote

nel mio sistema, l'unico motore web che, al momento, riesce a incorporare i pdf nel browser è khtml (sia benedetto okular).

webkit, gecko e chromium ciccia.
ho acroread compilato con la use nsplugin.

che altro devo fare?
_________________
vu vu vu
gentù
mi piaci tu


Last edited by cloc3 on Tue Oct 12, 2010 8:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Fri Oct 01, 2010 8:13 pm    Post subject: Reply with quote

Io riesco a vederli (sono su amd64) e fra i plugin ho:
Code:
Adobe Reader 9.3

    File: npwrapper.nppdf.so
    Version:
    The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.

L'unica cosa è che non capisco quale pacchetto mi ha installato questo file!!!
Code:
/usr/lib64/nsbrowser/plugins/npwrapper.nppdf.so


Non so, prova intanto a installare nspluginwrapper e acroread.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Oct 01, 2010 8:45 pm    Post subject: Reply with quote

effettivamente, a 32bit firefox funge.

ma webkit e chromium cilecca lo stesso.
eppure konqueror carica il plugin nppdf.so
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Fri Oct 01, 2010 8:47 pm    Post subject: Reply with quote

Ah, scusa... ho ragionato direttamente come se usassi firefox. Comunque uso firefox a 64 bit e il nspluginwrapper.
Per gli altri, mi dispiace ma non so aiutarti.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1521
Location: Milan, Italy

PostPosted: Fri Oct 01, 2010 10:40 pm    Post subject: Reply with quote

fbcyborg wrote:
L'unica cosa è che non capisco quale pacchetto mi ha installato questo file!!!
Code:
/usr/lib64/nsbrowser/plugins/npwrapper.nppdf.so


Qfile non dice nulla? Può essere un qualcosa installato da plugin non installati da portage altrimenti
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sat Oct 02, 2010 6:28 am    Post subject: Reply with quote

Purtroppo no, non dice nulla. È molto strano infatti! :roll:
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sat Oct 02, 2010 7:29 am    Post subject: Reply with quote

Mi sono perso qualcosa.. come faccio ad installare il plugin per firefox? Devo installare per forza adobe reader o è un altro pacchetto?

:?:
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sat Oct 02, 2010 7:55 am    Post subject: Reply with quote

Adobe reader credo che tu lo debba installare per forza (anzi, credo di aver capito come ho fatto), anche perché è proprio adobe reader ad essere aperto in una pagina di firefox (che gli fa da wrapper appunto).

Ora che ci penso, io ho sempre avuto Adobe Reader e il relativo plugin a 32 bit, però non mi ha mai funzionato sui 64 bit. Credo che abbia preso a funzionare da quando ho installato nspluginwrapper, ed infatti ecco che lo sto usando:
Code:
# nspluginwrapper -l
/usr/lib/firefox/plugins/npwrapper.nppdf.so
  Original plugin: /usr/lib32/nsbrowser/plugins/nppdf.so
  Plugin viewer: /usr/lib64/nspluginwrapper/i386/linux/npviewer
  Wrapper version string: 1.3.0
/usr/lib64/firefox/plugins/npwrapper.nppdf.so
  Original plugin: /usr/lib32/nsbrowser/plugins/nppdf.so
  Plugin viewer: /usr/lib64/nspluginwrapper/i386/linux/npviewer
  Wrapper version string: 1.3.0
/usr/lib/nsbrowser/plugins/npwrapper.nppdf.so
  Original plugin: /usr/lib32/nsbrowser/plugins/nppdf.so
  Plugin viewer: /usr/lib64/nspluginwrapper/i386/linux/npviewer
  Wrapper version string: 1.3.0
/usr/lib64/nsbrowser/plugins/npwrapper.nppdf.so
  Original plugin: /usr/lib32/nsbrowser/plugins/nppdf.so
  Plugin viewer: /usr/lib64/nspluginwrapper/i386/linux/npviewer
  Wrapper version string: 1.3.0

_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Oct 02, 2010 6:58 pm    Post subject: Reply with quote

ok.
qui a 64bit un nspluginwrapper -i /opt/netscape/plugins/nppdf.so risolve per firefox e webkit.
chromium rimane al palo.

in seguito cercherò di capire il fenomeno webkit a 32, che sinceramente non mi torna.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Oct 02, 2010 7:08 pm    Post subject: Reply with quote

Su chromium il plugin di adobe reader non funziona, bisogna installare questa estensione https://chrome.google.com/extensions/detail/nnbmlagghjjcbdhgmkedmbmedengocbn
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Oct 02, 2010 7:24 pm    Post subject: Reply with quote

riverdragon wrote:
bisogna installare questa estensione:


grazie.
certo che quel warning in fase di installazione è increbibile:
installer del lettore pdf di google wrote:

questa estensione può accedere a: i tuoi dati su tutti i sisti web

:lol: :lol: :lol:

che m*****a sono i miei dati su tutti i siti web?
o che lo sono o che lo fanno...
:roll:

p.s.:
comunque non funziona: quell'estensione è una sorta di redirect che si appoggia sul lettore di pdf di google.
non è uno strumento che include i contenti del tag <object>.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Oct 03, 2010 9:44 am    Post subject: Reply with quote

cloc3 wrote:
comunque non funziona: quell'estensione è una sorta di redirect che si appoggia sul lettore di pdf di google.
non è uno strumento che include i contenti del tag <object>.
Non è che non funziona, è che funziona così! Se vuoi vedere i pdf in chromium senza doverli scaricare, è l'unico sistema.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Oct 12, 2010 11:38 am    Post subject: Reply with quote

Durante un aggiornamento stavo leggendo questo messaggio:
Code:
 * Messages for package app-text/acroread-9.4.0:

 * If you're running a 64bit browser you may also want to install
 * "www-plugins/nspluginwrapper" to be able to use the Adobe Reader
 * browser plugin.

Non specifica nulla riguardo un browser in particolare, quindi suppongo che debba funzionare con qualsiasi browser.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Tue Oct 12, 2010 5:55 pm    Post subject: Reply with quote

Io uso mozplugger ed apro direttamente Okular dentro a Firefox per leggere i pdf...E' enormemente più veloce ad aprirsi di acroread. E poi lo puoi configurare come vuoi, ad esempio apro i .doc e .xls con openoffice (che appare sempre dentro la finestra del browser)
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Oct 12, 2010 5:57 pm    Post subject: Reply with quote

Fico!!
mozplug: Configurable browser plugin to launch streaming media players.
Ma quindi è anche un plugin per vedere i filmati...?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Tue Oct 12, 2010 6:28 pm    Post subject: Reply with quote

Per quello non l'ho mai provato, ma suppongo di sì...
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Oct 12, 2010 8:10 pm    Post subject: Reply with quote

canduc17 wrote:
Io uso mozplugger

Fico!

ho eseguito l' emerge -C della mia vita!
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
canduc17
l33t
l33t


Joined: 11 Oct 2005
Posts: 795
Location: Ferrara, Italy

PostPosted: Tue Oct 12, 2010 8:17 pm    Post subject: Reply with quote

cloc3 wrote:
canduc17 wrote:
Io uso mozplugger

Fico!

ho eseguito l' emerge -C della mia vita!


Lo so, anche a me ha dato parecchia soddisfazione :D
Felice di essere stato d'aiuto!
_________________
A cow enters a supermarket, does an handstand and dies. (Public toilet graffito)
Back to top
View user's profile Send private message
johnnystuff
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2003
Posts: 141

PostPosted: Wed Oct 13, 2010 4:35 pm    Post subject: Reply with quote

scusate il leggero OT e la nabbaggine, ma mozplugger gestisce tutti i plugin (tipo anche flash?) o solo alcuni o magari bisogna configurarlo per quelli che gli si vuole far gestire? Me lo chiedevo per sapere se posso unmergere anche nspluginwrapper oltre ad acroread o sono 2 cose diverse (nspluginwrapper e mozplugger)?
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Oct 13, 2010 4:52 pm    Post subject: Reply with quote

mi pare che il file /etc/mozpluggerrc ne configuri il comportamento di default.

poi, si tratta di provare per capire fino a che punto ci si possa spingere con gli esperimenti.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Jan 03, 2012 2:46 pm    Post subject: Reply with quote

riverdragon wrote:
Su chromium il plugin di adobe reader non funziona, bisogna installare questa estensione https://chrome.google.com/extensions/detail/nnbmlagghjjcbdhgmkedmbmedengocbn

A quanto pare il plugin ancora non funziona, però quello che hai segnalato non apre acrobat nel browser.
Per ora sto usando KParts, che però obbliga l'uso di Okular, che non mi sta particolarmente simpatico.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum