Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Screenruler will no longer run[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 698

PostPosted: Fri Sep 17, 2010 1:42 am    Post subject: Screenruler will no longer run[SOLVED] Reply with quote

Hi All:

From the graaff overlay:

jerinkturion jserink # emerge -pv screenruler

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] gnome-extra/screenruler-0.89.1 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
[0] /usr/portage
[1] /var/lib/layman/graaff


Awesome tool to get dimensions of pdf spec sheets....it won't run any more. Re-emerged, still won't run.
Form a bash console as me:

jserink@jerinkturion ~ $ screenruler
Loading libraries...
Connecting to GConf...
Creating windows...
./utils/glade_window.rb: line 32
Gtk-WARNING **:GtkSpinButton: setting an adjustment with non-zero page size is deprecated
./utils/glade_window.rb: line 32
Gtk-WARNING **:GtkSpinButton: setting an adjustment with non-zero page size is deprecated
Reading settings...
Presenting ruler...
./utils/canvas.rb:40:in `initialize': undefined method `create_cairo_context' for #<Gdk::Pixmap:0x7f514a162158 ptr=0xbd4c10>
from /usr/bin/screenruler:74:in `call'
from /usr/bin/screenruler:74:in `main'
from /usr/bin/screenruler:74
Shutting down...


ANy hints on how to make this go?

Cheers,
John


Last edited by jserink on Tue May 03, 2011 3:20 am; edited 1 time in total
Back to top
View user's profile Send private message
christofdeluca
n00b
n00b


Joined: 19 Mar 2005
Posts: 34

PostPosted: Thu Feb 24, 2011 11:06 pm    Post subject: Reply with quote

Bump. Same problem.
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 698

PostPosted: Mon Mar 07, 2011 8:55 am    Post subject: Reply with quote

According to this:
http://sourceforge.net/tracker/?func=detail&atid=470969&aid=3178228&group_id=53614

its a ruby-gnome2 problem that has just been fixed. unfortunately, what we have in portage is this:
jerinkturion jserink # ls -l /usr/portage/dev-ruby/ruby-gnome2
total 20
-rw-r--r-- 1 root root 6674 Oct 22 21:44 ChangeLog
-rw-r--r-- 1 root root 1065 Oct 22 21:44 Manifest
-rw-r--r-- 1 portage portage 157 Aug 6 2003 metadata.xml
-rw-r--r-- 1 root root 651 Oct 21 05:53 ruby-gnome2-0.19.4.ebuild

at http://sourceforge.net/projects/ruby-gnome2/files/ruby-gnome2/ there is:

Home / ruby-gnome2
Name Modified Size Status
Parent folder
ruby-gnome2-0.90.8 2011-03-04
ruby-gnome2-0.90.7 2011-02-02
ruby-gnome2-0.90.6 2011-01-30
ruby-gnome2-0.90.5 2010-10-28
ruby-gnome2-0.90.4 2010-10-24
ruby-gnome2-0.90.3 2010-10-23
ruby-gnome2-0.90.2 2010-09-26
ruby-gnome2-0.90.1 2010-09-23
ruby-gnome2-0.90.0 2010-09-23
ruby-gnome2-0.19.4 2010-04-17

We're 9 versions behind. The bug was fixed in Fen so the latest trunk should have it.

Is there an over-lay with ruby-gnome2 on it?

Cheers,
john
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 698

PostPosted: Sun Apr 03, 2011 2:31 pm    Post subject: Reply with quote

ok, tried this:

Downloaded ruby-gnome2 all from here:
http://sourceforge.net/projects/ruby-gnome2/files/ruby-gnome2/ruby-gnome2-0.90.8/

and manully built and installed it.
Re emerged screenruler and same problem.

Darn, I miss this app.
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 455

PostPosted: Tue Apr 05, 2011 8:10 am    Post subject: Reply with quote

me too :(
Back to top
View user's profile Send private message
dberkholz
Developer
Developer


Joined: 18 Mar 2003
Posts: 1008
Location: Minneapolis, MN, USA

PostPosted: Wed Apr 13, 2011 2:36 am    Post subject: Reply with quote

I like it too. Guessing it may need porting to a newer ruby-gnome2.
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 698

PostPosted: Tue May 03, 2011 3:23 am    Post subject: Fixed! Reply with quote

Hi All;

Did and emerge -uDp world today and a new rcairo got brought in.
Screenruler still didn't run, same error.
Followed the instructions here:
https://aur.archlinux.org/packages.php?ID=34823

1. Re-remerged rcairo just to be sure,
2. re-emerged ruby-gtk2,
3. re-emerged ruby-pango,
4. re-emerged screenruler.....and it works!

YYYEEESSSS!!!!!!

Cheers,
john
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 455

PostPosted: Wed May 04, 2011 1:37 pm    Post subject: Reply with quote

Indeed, it works again. Thanks!
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 698

PostPosted: Mon Mar 17, 2014 3:57 am    Post subject: Reply with quote

Ok guys....., here we go again.

Ruby 1.8 is being removed from portage so screenruler 89.1 will get binned with it.

There is a new release of screen ruler 0.960 that runs under ruby 1.9 but I can't find an ebuild for it.


Anyone have any idea on that?

Cheers,
John
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 698

PostPosted: Mon Mar 17, 2014 4:59 am    Post subject: Reply with quote

Source is here:
https://launchpad.net/screenruler
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 698

PostPosted: Mon Mar 17, 2014 7:45 am    Post subject: Reply with quote

Hi All:

Ok, so I downloaded the source and expanded it out and ran screenruler.rb, got an error about not finding gettext so emerged ruby-gettext.
That error is now gone but got a bunch of other ones....
jserink@jserinki7 ~/Downloads/screenruler-0.960+bzr41 $ ruby screenruler.rb
Loading libraries...
/usr/lib64/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:45:in `require': cannot load such file -- ruler_window (LoadError)
from /usr/lib64/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_require.rb:45:in `require'
from /home/jserink/Downloads/screenruler-0.960+bzr41/utils/addons_ruby.rb:59:in `block in require'
from /home/jserink/Downloads/screenruler-0.960+bzr41/utils/addons_ruby.rb:59:in `each'
from /home/jserink/Downloads/screenruler-0.960+bzr41/utils/addons_ruby.rb:59:in `require'
from screenruler.rb:51:in `<main>'

ruler_window.rb is in the source directory so not sure how to deal with this one.
addons_ruby.rb has this:
module Kernel
# a new 'require' supporting multiple files
alias_method :orig_require, :require
def require(*list)
list.each { |file| orig_require(file) }
end

def loop(from, to, step=1)
i = from
while i <= to
yield i
i += step
end
end
end

Which is likely the problem but I'm no ruby expert.
Comments?

Cheers,
John
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 698

PostPosted: Sun Apr 06, 2014 2:42 pm    Post subject: Fixed using RPM Reply with quote

Hi All:

i followed the discussion here:
https://bugzilla.redhat.com/show_bug.cgi?id=831501

On getting screenruler to work using ruby 19. went here to get the rpm:
http://rpmfind.net/linux/rpm2html/search.php?query=screenruler

Got the x86_64 one.
Installed it:
jserinki7 screenruler # rpm -ivh --nodeps screenruler-0.96-2.fc20.noarch.rpm
warning: screenruler-0.96-2.fc20.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 246110c1: NOKEY
Preparing... ################################# [100%]
Updating / installing...
1:screenruler-0.96-2.fc20 ################################# [100%]


And there it is under accessories and it runs perfectly!

Yippie!

Cheers,
john
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum