Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]fsck.ext3 no such file or directory while trying to
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Mon Sep 06, 2010 4:35 pm    Post subject: [RISOLTO]fsck.ext3 no such file or directory while trying to Reply with quote

salve a tutti, ho un problema con il mio mac mini con architettura ppc, dopo un aggiornamento di world ha smesso di avviarsi, ora muore al punto:

Code:
checking root filesystem...
ext2fs_check_if_mount: Can't check if filesystem is mounted due to missing mtab file while determining whether /dev/hda4 is mounted.
fsck.ext3: No such file or directory while trying to open /dev/hda4
/dev/hda4:
The superblock could not be read or does not descrive a correct ext2 filesystem.
[...]
filesystem couldn't be fixed
give root password for maintenance
(or type control-D to continue):


inserendo la password e andando a controllare in /dev/ effettivamente manca un po' di roba
ho provato a fare tabula rasa e reinstallare tutto il sistema da capo, ma il problema si ripresenta uguale, nel kernel (2.6.35-r4 mi pare) per sicurezza ho incluso tutti i supporti possibili per i driver ata e sata, ma non è cambiato nulla. ho provato anche a installare la versione in testing di udev, ma il risultato non cambia.

qualcuno conosce la causa del problema e la possibile soluzione? grazie in anticipo per l'aiuto ;)


Last edited by k01 on Thu Sep 09, 2010 7:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Mon Sep 06, 2010 5:01 pm    Post subject: Re: fsck.ext3 no such file or directory while trying to open Reply with quote

The Extremer wrote:
ho provato a fare tabula rasa e reinstallare tutto il sistema da capo, ma il problema si ripresenta uguale, nel kernel (2.6.35-r4 mi pare) per sicurezza ho incluso tutti i supporti possibili per i driver ata e sata, ma non è cambiato nulla. ho provato anche a installare la versione in testing di udev, ma il risultato non cambia.

qualcuno conosce la causa del problema e la possibile soluzione? grazie in anticipo per l'aiuto ;)

Non so aiutarti ma il .35 non mi ispira molta fiducia:

Kernels 2.6.35+ very slow on an i7.
2.6.35 hangs badly
2.6.35 problems with ethernet + grub
2.6.35 is not ready for prime time
2.6.35: why does kernel try to mount ext4 as ext2 first?
_________________
proud user of faKeDE-4.7.3


Last edited by xdarma on Mon Sep 06, 2010 7:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon Sep 06, 2010 7:40 pm    Post subject: Re: fsck.ext3 no such file or directory while trying to open Reply with quote

The Extremer wrote:
inserendo la password e andando a controllare in /dev/ effettivamente manca un po' di roba
ho provato a fare tabula rasa e reinstallare tutto il sistema da capo, ma il problema si ripresenta uguale, nel kernel (2.6.35-r4 mi pare) ma il risultato non cambia.


xdarma wrote:
Non so aiutarti ma il .35 non mi ispira molta fiducia



Hai provato con un'altro kernel?Nell'upgrade di cui parlavi hai aggiornato appunto quello?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Mon Sep 06, 2010 10:30 pm    Post subject: Reply with quote

allora ho sbagliato, ricordavo male, forse il kernel .35 è sull'i686. qui ho i gentoo-sources 2.6.34-r1 e udev 161

durante l'aggiornamento di world non ricordo se includesse anche i sorgenti del kernel, ma comunque sicuramente non ne ho ricompilato un altro, quindi quello era rimasto uguale. comunque proverò anche con un kernel più vecchio prendendolo da www.kernel.org
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Tue Sep 07, 2010 7:54 am    Post subject: Reply with quote

The Extremer wrote:
allora ho sbagliato, ricordavo male, forse il kernel .35 è sull'i686. qui ho i gentoo-sources 2.6.34-r1 e udev 161

durante l'aggiornamento di world non ricordo se includesse anche i sorgenti del kernel, ma comunque sicuramente non ne ho ricompilato un altro, quindi quello era rimasto uguale. comunque proverò anche con un kernel più vecchio prendendolo da www.kernel.org


emerge vanilla-sources è la stessa cosa :P
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Tue Sep 07, 2010 9:37 am    Post subject: Reply with quote

già è vero, ma non pensavo di trovare kernel così vecchi, pensavo si fermassero ad un paio di versioni fa, prima di formattare mi pare avessi il 2.6.31
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Tue Sep 07, 2010 7:32 pm    Post subject: Reply with quote

dato che hai detto che la causa del tuo mal è stato un aggiornamento, se non avessi formattato, un
Code:
qlop -l
ci avrebbe dato una mano ;)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Tue Sep 07, 2010 8:25 pm    Post subject: Reply with quote

The Extremer wrote:
non ricordo se includesse anche i sorgenti del kernel, ma comunque sicuramente non ne ho ricompilato un altro, quindi quello era rimasto uguale

Può essere utile questo post?
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Thu Sep 09, 2010 7:52 pm    Post subject: Reply with quote

xdarma wrote:
The Extremer wrote:
non ricordo se includesse anche i sorgenti del kernel, ma comunque sicuramente non ne ho ricompilato un altro, quindi quello era rimasto uguale

Può essere utile questo post?


perfetto, era proprio quello il problema, ora è risolto, grazie ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum