Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Lighttpd] Erreur 404
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sat Sep 04, 2010 6:02 pm    Post subject: [Lighttpd] Erreur 404 Reply with quote

Bonjour,

J'ai installé il y a quelques temps Lighttpd en remplacement de Apache. j'ai suivi le wiki Gentoo pour l'installation et la configuration.

Tout fonctionnait très bien auparavant. Mais aujourd'hui, l'adresse http://localhost/ me donne une erreur 404.

Lighttpd est démarré. J'ai essayé de le redémarrer et même de le recompiler, sans succès.

Le log d'accès de Lighttpd n'indique aucune erreur :
Code:
127.0.0.1 localhost - [04/Sep/2010:19:41:27 +0200] "GET /~jerome/wwwsqldesigner/ HTTP/1.1" 404 345 "-" "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.8) Gecko/20100807 Gentoo Firefox/3.6.8"
127.0.0.1 localhost - [04/Sep/2010:19:41:28 +0200] "GET /favicon.ico HTTP/1.1" 404 345 "-" "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.8) Gecko/20100807 Gentoo Firefox/3.6.8"
127.0.0.1 localhost - [04/Sep/2010:19:41:30 +0200] "GET /favicon.ico HTTP/1.1" 404 345 "-" "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.8) Gecko/20100807 Gentoo Firefox/3.6.8"


Le log d'erreur de Lighttpd ne donne rien d'intéressant non plus.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Sat Sep 04, 2010 6:16 pm    Post subject: Reply with quote

Dans ton lighttpd.conf, peut-être que c'est ça qui a besoin d'être activé :
Code:
dir-listing.activate      = "enable"


Au lieu du 404, tu auras le contenu de tes répertoires.
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sat Sep 04, 2010 8:53 pm    Post subject: Reply with quote

Cr0k wrote:
Dans ton lighttpd.conf, peut-être que c'est ça qui a besoin d'être activé :
Code:
dir-listing.activate      = "enable"


Au lieu du 404, tu auras le contenu de tes répertoires.

Aucun changement.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sun Sep 19, 2010 10:01 pm    Post subject: Reply with quote

Bonjour,

Ca ne fonctionne toujours pas. J'ai complètement réinstallé Lighttpd. Au premier démarrage il a fonctionné correctement.

Je l'ai ajouté au niveau d'exécution « default » avec :
Code:
rc-update add lighttpd default


Mais après redémarrage de mon poste, il ne fonctionne pas. Pire : si j'essaie de le lancer ou le relancer, j'obtiens :

Code:
tux jerome # /etc/init.d/lighttpd start
 * Starting eth0
 *   Bringing up eth0
 *     dhcp
 *       Running dhcpcd ...
eth0: dhcpcd already running on pid 8835 (/var/run/dhcpcd-eth0.pid)           [ !! ]
 * Starting eth0
 *   Bringing up eth0
 *     dhcp
 *       Running dhcpcd ...
eth0: dhcpcd already running on pid 8835 (/var/run/dhcpcd-eth0.pid)           [ !! ]
 * ERROR:  cannot start netmount as net.eth0 could not start
 * ERROR:  cannot start lighttpd as net.eth0 could not start

_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum