Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Wifi dont work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ILoveUNIX
n00b
n00b


Joined: 10 Dec 2009
Posts: 7

PostPosted: Thu Aug 26, 2010 1:14 pm    Post subject: [SOLVED] Wifi dont work Reply with quote

I have problem with wifi - dont work...

ThinkPad R400
Wifi: Intel 5100

uname -a
Code:

Linux Gentoo 2.6.34-zen1-libre #5 ZEN SMP PREEMPT Wed Aug 25 12:27:49 CEST 2010 x86_64 Intel(R) Core(TM)2 Duo CPU T6670 @ 2.20GHz GenuineIntel GNU/Linux


ifconfig -a
Code:

eth0      Link encap:Ethernet  HWaddr 00:27:13:b5:23:22 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:fc000000-fc020000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


wlan0 missing.

lsmod
Code:

Module                  Size  Used by
nls_utf8                1224  1
nls_cp437               5833  1
joydev                 10317  0
uvcvideo               58495  0
videodev               37307  1 uvcvideo
v4l1_compat            15578  2 uvcvideo,videodev
v4l2_compat_ioctl32    10161  1 videodev
psmouse                53374  0
iTCO_wdt               10533  0
tpm_tis                 8093  0
iwlagn                120168  0
thinkpad_acpi          52186  0
sdhci_pci               6659  0
e1000e                127962  0
iTCO_vendor_support     1809  1 iTCO_wdt
tpm                    11005  1 tpm_tis
wmi                     5989  0
pcspkr                  1763  0
serio_raw               4344  0
sdhci                  15937  1 sdhci_pci
iwlcore               103123  1 iwlagn
nvram                   5493  1 thinkpad_acpi
tpm_bios                5417  1 tpm
i2c_i801                8390  0
mmc_core               53507  1 sdhci
yenta_socket           21283  0
rsrc_nonstatic          8659  1 yenta_socket
evdev                   8825  7


* mac80211 and cfg80211 is compiled into kernel

dmesg
Code:

iwlagn: Copyright(c) 2003-2010 Intel Corporation
iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwlagn 0000:03:00.0: setting latency timer to 64
iwlagn 0000:03:00.0: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
iwlagn 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
iwlagn 0000:03:00.0: irq 31 for MSI/MSI-X
0000:03:00.0: Missing Free firmware
iwlagn 0000:03:00.0: firmware: requesting /*(DEBLOBBED)*/
iwlagn 0000:03:00.0: PCI INT A disabled
iwlagn: probe of 0000:03:00.0 failed with error -22


firmware: requesting /*(DEBLOBBED)*/ - how i do it?

----------------------------------------------------------------------
Solution:
No use flag "deblob" with zen-sources package.
----------------------------------------------------------------------


Last edited by ILoveUNIX on Thu Aug 26, 2010 6:25 pm; edited 2 times in total
Back to top
View user's profile Send private message
idella4
Retired Dev
Retired Dev


Joined: 09 Jun 2006
Posts: 1600
Location: Australia, Perth

PostPosted: Thu Aug 26, 2010 1:17 pm    Post subject: Reply with quote

here
Code:

0000:03:00.0: Missing Free firmware

is the problem. Seems you need to acquire the needed firmware.
_________________
idella4@aus
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum