Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome minus Metacity and other update headaches
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 11 Sep 2003
Posts: 109

PostPosted: Sun Sep 14, 2003 8:51 pm    Post subject: Gnome minus Metacity and other update headaches Reply with quote

I'm having some problems updating my system. I've only had a gentoo install for the last few days, so it's arguable that I don't really need to update yet, but I ran "emerge -UDp world" to see what it would say, and it hit the following problem:

Calculating world dependencies -
!!! all ebuilds that could satisfy "~media-video/nvidia-kernel-1.0.4496" have been masked.
!!! (dependency required by "media-video/nvidia-glx-1.0.4496" [ebuild])

!!! Problem with ebuild net-www/mplayerplug-in-0.80
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.

I'm using a 2.6 kernel, so I need the 4496 versions of these drivers, plus I merged that version specifically because they're the latest version available. I don't want to unmask other unstable packages, I'm happy with the versions I have of other software.

When I run "emerge -uDp world" (update as opposed to upgradeonly) I get the following output:
[ebuild N ] sys-apps/coreutils-5.0-r3
[ebuild U ] sys-apps/debianutils-1.16.7-r3 [1.16.7-r2]
[ebuild N ] sys-kernel/linux-headers-2.4.19-r1
[ebuild U ] sys-apps/baselayout- []
[ebuild U ] media-video/nvidia-kernel-1.0.4363-r3 [1.0.4496-r3]
[ebuild UD] media-video/nvidia-glx-1.0.4363 [1.0.4496]
[ebuild N ] gnome-base/ORBit-0.5.17
[ebuild N ] gnome-base/gnome-libs-1.4.2
[ebuild N ] media-libs/gdk-pixbuf-0.21.0
[ebuild N ] dev-libs/libxml-1.8.17-r2
[ebuild U ] gnome-base/libglade-0.17-r6 [2.0.1]
[ebuild N ] net-www/lynx-
[ebuild N ] gnome-base/gnome-common-1.2.4-r3
[ebuild N ] gnome-base/oaf-0.6.10
[ebuild U ] gnome-base/gconf-1.0.8-r5 [2.2.1]
[ebuild U ] gnome-base/gnome-vfs-1.0.5-r3 [2.2.5]
[ebuild U ] gnome-base/control-center- [2.2.2]
[ebuild U ] gnome-base/gnome-panel-1.4.2-r2 []
[ebuild N ] x11-wm/metacity-2.4.55

Why are there so many GNOME packages going to be newly installed? They clearly weren't dependencies when merging GNOME itself, or anything I've so far merged since.
Also, why does it want to install 1.4 verions of gconf, vfs, control-center and panel? It even acknowledges that I've already got 2.2 versions of these installed.
Finally, is there any way to stop it wanting to reinstall metacity? I unmerged metacity after I installed sawfish, but for whatever reason - presumably because it's a gnome dependency, and gnome's installed - it wants to re-emerge it upon updating. And there's no "-metacity" USE flag - if there was, it would be INCREDIBLY useful... GNOME and Gentoo assume I want Metacity, and I don't.

Please tell me upgrading isn't set to always be this much of a pain... I suppose I could look at the list of packages it wants to upgrade and just manually re-emerge the upgrades I actually want, but as I install more software on my system, this will become more and more of a pain.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum