Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi con lettere accentate e segni in gnome-terminal/tty
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mz9999
n00b
n00b


Joined: 18 Aug 2010
Posts: 10

PostPosted: Sun Aug 22, 2010 9:17 pm    Post subject: Problemi con lettere accentate e segni in gnome-terminal/tty Reply with quote

Ho notato che sullo gnome-terminal e sulle tty al posto delle lettere accentate e di alcuni segni come ' (solamente negli output e non quando scrivo io) vengono riportati dei punti interrogativi così --> �
Ho letto una marea di post sul forum e guide varie in rete per la localizzazione di gentoo ma purtroppo non riesco a venire a capo di questa situazione.
Per darvi maggiori info posto i miei vari files dove sono presenti delle localizzazioni o codifiche:
/etc/conf.d/consolefont
Code:
# consolefont specifies the default font that you'd like Linux to use on the
# console.  You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
# not want to use it, run "rc-update del consolefont" as root).
consolefont="default8x16"

# consoletranslation is the charset map file to use.  Leave commented to use
# the default one.  Have a look in /usr/share/consoletrans for a selection of
# map files you can use.
consoletranslation="8859-15_to_uni"

# unicodemap is the unicode map file to use. Leave commented to use the
# default one. Have a look in /usr/share/unimaps for a selection of map files
# you can use.
unicodemap="8859-15.a0-ff"


/etc/conf.d/keymaps
Code:
# /etc/conf.d/keymaps

# Use KEYMAP to specify the default console keymap.  There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.

KEYMAP="it"


# Should we first load the 'windowkeys' console keymap?  Most x86 users will
# say "yes" here.  Note that non-x86 users should leave it as "no".

SET_WINDOWKEYS="no"


# The maps to load for extended keyboards.  Most users will leave this as is.

EXTENDED_KEYMAPS=""
#EXTENDED_KEYMAPS="backspace keypad euro"


# Tell dumpkeys(1) to interpret character action codes to be
# from the specified character set.
# This only matters if you set UNICODE="yes" in /etc/rc.conf.
# For a list of valid sets, run `dumpkeys --help`

DUMPKEYS_CHARSET="iso-8859-15"


/etc/env.d/02locale
Code:
LANG="it_IT.UTF-8"
LC_COLLOCATE="C"


rc.conf
Code:
# /etc/rc.conf: Global startup script configuration settings

# UNICODE specifies whether you want to have UNICODE support in the console. 
# If you set to yes, please make sure to set a UNICODE aware CONSOLEFONT and
# KEYMAP in the /etc/conf.d/consolefont and /etc/conf.d/keymaps config files.

UNICODE="yes"

# Set EDITOR to your preferred editor.
# You may use something other than what is listed here.

EDITOR="/bin/nano"
#EDITOR="/usr/bin/vim"
#EDITOR="/usr/bin/emacs"

# DISPLAYMANAGER has moved to /etc/conf.d/xdm

# XSESSION is a new variable to control what window manager to start
# default with X if run with xdm, startx or xinit.  The default behavior
# is to look in /etc/X11/Sessions/ and run the script in matching the
# value that XSESSION is set to.  The support scripts are smart enough to
# look in all bin directories if it cant find a match in /etc/X11/Sessions/,
# so setting it to "enlightenment" can also work.  This is basically used
# as a way for the system admin to configure a default system wide WM,
# allthough it will work if the user export XSESSION in his .bash_profile, etc.
#
# NOTE:  1) this behaviour is overridden when a ~/.xinitrc exists, and startx
#           is called.
#        2) even if ~/.xsession exists, if XSESSION can be resolved, it will
#           be executed rather than ~/.xsession, else KDM breaks ...
#
# Defaults depending on what you install currently include:
#
# Gnome - will start gnome-session
# kde-<version> - will start startkde (look in /etc/X11/Sessions/)
# Xfce4 - will start a XFCE4 session
# Xsession - will start a terminal and a few other nice apps

#XSESSION="Gnome"

rc_hotplug="!net*"


/etc/locale.gen
Code:
en_US ISO-8859-1
en_US.UTF-8
it_IT.UTF-8 UTF-8 
it_IT ISO-8859-1 
it_IT@euro ISO-8859-15


in make.conf ho impostato tra le use flags "nls unicode" e LINGUAS="it".
Secondo voi dove sbaglio?
grazie anticipatamente.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sun Aug 22, 2010 10:57 pm    Post subject: Reply with quote

ti manca qualche font? (di quelli essenziali)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
mz9999
n00b
n00b


Joined: 18 Aug 2010
Posts: 10

PostPosted: Mon Aug 23, 2010 12:05 am    Post subject: Reply with quote

Guarda, propio prima ho provato ad aggiungere truetype alle use flags e mi ha fatto ricompilare dei pacchetti e installare corefonts, di mio ho provato anche ad installare terminus-font e "sembra" (non voglio parlare troppo presto) che impostando quest'ultimo font in gnome-terminal riesco a vedere ' e ` mentre continuo a non visualizzare "è" negli output.
Come fonts essenziali (se per essenziali intendi quelli segnalati qui http://en.gentoo-wiki.com/wiki/X.Org/Fonts nella sezione Emerging "Essential" Packages > Essential high quality fonts ) in questo momento quindi ho corefonts , dejavu al posto di bitstream-vera e terminus-font mentre non ho font-bh-type1 ne font-bh-ttf (pensi siano quelli?).
Back to top
View user's profile Send private message
mz9999
n00b
n00b


Joined: 18 Aug 2010
Posts: 10

PostPosted: Mon Aug 23, 2010 1:18 pm    Post subject: Reply with quote

Ho provato ad installare font-bh-type1,font-bh-ttf e bitstream-vera ma continuo a non vedere "è".
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon Aug 23, 2010 2:47 pm    Post subject: Reply with quote

se può servire ti posto quelli che ho attualmente:
Code:
[I] media-fonts/corefonts
[I] media-fonts/encodings
[I] media-fonts/font-alias
[I] media-fonts/font-misc-misc
[I] media-fonts/font-util
[I] media-fonts/gnu-gs-fonts-std
[I] media-fonts/terminus-font

_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
mz9999
n00b
n00b


Joined: 18 Aug 2010
Posts: 10

PostPosted: Mon Aug 23, 2010 3:41 pm    Post subject: Reply with quote

Ho tutti quei fonts installati.
Non è che devo ricompilare qualcosa forse?
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon Aug 23, 2010 4:29 pm    Post subject: Reply with quote

eselect fontconfig list e locale cosa dicono?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
mz9999
n00b
n00b


Joined: 18 Aug 2010
Posts: 10

PostPosted: Mon Aug 23, 2010 5:52 pm    Post subject: Reply with quote

eselect fontconfig list
Code:
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-dejavu-sans.conf
  [10]  20-unhint-small-dejavu-sans-mono.conf
  [11]  20-unhint-small-dejavu-serif.conf
  [12]  20-unhint-small-vera.conf *
  [13]  25-unhint-nonlatin.conf
  [14]  30-metric-aliases.conf *
  [15]  30-urw-aliases.conf *
  [16]  40-nonlatin.conf *
  [17]  45-latin.conf *
  [18]  49-sansserif.conf *
  [19]  50-user.conf *
  [20]  51-local.conf *
  [21]  57-dejavu-sans.conf
  [22]  57-dejavu-sans-mono.conf
  [23]  57-dejavu-serif.conf
  [24]  60-latin.conf *
  [25]  65-fonts-persian.conf *
  [26]  65-khmer.conf
  [27]  65-nonlatin.conf *
  [28]  69-unifont.conf *
  [29]  70-no-bitmaps.conf
  [30]  70-yes-bitmaps.conf
  [31]  80-delicious.conf *
  [32]  90-synthetic.conf *


locale
Code:
LANG=it_IT.UTF-8
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Mon Aug 23, 2010 7:35 pm    Post subject: Reply with quote

controlla la variabile d'ambiente
GCONV_PATH

dovrebbe essere in /usr/lib/gconv/ (o lib64 se hai un 64bit) (guarda dentro /etc/env.d/)

prova quindi a lanciare lo gnome terminal così:
Code:

GCONV_PATH=/usr/lib/gconv/ gnome-terminal


poi, beh, aggiusta tu il comando con il path corretto e il nome del comando corretto.
in teoria non dovresti notare differenze, ma si sa mai. (nel caso, vuol dire che dentro /etc/env.d/ non è stata settata correttamente la variabile)

controlla anche di non aver librerie scazzate
Code:
revdep-rebuild -i -p

si sa mai...
_________________
Darkman
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 682
Location: tra veneto e friuli (italy)

PostPosted: Mon Aug 23, 2010 7:52 pm    Post subject: Re: Problemi con lettere accentate e segni in gnome-terminal Reply with quote

Curiosità: ma questa riga qui nel tuo /etc/conf.d/consolefont
Code:
unicodemap="8859-15.a0-ff"

da dove l'hai presa e/o a cosa dovrebbe servire?
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
mz9999
n00b
n00b


Joined: 18 Aug 2010
Posts: 10

PostPosted: Mon Aug 23, 2010 8:35 pm    Post subject: Reply with quote

darkmanPPT wrote:
controlla la variabile d'ambiente
GCONV_PATH

dovrebbe essere in /usr/lib/gconv/ (o lib64 se hai un 64bit) (guarda dentro /etc/env.d/)

prova quindi a lanciare lo gnome terminal così:
Code:

GCONV_PATH=/usr/lib/gconv/ gnome-terminal


poi, beh, aggiusta tu il comando con il path corretto e il nome del comando corretto.
in teoria non dovresti notare differenze, ma si sa mai. (nel caso, vuol dire che dentro /etc/env.d/ non è stata settata correttamente la variabile)

controlla anche di non aver librerie scazzate
Code:
revdep-rebuild -i -p

si sa mai...


Ho fatto con GCONV_PATH=/usr/lib/gconv/ gnome-terminal ma è tutto uguale.
Per revdep-rebuild dovrei installare gentoolkit vero? EDIT: installato gentoolkit, eseguito il comando e sembra tutto regolare, niente da ricompilare.

xdarma wrote:
Curiosità: ma questa riga qui nel tuo /etc/conf.d/consolefont
Codice:
unicodemap="8859-15.a0-ff"

da dove l'hai presa e/o a cosa dovrebbe servire?

era su /etc/conf.d/consolefont ma commentata (#), io ho cercato in /usr/share/unimaps un file che contenesse la mappatura unicode 8859-15.
Ho provato anche a ricommentare, sto provando tutte le combinazioni possibili ma non cambia nulla.
Back to top
View user's profile Send private message
mz9999
n00b
n00b


Joined: 18 Aug 2010
Posts: 10

PostPosted: Thu Aug 26, 2010 3:42 pm    Post subject: Reply with quote

Ragazzi ma giusto per curiosità, pongo una domanda a chi ha le mie stesse impostazioni, avete modo di testare se "è" è visibile su gnome-terminal e tty? parlo solamente di output restituito in quanto a scrivere "è" ci riesco.
mi sembra stranissimo... non trovo un solo errore nei miei files di configurazione e sto iniziando a pensare che non dipenda da me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum