Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Encoding problem when accessing samba share from windows
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
RaraRasputin
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2004
Posts: 142
Location: Germany

PostPosted: Fri Aug 20, 2010 11:09 am    Post subject: Encoding problem when accessing samba share from windows Reply with quote

Hi folks,

I have a problem concerning my samba shares. When I copy files from a windows xp station, the file names are in iso8859-1, though the filesystem (which is ext4) uses utf-8. So everytime I copied data from windows, I have to run convmv.

Additionally, all files I copy to the share have the executable bit set, regardless of the type of the file.

What can I do about this?

-Rasputin
_________________
RaraRasputin, lover of the Russian Queen
Back to top
View user's profile Send private message
msalerno
Veteran
Veteran


Joined: 17 Dec 2002
Posts: 1338
Location: Sweating in South Florida

PostPosted: Fri Aug 20, 2010 1:50 pm    Post subject: Reply with quote

http://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html

What do you have your "unix charset" set to in your smb.conf?

Which direction are you copying?
From windows to smb share?
From linux smb mount to windows share?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum