Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
resolving freetype and libXft dependencies
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1185
Location: Stuttgart, Germany

PostPosted: Tue Aug 03, 2010 2:37 pm    Post subject: resolving freetype and libXft dependencies Reply with quote

am I missing something with the dependencies for fontconfig? Here is the error I get:
Code:


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/freetype:2

  ('installed', '/', 'media-libs/freetype-2.4.1', 'nomerge') pulled in by
    =media-libs/freetype-2* required by ('installed', '/', 'x11-libs/libast-0.7', 'nomerge')
    media-libs/freetype required by @world
    >=media-libs/freetype-2.2.1 required by ('installed', '/', 'media-libs/fontconfig-2.8.0-r1', 'nomerge')
    (and 37 more)

  ('ebuild', '/', 'media-libs/freetype-2.3.11', 'merge') pulled in by
    >=media-libs/freetype-2.2.1[cleartype,-ubuntu] required by ('ebuild', '/', 'media-libs/fontconfig-2.8.0', 'merge')
    media-libs/freetype[cleartype,-ubuntu] required by ('installed', '/', 'x11-libs/libXft-2.1.14', 'nomerge')
    (and 40 more)
I don't see how those two dependencies conflict: one says >=2.2, and another says =2*. And yet they block each other. Can someone explain what's going wrong?

fontconfig and freetype are part of an overlay, either gentoo-quebec or devnull. Perhaps that's the problem?

Thanks,

EE
Back to top
View user's profile Send private message
xiber
Apprentice
Apprentice


Joined: 28 Oct 2003
Posts: 245
Location: Fremont, CA

PostPosted: Fri Aug 20, 2010 4:52 am    Post subject: Re: resolving freetype and libXft dependencies Reply with quote

ExecutorElassus wrote:
fontconfig and freetype are part of an overlay, either gentoo-quebec or devnull. Perhaps that's the problem?


Probably. devnull hasn't updated cairo or freetype ebuilds in a while.
_________________
Athlon XP-M 2600 @ 2.3 GHz OC | Abit NF7-S r2.0 | 2x512MB PC3200 | 6600GT OC | Audigy 2 | Gentoo | 2005

Athlon 64 X2 4600 @ 2.4 GHz | Asus M2N-SLI DLX | 4x1GB PC6400 | 7600GT KO | 7HD @ 3.1TB | OpenSolaris SXCE | 2007
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum