Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NM and/or wicd not working on fluxbox's eepc...
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 04 Jun 2010
Posts: 84

PostPosted: Thu Aug 19, 2010 11:46 am    Post subject: NM and/or wicd not working on fluxbox's eepc... Reply with quote

Hi all
i previously posted this problem in DE section, but that's a networking problem so i re-post here

i installed gentoo on a eeepc 900p (1 GB ram, 900 mhz cpu, 4+16 GB SSD)
now it work fine and with /etc/conf.d/net scripts it does connect to my home wireless and to work wired wpa net

usually i don't use network managers 'cause i found better using an "old time" init script
but sometime i need a graphycal / "easy and quick" to use network manager to scan and connect to pubblic wireless or some of my friends' home wifi etc.

and then, on my big notebook with gnome, i use NM

so i decided to emerge NM on my eeepc with fluxbox too.
i emerged both NM and nm-applet with all dependecies

then when i try starting nm i read:

$ sudo /etc/init.d/NetworkManager start
   * Starting NetworkManager ...                                            [ !! ]
$ nm-applet

** (nm-applet:5408): WARNING **: <WARN>  request_name(): Could not acquire the NetworkManagerUserSettings service.
Error: (9) Connection ":1.8" is not allowed to own the service "org.freedesktop.NetworkManagerUserSettings" due to security policies in the configuration file

so i check nm status and i see

$ sudo /etc/init.d/NetworkManager status
   * status:  stopped

everytime i do "start" it keep saying me "starting" with double "!" then status says "stopped".

then i tried also wicd
when i start it says me:

Importing pynotify failed, notifications disabled.
Has notifications support False
Notifications disabled during configure
Connecting to daemon...
displaytray True
Done loading.
/usr/share/wicd/gtk/ GtkWarning: gtk_toolbar_set_icon_size: assertion `icon_size != GTK_ICON_SIZE_INVALID' failed
  self.wTree =
now i go scan for wireless and says me "no wireless network found"
and this is not possible 'cause wireless _is_ present (i'm connected with other PC) and still, if i do /etc/init.d/net.wlan0 restart it connect!
i also tried "manul discover of hidden network" (or something similar) but still, it found nothing :(

last, but not least, i tried to stop wireless network with
# /etc/init.d/net.wlan0 stop
# rfkill unblock all

(without rfkill wireless lan does'nt restart)

and again executed wicd or NM
same result...

where is the problem? i think there is something wrong i did someplace but i truly can't see where's the error :(

as always, ty for your help :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum