Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wicd & python 3.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
menschmeier
l33t
l33t


Joined: 15 Dec 2004
Posts: 727

PostPosted: Mon Aug 09, 2010 6:39 am    Post subject: wicd & python 3.1 Reply with quote

Yesterday I did an update of python. In the update process I was adviced to use python 3.1 in stead 2.6. So I did an eselect python set python3.1.

But now I can not use my WLAN anymore. I tried to find out the reason, wicd ist started within a python script. I got this error:
Code:
# /usr/sbin/wicd
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 122
    print "--no-autoconnect detected, not autoconnecting..."
                                                           ^
SyntaxError: invalid syntax


Here is the code snippet. I don't know python, but it doesn't look that bad. I do not understand why python 3.1 complains about the tailing ".
Code:
120         # Scan since we just got started
 121         if not auto_connect:
 122             print "--no-autoconnect detected, not autoconnecting..."
 123             self.SetForcedDisconnect(True)
 124         self.wireless_bus.Scan()


After switching back to python 2.6 wicd is starting again.
These are the packages I have installed:
Code:
# eix wicd
[I] net-misc/wicd
     Available versions:  1.7.0 {X +gtk ioctl libnotify ncurses nls +pm-utils}
     Installed versions:  1.7.0(10:36:50 PM 07/26/2010)(X gtk libnotify ncurses nls pm-utils -ioctl)
     Homepage:            http://wicd.sourceforge.net/
     Description:         A lightweight wired and wireless network manager for Linux

# eix dev-lang/python
[I] dev-lang/python
     Available versions: 
        (2.4)   2.4.6
        (2.5)   2.5.4-r4
        (2.6)   2.6.4-r1 2.6.5-r2 2.6.5-r3
        (2.7)   [M]~2.7
        (3.1)   3.1.2-r3 3.1.2-r4
        {-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml}                                                                           
     Installed versions:  2.6.5-r3(2.6)(06:51:30 PM 08/08/2010)(berkdb gdbm ipv6 ncurses readline ssl threads wide-unicode xml -build -doc -elibc_uclibc -examples -sqlite -tk -wininst) 3.1.2-r4(3.1)(06:59:31 PM 08/08/2010)(gdbm ipv6 ncurses readline ssl threads wide-unicode xml -build -doc -elibc_uclibc -examples -sqlite -tk -wininst)                                                                                                       
     Homepage:            http://www.python.org/
     Description:         Python is an interpreted, interactive, object-oriented programming language.


So what to to if I want to use python 3.1 per default and use wicd?
_________________
Please notice the back of this message.
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1969

PostPosted: Mon Aug 09, 2010 8:16 am    Post subject: Reply with quote

I don't think you can use Python >=3 as the default Python at the moment.
I think it breaks portage, apart from anything else. However, I've simply
masked it and not emerged it at all, so there might be someone with
better advice.

Will
Back to top
View user's profile Send private message
V-Li
Retired Dev
Retired Dev


Joined: 03 Jan 2006
Posts: 607

PostPosted: Mon Aug 09, 2010 11:03 am    Post subject: Re: wicd & python 3.1 Reply with quote

menschmeier wrote:
Yesterday I did an update of python. In the update process I was adviced to use python 3.1 in stead 2.6. So I did an eselect python set python3.1.


Where did you read that?
Back to top
View user's profile Send private message
menschmeier
l33t
l33t


Joined: 15 Dec 2004
Posts: 727

PostPosted: Mon Aug 09, 2010 12:26 pm    Post subject: Reply with quote

OK, I read the ebuild again. It was was a misapprehension. Sorry. It was recommended to stay with python2:

Code:
              ewarn "WARNING!"
                ewarn "Many Python modules have not been ported yet to Python 3.*."
                ewarn "Python 3 has not been activated and Python wrapper is still configured to use Python 2."
                ewarn "You can manually activate Python ${SLOT} using \`eselect python set python${SLOT}\`."
                ewarn "It is recommended to currently have Python wrapper configured to use Python 2."
                ewarn "Having Python wrapper configured to use Python 3 is unsupported."

_________________
Please notice the back of this message.
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 432

PostPosted: Mon Aug 09, 2010 4:38 pm    Post subject: Reply with quote

Why are we forced to install python3 anyway? I have masked version 3, but shouldn't this be the other way, one who wants to play with python3 can unmask it. I doubt that you can use it with any app beside testing your own...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum