Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ntfs3g-2010.3.6 doesn't allow apache to access a NTFS dir
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3809
Location: Hamburg

PostPosted: Wed Jul 28, 2010 6:09 pm    Post subject: ntfs3g-2010.3.6 doesn't allow apache to access a NTFS dir Reply with quote

I'm wondering why suddenly I'm no longer allowed to access a directory stored at a local NTFS drive my fotos using a local running apache - I know that it worked at least before 20zh of July and in the mean while I updated sys-fs/ntfs3g-2010, sys-libs/cracklib-2.8.16, sys-apps/coreutils-8.5, sys-libs/glibc-2.11.2 and others ....

Last edited by toralf on Thu Jul 29, 2010 8:37 am; edited 1 time in total
Back to top
View user's profile Send private message
xibo
Apprentice
Apprentice


Joined: 21 Aug 2007
Posts: 152
Location: moving between kubuntu and ubuntu kde edition

PostPosted: Wed Jul 28, 2010 6:45 pm    Post subject: Reply with quote

can you read the content of your ntfs mounts without being root?
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3809
Location: Hamburg

PostPosted: Wed Jul 28, 2010 8:41 pm    Post subject: Reply with quote

xibo wrote:
can you read the content of your ntfs mounts without being root?
yes - no problem, here's the fstab entry :
Code:
tfoerste@n22 ~ $ grep sda2 /etc/fstab
/dev/sda2       /mnt/E          ntfs-3g        auto,user,noatime,uid=tfoerste,gid=users,umask=0027,locale=de_DE.utf8,noexec
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3809
Location: Hamburg

PostPosted: Thu Jul 29, 2010 8:35 am    Post subject: Reply with quote

sys-fs/ntfs3g-2010.3.6 is the culprit - sys-fs/ntfs3g-2010.1.16 works fine - now I'm wondering whether the package sys-fs/ntfs3g-2010.1.16 _was_ buggy or whether sys-fs/ntfs3g-2010.3.6 _is_ buggy.
UpdateWell, I had to change the fstab entry from 0027 to 0022, b/c the default mount option now includes "default_permissions" as a parameter too./Update
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum