Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]Audio ATI Technologies Inc SBx00 Azalia (Intel HDA)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
neretux
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 83

PostPosted: Tue Jul 20, 2010 8:56 am    Post subject: [Risolto]Audio ATI Technologies Inc SBx00 Azalia (Intel HDA) Reply with quote

Quella in oggetto è la mia scheda audio ma l'audio non funziona.
Le impostazione del kernel sono queste:
Code:
<*> Sound card support  --->
 [*]   Preclaim OSS device numbers                                                                             
                                     <*>   Advanced Linux Sound Architecture  --->   
                                      <*>   Sequencer support                                                                                   
                                      <*>     Sequencer dummy client                                                                             
                                      <*>   OSS Mixer API                                                                                         
                                      <*>   OSS PCM (digital audio) API                                                                           
                                      [*]     OSS PCM (digital audio) API - Include plugin system                                                 
                                      [*]   OSS Sequencer API                                                                                     
                                    <*>   HR-timer backend support                                                                               
                                      [*]     Use HR-timer as default sequencer timer                                                               
                                      [*]   Dynamic device file minor numbers                                                                     
                                      [*]   Support old ALSA API                                                                                   
                                     [*]   Verbose procfs contents                                                                                 
                                     [ ]   Verbose printk                                                                                       
                                     [ ]   Debug                                                                                                 
                                     [*]   Generic sound devices  --->                                                                             
                                     [*]   PCI sound devices  --->                                                                                 
                                     [*]   USB sound devices  --->                                                                                 
                                     [*]   PCMCIA sound devices  --->                                                                             
                                        <*>   ALSA for SoC audio support  --->                                                       
                                     < >   Open Sound System (DEPRECATED)  --->   

Ho installato alsa-utils ma quando faccio alsaconf mi dice No sound card found
Faccio alsamixer imposto tutti i livelli al massimo ma non si sente niente.
Che posso fare?


Last edited by neretux on Wed Jul 21, 2010 6:01 pm; edited 3 times in total
Back to top
View user's profile Send private message
neretux
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 83

PostPosted: Tue Jul 20, 2010 1:54 pm    Post subject: Reply with quote

Ho seguito anche questa guida: http://www.gentoo.org/doc/it/alsa-guide.xml ma l'audio non c'è ancora. Non capisco perchè. Cosa posso fare?
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Tue Jul 20, 2010 2:59 pm    Post subject: Reply with quote

cosa stai provando a riprodurre? i livelli sono al massimo, ma hai controllato che non siano muti?
Back to top
View user's profile Send private message
neretux
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 83

PostPosted: Tue Jul 20, 2010 4:37 pm    Post subject: Reply with quote

Si ho controllato e sono attivi. Non riesco a sentire l'audio su firefox ovvero su youtube, su 105.net ecc.Come posso risolvere?
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Tue Jul 20, 2010 4:45 pm    Post subject: Reply with quote

io posseggo questa
Code:
lspci
...
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
...


e funziona più che egregiamente.
ecco le voci che ho attivato:
Code:

  --- Sound card support                                                                                                        │ │   
[ ]   Preclaim OSS device numbers                                                                                             │ │   
<*>   Advanced Linux Sound Architecture  --->                                                                                 │ │   
  <*>   Sequencer support                                                                                                       │ │   
  <*>     Sequencer dummy client                                                                                                │ │   
  <*>   OSS Mixer API                                                                                                           │ │   
  <*>   OSS PCM (digital audio) API                                                                                             │ │   
  [*]     OSS PCM (digital audio) API - Include plugin system                                                                   │ │   
  [*]   OSS Sequencer API                                                                                                       │ │   
  <*>   HR-timer backend support                                                                                                │ │   
  [*]     Use HR-timer as default sequencer timer                                                                               │ │   
  [*]   Dynamic device file minor numbers                                                                                       │ │   
  [ ]   Support old ALSA API                                                                                                    │ │   
  [ ]   Verbose procfs contents                                                                                                 │ │   
  [ ]   Verbose printk                                                                                                          │ │   
  [ ]   Debug                                                                                                                   │ │   
  [ ]   Generic sound devices  --->                                                                                             │ │   
  [*]   PCI sound devices  --->                                                                                                 │ │   
        <*>   Intel HD Audio  --->     
  │ │               [*]   Build hwdep interface for HD-audio driver                                                                               │ │   
  │ │               [*]     Allow dynamic codec reconfiguration (EXPERIMENTAL)                                                                    │ │   
  │ │               [ ]   Support digital beep via input layer                                                                                    │ │   
  │ │               [*]   Support jack plugging notification via input layer                                                                      │ │   
  │ │              [ ]   Support initialization patch loading for HD-audio                                                                       │ │   
  │ │              [*]   Build Realtek HD-audio codec support                                                                                    │ │   
  │ │              [*]   Build Analog Device HD-audio codec support                                                                              │ │   
  │ │              [*]   Build IDT/Sigmatel HD-audio codec support                                                                               │ │   
  │ │              [*]   Build VIA HD-audio codec support                                                                                        │ │   
  │ │             [*]   Build ATI HDMI HD-audio codec support                                                                                   │ │   
  │ │              [*]   Build NVIDIA HDMI HD-audio codec support                                                                                │ │   
  │ │              [*]   Build INTEL HDMI HD-audio codec support                                                                                 │ │   
  │ │               [ ]   Build Cirrus Logic codec support                                                                                        │ │   
  │ │                [*]   Build Conexant HD-audio codec support                                                                                   │ │   
  │ │              [*]   Build Creative CA0110-IBG codec support                                                                                 │ │   
  │ │                [*]   Build C-Media HD-audio codec support                                                                                    │ │   
  │ │             [*]   Build Silicon Labs 3054 HD-modem codec support                                                                          │ │   
  │ │                 [*]   Enable generic HD-audio codec parser                                                                                    │ │   
  │ │               [ ]   Aggressive power-saving on HD-audio                                                                                     │ │   

    [*]   USB sound devices  --->                                                                                                 │ │   
    < >   ALSA for SoC audio support  --->           

< >   Open Sound System (DEPRECATED)  --->     

_________________
Darkman
Back to top
View user's profile Send private message
neretux
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 83

PostPosted: Tue Jul 20, 2010 5:43 pm    Post subject: Reply with quote

Riesci a sentire tutto perfettamente? Anche su Internet?
Io ho attivato le tue stesse opzioni, ho ricompilato ma non sento nulla ugualmente.
Perchè?
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Tue Jul 20, 2010 6:29 pm    Post subject: Reply with quote

sento tutto e perfettamente :wink:

zero problemi.
Code:
eix -I alsa
[I] media-libs/alsa-lib
     Available versions:  1.0.20-r1 1.0.21a ~1.0.22 ~1.0.22-r1 ~1.0.23 {alisp alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol debug doc python}
     Installed versions:  1.0.21a(17:12:58 02/18/10)(alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol python -alisp -debug -doc)
     Homepage:            http://www.alsa-project.org/
     Description:         Advanced Linux Sound Architecture Library

[I] media-plugins/alsa-plugins
     Available versions:  1.0.20 1.0.21 ~1.0.22 ~1.0.23-r1 {debug ffmpeg jack libsamplerate pulseaudio speex}
     Installed versions:  1.0.21(22:58:34 02/18/10)(ffmpeg jack libsamplerate speex -debug -pulseaudio)
     Homepage:            http://www.alsa-project.org/
     Description:         ALSA extra plugins

[I] media-plugins/gst-plugins-alsa
     Available versions:  (0.10) 0.10.24!t 0.10.25!t 0.10.28!t ~0.10.29!t
     Installed versions:  0.10.28(0.10)!t(21:09:25 07/01/10)
     Homepage:            http://gstreamer.freedesktop.org/
     Description:         plugin for gstreamer

[I] media-sound/alsa-headers
     Available versions:  1.0.20!b!s 1.0.21!b!s ~1.0.22!b!s ~1.0.23!b!s **9999!b!s
     Installed versions:  1.0.21!b!s(00:48:59 07/06/10)
     Homepage:            http://www.alsa-project.org/
     Description:         Header files for Advanced Linux Sound Architecture kernel modules

[I] media-sound/alsa-tools
     Available versions:  (0.9) 1.0.20-r1 ~1.0.20-r2 1.0.21 ~1.0.21-r1 ~1.0.22 ~1.0.23
        {alsa_cards_darla20 alsa_cards_darla24 alsa_cards_echo3g alsa_cards_emu10k1 alsa_cards_emu10k1x alsa_cards_gina20 alsa_cards_gina24 alsa_cards_hdsp alsa_cards_hdspm alsa_cards_ice1712 alsa_cards_indigo alsa_cards_indigoio alsa_cards_layla20 alsa_cards_layla24 alsa_cards_mia alsa_cards_mixart alsa_cards_mona alsa_cards_pcxhr alsa_cards_rme32 alsa_cards_rme96 alsa_cards_sb16 alsa_cards_sbawe alsa_cards_sscape alsa_cards_usb-usx2y alsa_cards_vx222 fltk gtk}                                                     
     Installed versions:  1.0.21(0.9)(18:06:54 02/18/10)(alsa_cards_emu10k1x gtk -alsa_cards_darla20 -alsa_cards_darla24 -alsa_cards_echo3g -alsa_cards_emu10k1 -alsa_cards_gina20 -alsa_cards_gina24 -alsa_cards_hdsp -alsa_cards_hdspm -alsa_cards_ice1712 -alsa_cards_indigo -alsa_cards_indigoio -alsa_cards_layla20 -alsa_cards_layla24 -alsa_cards_mia -alsa_cards_mixart -alsa_cards_mona -alsa_cards_pcxhr -alsa_cards_rme32 -alsa_cards_rme96 -alsa_cards_sb16 -alsa_cards_sbawe -alsa_cards_sscape -alsa_cards_usb-usx2y -alsa_cards_vx222 -fltk)                                                                                                                                                         
     Homepage:            http://www.alsa-project.org
     Description:         Advanced Linux Sound Architecture tools

[I] media-sound/alsa-utils
     Available versions:  (0.9) 1.0.20-r5 1.0.21-r1 ~1.0.22-r1 ~1.0.23
        {doc minimal nls}
     Installed versions:  1.0.21-r1(0.9)(17:14:45 02/18/10)(nls -doc -minimal)
     Homepage:            http://www.alsa-project.org/
     Description:         Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)



hai anche tu tutte 'ste cose installate?
_________________
Darkman
Back to top
View user's profile Send private message
neretux
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 83

PostPosted: Tue Jul 20, 2010 7:41 pm    Post subject: Reply with quote

Ora sì, ma non ho risolto per niente. Che posso fare altro?
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Tue Jul 20, 2010 7:58 pm    Post subject: Reply with quote

ti da ancora lo stesso errore? (card not found?)

altra cosa. controlla BENE di aver abilitato SOLO ED ESCLUSIVAMENTE le opzioni del kernel che ti ho messo io.
il motivo?

sia mai che tu abbia abilitato cose del tipo "dummy card". in questo modo la "prima" sound-card che il sistema ti legge è "l'altra".
a me è capitato. :wink:

altra cosa:
dentro /var/log/ hai per caso dei log di alsa?

se si, postali.

poi prova a fare /etc/init.d/alsasound restart

e facci sapere eventuali errori (se non ti vengono fuori, guarda il dmesg)
_________________
Darkman
Back to top
View user's profile Send private message
neretux
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 83

PostPosted: Wed Jul 21, 2010 8:42 am    Post subject: Reply with quote

Premesso che ho impostato pedissequamente le opzioni che mi hai postato, allora i messaggi che mi da alsaconf sono:
Quote:
No supported PnP or PCI card found. Would you like to probe legacy isa sound card/chips?

Ho scelto Yes
Quote:
Probing legacy isa cards might make your system unstable. Do you want to proceed?

Ho scelto Yes
Quote:
No legacy drivers are available


Poi ho fatto
Code:
localhost neretux # ls  /var/log/
ConsoleKit      cups              emerge.log  news     wicd
Xorg.0.log      dmesg             faillog     portage  wtmp
Xorg.0.log.old  emerge-fetch.log  lastlog     sandbox

Ed ancora
Code:
localhost neretux #  /etc/init.d/alsasound restart
 * Loading ALSA modules ...                                               [ ok ]
 * Restoring Mixer Levels ...                                             [ ok ]

Ecco dmesg: http://pastebin.com/5X47JBic
Suggerimenti?
Back to top
View user's profile Send private message
neretux
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 83

PostPosted: Wed Jul 21, 2010 5:21 pm    Post subject: Reply with quote

Ho risolto! :D
Dato che su gentoo l'audio funziona il problema era con firefox perchè non riuscivo ad ascoltare youtube, 105.net ecc. Avendo installato flash con nsplugin wrapper è bastato installare
Code:
# emerge -av app-emulation/emul-linux-x86-soundlibs
seguendo questo wiki http://www.gentoo-wiki.info/Adobe_Flash#No_sound_using_nspluginwrapper
Grazie per l'aiuto. :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum