Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trouble-shooting Blueman on xfce4 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 992

PostPosted: Mon Jul 19, 2010 2:04 am    Post subject: Trouble-shooting Blueman on xfce4 [SOLVED] Reply with quote

Hi All:

I have been trying to get bluetooth working over the past couple of days to my BB 9700.
bluez appears to be working as i can see the phone using hcitool:
jserink@jerinkturion ~/qemu $ hcitool scan
Scanning ...
2C:A8:35:C3:46:A6 JohnSerinkBlackBerry9700

So that part appears to be working.
Getting blueman working as been a challenge and feel I'm almost there except for a few gnome nigglies.....
Here are my blueman use flags:
[ebuild R ] net-wireless/blueman-1.21-r1 USE="gnome hal network nls -pulseaudio" 0 kB

Ok, now, blueman is sitting int he notification tray and when I click on Setup new device it does nothing, and if I click on adapters I get a little GTK window with an CLOSE button. CLI....
First, find the commands, output from locate blueman run as root:
/usr/bin/blueman-manager
/usr/bin/blueman-applet
/usr/bin/blueman-browse
/usr/bin/blueman-sendto
/usr/bin/blueman-ifup
/usr/bin/blueman-assistant
/usr/bin/blueman-adapters
/usr/bin/blueman-services

Cool, logged in as me, i do the following:
jserink@jerinkturion ~/qemu $ Loading configuration plugins
Using gconf config backend
there is an instance already running

[1]+ Done blueman-manager

Makes sense, the icon is in the notification tray. Fine.

jserink@jerinkturion ~/qemu $ blueman-adapters
org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.28" (uid=500 pid=7615 comm="/usr/bin/python2.6) interface="org.bluez.Manager" member="ListAdapters" error name="(unset)" requested_reply=0 destination="org.bluez" (uid=0 pid=4336 comm="/usr/sbin/bluetoothd))
org.bluez owner changed to :1.0

Ahhh, now we're getting somewhere. Ok, first thing, permission issue somewhere.
What if I run that as root, it should work right?

jerinkturion modules # blueman-applet
Loading configuration plugins
Skipping plugin gconf
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
No suitable configuration backend found, exitting

Right, now we're getting more info. So, I DO have a permissions issue from a normal user but also there is some gnome backend-crud that is not right. I need a hand at this point. What is blueman-applet looking for here?

I did a ps -elf | grep "blueman" and killed off everything and then did this:
jerinkturion modules # blueman-manager
Loading configuration plugins
Skipping plugin gconf
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
No suitable configuration backend found, exitting

VERY similar error to what I got running blueman-adapter.

Ok, need some pointers at this point.

Woooooo....google is it. Went here:
https://bugs.launchpad.net/ubuntu/+source/gconf/+bug/336660

And put this in my terminal that I started as jserink but then su'd to root:
export DBUS_SESSION_BUS_ADDRESS=""

then I re-run blueman-manager and boom, dialog with my adapter showing......Ahhhhhhhh......

Ok, fine, so now new questions:
1. Is blueman-manager suppose to start as root?
2. If the answer is yes, how do I make sure that it does start as root?
3. If the answer to 1 is no, then who it is suppose to start as?
4. When I start blueman-manager as me, I get this:
jserink@jerinkturion ~/qemu $ Loading configuration plugins
Using gconf config backend
Using gconf config backend
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/dbus/connection.py", line 578, in msg_reply_handler
reply_handler(*message.get_args_list(**get_args_opts))
File "/usr/bin/blueman-manager", line 153, in on_bluez_name_owner_changed
self.List = ManagerDeviceList(adapter=self.Config.props.last_adapter, inst=self)
File "/usr/lib64/python2.6/site-packages/blueman/gui/manager/ManagerDeviceList.py", line 71, in __init__
DeviceList.__init__(self, adapter, data)
File "/usr/lib64/python2.6/site-packages/blueman/gui/DeviceList.py", line 121, in __init__
self.SetAdapter(adapter)
File "/usr/lib64/python2.6/site-packages/blueman/gui/DeviceList.py", line 331, in SetAdapter
except dbus.DBusServiceUnknownError:
AttributeError: 'module' object has no attribute 'DBusServiceUnknownError'

4. What permissions do I have to change to make this work?
here is me now:
jserink@jerinkturion ~/qemu $ groups jserink
root bin tty disk lp wheel floppy uucp man console audio cdrom dialout video cdrw usb locate jserink plugdev gkrellmd qemu internal wireshark kvm games users

Cheers,
John


Last edited by jserink on Thu Jul 22, 2010 4:01 am; edited 1 time in total
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 992

PostPosted: Tue Jul 20, 2010 3:59 am    Post subject: Reply with quote

Ok, so it works if I start blueman-manager as root, but I don't want to do that.

So, goodled "Should blueman-manager be run as root?" and got sent here:
https://bbs.archlinux.org/viewtopic.php?id=70429

There a chap said to use this from a terminal logged in as me:
ck-launch-session blueman-manager

Ok, it worked......

Why?

And where should I put this so that it comes up when xfce4 starts?

Cheers,
john
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 992

PostPosted: Thu Jul 22, 2010 4:01 am    Post subject: Ok, fixed Reply with quote

Hi:

Had some time to go in and out of X so got this sorted....

Made a directory ~/bin.
In this I made the file bluemanstart.sh
Here is this file:
ck-launch-session blueman-applet > /dev/null 2>&1 &

I then made it executable.

I went to Settings-> Session and Startup->Applicatin Autostart.

Here I unticked the blueman applet since this would start with my security credentials which are not quite right.
I then ckicked the ADD button and pointed it to my file bluemanstart.sh.

Now when xfce4 starts, the blueman-applet is running and it works!

Cheers,
John
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum