Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Erreur à la compilation de Kompzer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Wed Jul 14, 2010 11:56 am    Post subject: [emerge] Erreur à la compilation de Kompzer Reply with quote

Bonjour,

La recompilation de Kompozer provoque une erreur :

Quote:
nsPNGEncoder.cpp: In member function ‘virtual nsresult nsPNGEncoder::InitFromData(const PRUint8*, PRUint32, PRUint32, PRUint32, PRUint32, PRUint32, const nsAString_internal&)’:
nsPNGEncoder.cpp:114: erreur: ‘png_voidp_NULL’ was not declared in this scope
nsPNGEncoder.cpp:115: erreur: ‘png_error_ptr_NULL’ was not declared in this scope
gmake[4]: *** [nsPNGEncoder.o] Erreur 1
gmake[4]: quittant le répertoire « /var/tmp/portage/app-editors/kompozer-0.8_beta1/work/mozilla/modules/libpr0n/encoders/png »
gmake[3]: *** [libs] Erreur 2
gmake[3]: quittant le répertoire « /var/tmp/portage/app-editors/kompozer-0.8_beta1/work/mozilla/modules/libpr0n/encoders »
gmake[2]: *** [libs] Erreur 2
gmake[2]: quittant le répertoire « /var/tmp/portage/app-editors/kompozer-0.8_beta1/work/mozilla/modules/libpr0n »
gmake[1]: *** [tier_9] Erreur 2
gmake[1]: quittant le répertoire « /var/tmp/portage/app-editors/kompozer-0.8_beta1/work/mozilla »
make: *** [default] Erreur 2
* ERROR: app-editors/kompozer-0.8_beta1 failed:
* make failed
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 3580: Called die
* The specific snippet of code:
* emake ${jobs} || die "make failed"
*
* If you need support, post the output of 'emerge --info =app-editors/kompozer-0.8_beta1',
* the complete build log and the output of 'emerge -pqv =app-editors/kompozer-0.8_beta1'.
* This ebuild is from an overlay: '/usr/local/portage/overlay/'
* The complete build log is located at '/var/tmp/portage/app-editors/kompozer-0.8_beta1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-editors/kompozer-0.8_beta1/temp/environment'.
* S: '/var/tmp/portage/app-editors/kompozer-0.8_beta1/work/mozilla'
sandbox:main signal SIGQUIT already had a handler ...


>>> Failed to emerge app-editors/kompozer-0.8_beta1, Log file:

>>> '/var/tmp/portage/app-editors/kompozer-0.8_beta1/temp/build.log'

* Messages for package app-editors/kompozer-0.8_beta1:

* Selected language packs (first will be default): fr
* ERROR: app-editors/kompozer-0.8_beta1 failed:
* make failed
*
* Call stack:
* ebuild.sh, line 54: Called src_compile
* environment, line 3580: Called die
* The specific snippet of code:
* emake ${jobs} || die "make failed"
*
* If you need support, post the output of 'emerge --info =app-editors/kompozer-0.8_beta1',
* the complete build log and the output of 'emerge -pqv =app-editors/kompozer-0.8_beta1'.
* This ebuild is from an overlay: '/usr/local/portage/overlay/'
* The complete build log is located at '/var/tmp/portage/app-editors/kompozer-0.8_beta1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-editors/kompozer-0.8_beta1/temp/environment'.
* S: '/var/tmp/portage/app-editors/kompozer-0.8_beta1/work/mozilla'

_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7894
Location: ~Brussels - Belgique

PostPosted: Wed Jul 14, 2010 12:47 pm    Post subject: Reply with quote

Quelle version de libpng as-tu ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 490

PostPosted: Wed Jul 14, 2010 12:52 pm    Post subject: Reply with quote

+1 pour la libpng...

Sinon, une raison particulière de ne pas utiliser la 0.8-beta3? (cf ebuild
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Wed Jul 14, 2010 10:58 pm    Post subject: Reply with quote

XavierMiller wrote:
Quelle version de libpng as-tu ?

1.4.3
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7894
Location: ~Brussels - Belgique

PostPosted: Thu Jul 15, 2010 6:45 am    Post subject: Reply with quote

OK. Peut-être que cette version de Kompozer ne supporte pas cette nouvelle version de libpng.

As-tu jeté un oeil sur https://bugs.gentoo.org ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Thu Jul 15, 2010 10:17 pm    Post subject: Reply with quote

XavierMiller wrote:
As-tu jeté un oeil sur https://bugs.gentoo.org ?

Oui, il n'y a rien d'intéressant.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7894
Location: ~Brussels - Belgique

PostPosted: Fri Jul 16, 2010 6:24 am    Post subject: Reply with quote

Il y a ce bug : https://bugs.gentoo.org/show_bug.cgi?id=146761
Réponds-y que ça ne va pas chez toi, avec ton message d'erreur.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sat Jul 17, 2010 12:58 pm    Post subject: Reply with quote

Bonjour,

Je n'arrive pas non plus à compiler la version 0.8_beta3 :

Code:
 * ERROR: app-editors/kompozer-0.8_beta3 failed:
 *   error reading mozconfig: ac_add_options --enable-extensions="default spellcheck"
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 5334:  Called mozconfig_final
 *   environment, line 4739:  Called die
 * The specific snippet of code:
 *           [[ -z ${hash} || ${hash} == \# ]] || die "error reading mozconfig: ${ac} ${opt} ${hash} ${reason}";

_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Sat Jul 17, 2010 1:44 pm    Post subject: Reply with quote

Salut,

Je crois que pour la beta3 il ne faut pas oublier de recopier les 2 eclass modifiés qu'ils fournissent dans le bugzilla dans /usr/portage/eclass. Mais je pense qu'il faudrait voir avec les auteurs des ebuilds et/ou de Kompozer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum