Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
another locale issue???
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
mrknowitall
Apprentice
Apprentice


Joined: 02 Feb 2005
Posts: 173

PostPosted: Tue Jul 06, 2010 9:09 pm    Post subject: another locale issue??? Reply with quote

hi guys,

i'm working with linux for a while, but i don't seem to get along well with locales...

I use the KDE desktop environment. The problem is, that sometimes for german umlauts i get a "�" instead of the right one. This doesn't happen when typing, like when typing "ü". I really don't have a clue where it's coming from. I use unicode use flag in my /etc/make.conf.

this are the config files related:

/etc/locale.gen

    en_US ISO-8859-1
    en_US.UTF-8 UTF-8
    #ja_JP.EUC-JP EUC-JP
    #ja_JP.UTF-8 UTF-8
    #ja_JP EUC-JP
    #en_HK ISO-8859-1
    #en_PH ISO-8859-1
    de_DE ISO-8859-1
    de_DE@euro ISO-8859-15
    de_DE.UTF-8 UTF-8
    #es_MX ISO-8859-1
    #fa_IR UTF-8
    #fr_FR ISO-8859-1
    #fr_FR@euro ISO-8859-15
    #it_IT ISO-8859-1


/etc/env.d/02locale
    LANG="de_DE.UTF-8"
    KDM_LANG="de_DE.UTF-8"
    LC_COLLATE="C"
    LC_CTYPE="C"
    LC_MESSAGES="C"
    LC_ALL="de_DE.UTF-8"


and of course in my .config file i have enabled support for unicode.

i don't care if compile messages appear in german or english (though english would be better), but i want a straight german desktop. and of course, i want to get rid of those strange symbols, since they prevent me from accessing the files properly.

any help appreciated!


cheers!

alex
_________________
ignorance is a bless!
Back to top
View user's profile Send private message
dermund
Apprentice
Apprentice


Joined: 28 Aug 2007
Posts: 205
Location: Sprawl

PostPosted: Wed Jul 07, 2010 12:30 pm    Post subject: Reply with quote

Hi Alex,

Quote:
I use the KDE desktop environment. The problem is, that sometimes for german umlauts i get a "�" instead of the right one. This doesn't happen when typing, like when typing "ü". I really don't have a clue where it's coming from. I use unicode use flag in my /etc/make.conf.


Does this behaviour occur in a specific application? If so, is the application itself supporting the desired codepage, utf-8?
Maybe the guys in the german forum could be a great help also.

Just my 2 cents,

dermund
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1381
Location: Montréal

PostPosted: Wed Jul 07, 2010 1:21 pm    Post subject: Reply with quote

Hello,
you probably know, but the fonts in use needs to contain the characters you want to display. You need to have the locales you want to be active for the applications use them by default. You sometimes need to set them manually even with the goods locales in service. Some applications can not support them at all. In plus, the file you want to see need to be encoded like it is set for the locales in use, or you have to place the application in the encoding of the file, or convert the file in the good encoding. A lot of files are not encoded in UTF8 but ISO-9660 and sometimes in ASCII. My desktop is in fr_FR-UTF8. I get some wrong characters too, specially with the manpages who use both ISO-9660 and UTF8. Subject more complex that it look.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum