Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
My dnsmasq don't starting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
APolozov
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2006
Posts: 149
Location: Voronezh, Russia

PostPosted: Sun Jul 04, 2010 1:02 pm    Post subject: My dnsmasq don't starting Reply with quote

I have a internet connection on PPP0 (global internet) over ETH0 (provider intranet).
I want share this connection to PPP1 (communacator with Windows Mobile)
NAT is installed and tuned. Trace for IP address is work.
But my fresh installed DNS daemon (for example dnsmasq or bind) don't starting.
Code:
pan@localhost /usr/portage/games-action $ sudo /etc/init.d/dnsmasq restart
dnsmasq         | * WARNING: dnsmasq is scheduled to start when net.ppp0 has started

Restarting net.ppp0 or net.eth0 don't help my. My skill of DNS service is Zero :-(
_________________
Excuse my bad English, I only study it.

I also connected to: velo36.ru openstreetmap.org
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2391
Location: Wisconsin (USA)

PostPosted: Sun Jul 04, 2010 6:04 pm    Post subject: Reply with quote

I would wonder why your ppp0 doesn't appear fully started - that seems to be the problem.
Back to top
View user's profile Send private message
APolozov
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2006
Posts: 149
Location: Voronezh, Russia

PostPosted: Sun Jul 04, 2010 6:25 pm    Post subject: Reply with quote

Hm, but my net.ppp0 is started and the internet is fully working
Code:
pan@localhost /home $ sudo /etc/init.d/net.ppp0 restart
net.ppp0        | * Bringing down interface ppp0
net.ppp0        | *   Stopping pppd on ppp0                                                        [ ok ]
net.ppp0        | * Bringing up interface ppp0
net.ppp0        | *   Starting pppd in ppp0 ...                                                    [ ok ]
net.ppp0        | *   Backgrounding ...
net.ppp0        | * WARNING: net.ppp0 has started, but is inactive

How I can make to change?
_________________
Excuse my bad English, I only study it.

I also connected to: velo36.ru openstreetmap.org
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2391
Location: Wisconsin (USA)

PostPosted: Sun Jul 04, 2010 6:40 pm    Post subject: Reply with quote

Hmm, has started but is inactive... I'm not sure what this means as I haven't ever used gentoo-managed ppp. Maybe there's an option to change that behavior?
Back to top
View user's profile Send private message
APolozov
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2006
Posts: 149
Location: Voronezh, Russia

PostPosted: Sun Jul 04, 2010 6:44 pm    Post subject: Reply with quote

Hm, I turn rc_depend_strict in /etc/rc.conf to "NO" and dnsmasq is loaded
_________________
Excuse my bad English, I only study it.

I also connected to: velo36.ru openstreetmap.org
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2391
Location: Wisconsin (USA)

PostPosted: Sun Jul 04, 2010 8:32 pm    Post subject: Reply with quote

That might be a good enough workaround - if it causes problems for other services then you could probably edit /etc/init.d/dnsmasq and remove the network dependency.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum