Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
skype segfault su multilib
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sat Jul 03, 2010 10:03 pm    Post subject: skype segfault su multilib Reply with quote

Allora,
ho un sistema multilib e ho installato pure skype-2.1.0.81. (ma la cosa=(stesso errore) mi si verifica per TUTTE le versioni di skype che ho) {testato su due versioni vecchie oltre a questa}
8O
(nb: se linko così, funziona tutto)

Code:
skype
Segmentation fault


fantastico.... però pare che la cosa capiti solo a me quindi listo di seguito alcune cose che possono esser d'aiuto a capire quale sia l'errore:
Code:
eix -I emul-   
[I] app-emulation/emul-linux-x86-baselibs
     Installed versions:  20100611!s(17:41:44 07/01/10)

[I] app-emulation/emul-linux-x86-gtklibs
     Installed versions:  20100611!s(20:08:03 07/01/10)

[I] app-emulation/emul-linux-x86-medialibs
     Installed versions:  20100611!s(20:41:31 07/01/10)

[I] app-emulation/emul-linux-x86-opengl
     Installed versions:  20100611!s(14:13:00 07/02/10)

[I] app-emulation/emul-linux-x86-qtlibs
     Installed versions:  20100611!s(14:15:45 07/02/10)

[I] app-emulation/emul-linux-x86-sdl
     Installed versions:  20100611!s(14:14:43 07/02/10)

[I] app-emulation/emul-linux-x86-soundlibs
     Installed versions:  20100611!s(20:41:50 07/01/10)(alsa -pulseaudio)

[I] app-emulation/emul-linux-x86-xlibs
     Installed versions:  20100611!s(20:00:21 07/01/10)(opengl)


e per quanto possa valere, strace:
Code:
strace /usr/bin/skype
execve("/usr/bin/skype", ["/usr/bin/skype"], [/* 61 vars */]) = 0
brk(0)                                  = 0x27f8000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f5721641000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=211468, ...}) = 0
.....
futex(0xffe2f0e0, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 1, NULL, ffe2f0f0) = -1 EAGAIN (Resource temporarily unavailable)
rt_sigaction(SIGRTMIN, {0xf732a410, [], SA_SIGINFO}, NULL, 8) = 0
rt_sigaction(SIGRT_1, {0xf732a900, [], SA_RESTART|SA_SIGINFO}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [RTMIN RT_1], NULL, 8) = 0
getrlimit(RLIMIT_STACK, {rlim_cur=-4286578688, rlim_max=-633953476585455600}) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Segmentation fault

_________________
Darkman
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum