Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Erreur de compilation des drivers NVIDIA (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sun Jun 27, 2010 7:30 am    Post subject: [emerge] Erreur de compilation des drivers NVIDIA (résolu) Reply with quote

Bonjour,

Je recompile les drivers NVIDIA suite à la mise à jour du kernel. J'obtiens l'erreur :
Code:
 * Messages for package x11-drivers/nvidia-drivers-190.42-r3:

 * ERROR: x11-drivers/nvidia-drivers-190.42-r3 failed:
 *   Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS=  IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux       SYSOUT=/lib/modules/2.6.33-gentoo-r2/build HOST_CC=x86_64-pc-linux-gnu-gcc clean module


emerge --info =x11-drivers/nvidia-drivers-190.42-r3 donne le résultat suivant.
_________________
emerge --info
dmesg
lspci
.config


Last edited by Neuromancien on Fri Jul 02, 2010 9:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Sun Jun 27, 2010 9:03 am    Post subject: Reply with quote

Tu dois avoir une autre erreur au dessus de ce message. Ce que tu nous montres là n'est qu'un message générique. Tu peux peut-être nous montrer le log complet ?
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Sun Jun 27, 2010 9:06 am    Post subject: Reply with quote

netfab +1
Un l33t devrait savoir ça depuis longtemps ! :roll:

Tu as consulté les topics récents, en particulier, celui de rocky800_1 ?
Aucun rapport ?
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sun Jun 27, 2010 6:21 pm    Post subject: Reply with quote

netfab wrote:
Tu dois avoir une autre erreur au dessus de ce message. Ce que tu nous montres là n'est qu'un message générique. Tu peux peut-être nous montrer le log complet ?

Oui, j'ai copié-collé un peu trop vite. L'erreur est la suivante :
Code:
*** Unable to determine the target kernel version. ***

Code:
tux jerome # ls -lrt /usr/src/linux
lrwxrwxrwx 1 root root 22 26 juin  20:15 /usr/src/linux -> linux-2.6.33-gentoo-r2

Je ne comprends pas où est le problème. Il y a bien un thread à ce sujet mais aucune des solutions proposées ne fonctionne.

Edit : Ce n'est pas le même problème que pour rocky800_1.
_________________
emerge --info
dmesg
lspci
.config


Last edited by Neuromancien on Sun Jun 27, 2010 6:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Sun Jun 27, 2010 6:27 pm    Post subject: Reply with quote

Visiblement l'emerge --info de ta signature n'est pas à jour.
Vérifie les liens symboliques dans le(s) répertoire(s) suivant(s) :
Code:

$ ls -l /lib/modules/2.6.3*

C'est par là que les eclass déterminent les sources utilisées.
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sun Jun 27, 2010 6:32 pm    Post subject: Reply with quote

netfab wrote:
Visiblement l'emerge --info de ta signature n'est pas à jour.

Non, puisque je n'ai pas pu lancer X sous le nouveau kernel.

netfab wrote:

Vérifie les liens symboliques dans le(s) répertoire(s) suivant(s) :
Code:

$ ls -l /lib/modules/2.6.3*

C'est par là que les eclass déterminent les sources utilisées.


Code:
source -> /usr/src/linux-2.6.33-gentoo-r2

_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1677
Location: 127.0.0.1

PostPosted: Sun Jun 27, 2010 6:36 pm    Post subject: Reply with quote

Il te manque un lien symbolique à cet endroit. Tu devrais aussi avoir un lien comme ceci :
Code:

build -> /usr/src/linux-2.6.33-gentoo-r2
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Sun Jun 27, 2010 6:45 pm    Post subject: Reply with quote

netfab wrote:
Il te manque un lien symbolique à cet endroit. Tu devrais aussi avoir un lien comme ceci :
Code:

build -> /usr/src/linux-2.6.33-gentoo-r2

Non, il est bien là lui-aussi:
Code:
build -> /usr/src/linux-2.6.33-gentoo-r2

_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
gulivert
l33t
l33t


Joined: 17 Jun 2004
Posts: 863
Location: Switzerland

PostPosted: Mon Jun 28, 2010 9:43 am    Post subject: Reply with quote

Je ne sais pas si c'est la solution, mais à ta place je ferais un coup de make && make modules_install dans les sources du noyau afin de recompiler la bête et après ton problème risque fort de disparaître. On dirait qu'un truc à merder avec ton kernel du coup sa peut, ou pas, régler le problème.

Bonne chance.
_________________
Macbook Pro Unibody 9.1 - Kernel 4.4.6 - Awesome 3.5
Back to top
View user's profile Send private message
Nirna
n00b
n00b


Joined: 01 Dec 2005
Posts: 36
Location: France

PostPosted: Mon Jun 28, 2010 7:30 pm    Post subject: Reply with quote

Ta version des drivers n'est pas compatible avec le noyau en question

Kernel et Hardware => pb drivers Nvidia et noyau 2.6.33

Tu peux prendre la version instable des drivers pour solutionner le problème.
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Fri Jul 02, 2010 9:23 pm    Post subject: Reply with quote

Nirna wrote:
Ta version des drivers n'est pas compatible avec le noyau en question

Kernel et Hardware => pb drivers Nvidia et noyau 2.6.33

Tu peux prendre la version instable des drivers pour solutionner le problème.

Merci.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum