Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
errore grub
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
alessandro95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2010
Posts: 148

PostPosted: Sat Jul 03, 2010 1:13 pm    Post subject: Reply with quote

sisi, comunque è tutto giusto , l'fstab l'ho ricontrollato , il grub.conf anche , tutto corretto ,nella shell di grub ho usato
Code:
grub> root (hd0,0)
grub> setup (hd0)
quit

mi ha dato tutto ok, yes e done , neanche un errore ,cos'è che non va? forse prorpio grub , forse come detto prima per me va bene lilo , c'è scritto sull'handbook che in certi pc grub non va bene. adesso cosa faccio ?
Code:
emerge --unmerge grub
emerge lilo

ci ho già provato ma quando faccio
Code:
emege lilo
mi dicce
Code:
Could not determine root partition!
cosa devo fare?? avete altre idee??
_________________
SPETTACOLO!!!!!!!!!
http://www.youtube.com/watch?v=GZqfH1LQEOQ
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Jul 03, 2010 1:18 pm    Post subject: Reply with quote

certo che stiamo uscendo pazzi! :D

Posteresti grub.conf aggiornato?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
alessandro95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2010
Posts: 148

PostPosted: Sat Jul 03, 2010 1:22 pm    Post subject: Reply with quote

Code:
default=0
timeout=30
splashimage=(hd0,0)/grub/splash.xpm.gz

#title Gentoo Linux 2.6.33-r2
#root (hd0,0)
#kernel /boot /kernel-genkernel-x86_64-2.6.33-gentoo-r2 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3
#initrd /boot/initramfs-genkernel-x86_64-2.6.33-gentoo-r2


_________________
SPETTACOLO!!!!!!!!!
http://www.youtube.com/watch?v=GZqfH1LQEOQ
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Jul 03, 2010 1:26 pm    Post subject: Reply with quote

ecco il nocciolo della situazione...devi sapere che in bash i cancelletti ( # ) sono commenti, per cui tutto quello che segue dopo un # viene semplicemente ignorato.
Per cui dovresti avere:
Code:
default=0

title Gentoo Linux 2.6.33-r2
root (hd0,0)
kernel /boot /kernel-genkernel-x86_64-2.6.33-gentoo-r2 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3
initrd /boot/initramfs-genkernel-x86_64-2.6.33-gentoo-r2


Se ben noti ho eliminato il timeout e lo splash in quanto (per il momento) poco utili.

Riposta se hai problemi :)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Sat Jul 03, 2010 1:26 pm    Post subject: Reply with quote

Ma perchè è tutto commentato?! Cancella i cancelletti.

P.S.: Scusa ago :)
Back to top
View user's profile Send private message
alessandro95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2010
Posts: 148

PostPosted: Sat Jul 03, 2010 2:05 pm    Post subject: Reply with quote

lol!!! era solo questo il problema , da quello che ho capito grub ignorava tutto quello che io scrivevo in grub.conf , così quando accendevo il pc non trovava niente da far partire.guisto?
_________________
SPETTACOLO!!!!!!!!!
http://www.youtube.com/watch?v=GZqfH1LQEOQ
Back to top
View user's profile Send private message
Zizo
Apprentice
Apprentice


Joined: 04 Feb 2010
Posts: 200
Location: Padova, Italy

PostPosted: Sat Jul 03, 2010 2:09 pm    Post subject: Reply with quote

Precisamente :) È una regola che vale quasi in ogni file di configurazione nonchè script in *sh e in altri moltissimi casi.
Quindi magari controlla anche /etc/fstab e gli altri file a cui puoi aver messo mano.

Ti chiedo scusa per non essermene accorto prima quando hai postato i file che ti avevo chiesto. Spero che ora sia più semplice per te :)
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Jul 03, 2010 2:33 pm    Post subject: Reply with quote

bene..finalmente possiamo mettere risolto


P.S. nei file in cui ritieni inutili puoi cancellare righe commentate al fine di avere un ordine maggiore :)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Sat Jul 03, 2010 2:43 pm    Post subject: Reply with quote

Quote:


Ma perchè è tutto commentato?! Cancella i cancelletti.

Quote:
lol!!! era solo questo il problema , da quello che ho capito grub ignorava tutto quello che io scrivevo in grub.conf , così quando accendevo il pc non trovava niente da far partire.guisto?

8O
Alessandro95......Crocifisso o al rogo?Scegli :twisted:

ehehehe scherzo
_________________
IL DESTINO è CONTRO DI ME?!.....................TANTO PEGGIO PER LUI!!!
Back to top
View user's profile Send private message
alessandro95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2010
Posts: 148

PostPosted: Sat Jul 03, 2010 3:52 pm    Post subject: Reply with quote

wowwwwwwwwwwwwwwww gentoo parteeeeee!!!!!!! :lol: :lol: :lol:
ho creato un nuovo utente ,come faccio ad installare kde ultima versione?
_________________
SPETTACOLO!!!!!!!!!
http://www.youtube.com/watch?v=GZqfH1LQEOQ
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sat Jul 03, 2010 4:03 pm    Post subject: Reply with quote

a dire il vero mi aspettavo un altro thread :o

cmq devi prima installare xorg

poi installi il tuo DE/WM preferito


P.S. un thread, un problema, ma prima di chiedere falla una lettura -.-
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
alessandro95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jan 2010
Posts: 148

PostPosted: Sat Jul 03, 2010 5:03 pm    Post subject: Risolto Reply with quote

xorg lo sto gia installando , ci sta mettendo un'eternità....cmq grazie mille a tutti per avermi risolto il problema e per la pazienza che avete con me , ricordate che ne dovrete avere altra , perchè adesso che sono riucito ad installare gentoo mi dovrete imparare un po di cosette!! :oops: :lol:
_________________
SPETTACOLO!!!!!!!!!
http://www.youtube.com/watch?v=GZqfH1LQEOQ
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Sat Jul 03, 2010 5:56 pm    Post subject: Reply with quote

Penso di aver capito il tuo problema, in /boot/grub/menu.lst devi specificare
kernek /kernel........ root=/dev/sda3 e non
kernel /boot/kernel........ root=/dev/sda3
e così anche per initramfs
intird /initramfs.........
perchè tu hai la partizione per /boot e una per root, se invece ne hai una sola per root
devi
kernel /boot/kernel........ root=/dev/sda3
intird /boot/initramfs.........
penso che sia il tuo equivoco......
:wink:
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Sat Jul 03, 2010 6:05 pm    Post subject: Reply with quote

il problema è già stato risolto una decina di post più su...
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Sun Jul 04, 2010 2:00 pm    Post subject: Reply with quote

Sì The Extremer, grazie ad avermelo fatto notare........
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum