Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VGA switcheroo howto
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
peltco
n00b
n00b


Joined: 25 Oct 2009
Posts: 2

PostPosted: Mon Jun 21, 2010 8:13 pm    Post subject: VGA switcheroo howto Reply with quote

for those with laptops both both a ati and an intel card i put toget a howto to make switching easy(er). should work with nvidia/intel combinations too with little change.

if anyone has any other tips/feedback let me know and i'll include it.

http://en.gentoo-wiki.com/wiki/Vga_switcheroo
Back to top
View user's profile Send private message
corphi
n00b
n00b


Joined: 19 May 2008
Posts: 20

PostPosted: Tue Aug 24, 2010 5:59 pm    Post subject: Reply with quote

I needed to explicitly
Code:
# mount -t debugfs debugfs /sys/kernel/debug


/etc/fstab helped:
Code:
debugfs    /sys/kernel/debug    debugfs    rw    0 0
Back to top
View user's profile Send private message
Goeland86
Apprentice
Apprentice


Joined: 12 Mar 2004
Posts: 177
Location: Neuchatel, Switzerland

PostPosted: Sun Apr 03, 2011 8:20 am    Post subject: Reply with quote

I don't know if it's my connection, of gentoo-wiki is down. Could I ask you to make the howto available somewhere else? I've got a laptop with two ATI cards (one IGP one discrete), and would really like to find a way to select the proper VGA card when I need it. (Using the radeon driver atm, fglrx doesn't support the PowerXpress settings afaik.

Thanks,

Goeland
Back to top
View user's profile Send private message
tclover
Apprentice
Apprentice


Joined: 10 Apr 2011
Posts: 295

PostPosted: Sat Apr 16, 2011 4:30 pm    Post subject: Reply with quote

deleted on May 30, 2011, at 00:30.

Last edited by tclover on Sun May 29, 2011 10:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
kkspeed
n00b
n00b


Joined: 17 Apr 2011
Posts: 11

PostPosted: Sun Apr 17, 2011 11:01 am    Post subject: Recently changes in kernel Reply with quote

Recently, in kernel 2.6.38, the contents in /sys/kernel/debug/vgaswitheroo/switch has changed.

Now it is sth like:

0:DIS: :Off:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0

so in the /etc/hprofile/profiles/graphics/ptest, you may need to change sth or you'll always get "invalid" :D .
I changed it like this:
Code:

#!/bin/bash

# This script should echo the name of the profile that should be used (only).

#check if we have switchable graphics
if [ ! -f /sys/kernel/debug/vgaswitcheroo/switch ] ; then
    echo "radeon"
    exit 0
fi


if [ `uname -r | grep 2.6.38` ] ; then
   if [ `grep "DIS:+" /sys/kernel/debug/vgaswitcheroo/switch` ] ; then
      echo "radeon"
      exit 0
   fi
   if [ `grep "IGD:+" /sys/kernel/debug/vgaswitcheroo/switch` ] ; then
      echo "intel"
      exit 0
   fi
else
   if [ `grep "0:+" /sys/kernel/debug/vgaswitcheroo/switch` ] ; then
      echo "radeon"
      exit 0
   fi
   if [ `grep "1:+" /sys/kernel/debug/vgaswitcheroo/switch` ] ; then
      echo "intel"
      exit 0
   fi
fi

echo "invalid"
exit 1

Back to top
View user's profile Send private message
tclover
Apprentice
Apprentice


Joined: 10 Apr 2011
Posts: 295

PostPosted: Sun Apr 17, 2011 1:23 pm    Post subject: Reply with quote

Thanks kkspeed. I will make the necessary changes. Since I updated to kernel 2.6.38 I don't remember to have run my image to my laptop yet. I'm actually trying to figure out how to make a squashed /lib64 to get rid of definitely of the disk i/o bottleneck.
See this thread https://forums.gentoo.org/viewtopic-t-646289.html for info. Well, I still have to fix splash for kernel 2.6.38, but that's not important. And then I'll update my image and extract it to my notebook disk.
Back to top
View user's profile Send private message
Blue-Sick
n00b
n00b


Joined: 16 Jun 2007
Posts: 12

PostPosted: Sun Apr 24, 2011 7:04 pm    Post subject: Reply with quote

As someone tried ( is it even possible ? ) to run switcheroo with the closed amd drivers ( ati-drivers) and an intel igp?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum