Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]grub error 17
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Mon Jun 21, 2010 7:11 pm    Post subject: [Risolto]grub error 17 Reply with quote

Salve, appena riavvio il sistema e seleziono gentoo ,grub mi dà errore 17, se ho capito bene dalla documentazione ....l'errore è dato da un mancato riconoscimento del filesystem della partizione che gli ho passato in grub.conf.....
Mi pare di capire che grub conta includendo lo zero .
L'ordine delle partizioni sul mio hardisk è
1)Windows partizione primaria
2)linux root partizione logica sda5 con jfs
3)swap partizione logica sda6

windows per grub sarà (hd0,0)
e la root di linux essendo la seconda sarà (hd0,1) giusto?? e la real_root= sarà /dev/sda5
ho messo pure ro per il filesystem jfs

in cosa sto sbagliando?


Last edited by Nio84 on Wed Jun 23, 2010 8:19 am; edited 1 time in total
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Mon Jun 21, 2010 7:55 pm    Post subject: Reply with quote

La prima partizione logica è (hd0,4) indipendentemente da quante partizioni primarie hai.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jun 21, 2010 8:03 pm    Post subject: Re: grub error 17 Reply with quote

Nio84 wrote:

2)linux root partizione logica sda5 con jfs

e la root di linux essendo la seconda sarà (hd0,1) giusto??

no.
concordemente con info grub->namingConventions, dovrebbe essere (hd0,4).

Hack, battuto sul tempo
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Mon Jun 21, 2010 8:10 pm    Post subject: Reply with quote

Ah capito quindi conta da zero a partire dai numeri sda..... pensavo in base alla posizione....Grazie
Back to top
View user's profile Send private message
bi-andrea
Apprentice
Apprentice


Joined: 09 Mar 2010
Posts: 171
Location: cesenatico

PostPosted: Tue Jun 22, 2010 9:26 am    Post subject: Reply with quote

riesci a bootare ora?
_________________
Quando arrivi a Linux è un trauma, abituati a Windows, quando arrivi a Gentoo è uno spavento col brivido , però quando lo capisci sei uscito dall'università "GNU/Linux" ;)
Back to top
View user's profile Send private message
Nio84
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2009
Posts: 140

PostPosted: Tue Jun 22, 2010 11:12 am    Post subject: Reply with quote

Si grazie ho corretto. :D
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Tue Jun 22, 2010 3:45 pm    Post subject: Reply with quote

quando si risolve il problema sarebbe opportuno aggiungere il tag risolto al topic ;)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum